Jump to content

T410 Maveriks Expresscard not full working


Recommended Posts

Hello everybody.

 Have just arrived to this forum because have installed Mavericks on my Lenovo T410 with Intelhd graphics folowing this tutorial:



 I tried with Mountain Lion but didn´t work (maybe the  Extra don´t know), but Mavericks works fine.


 I have this card for FW800 that´s fully working on windows,


When I plugged hot or even before restarting (tried both) can see it on the top bar, but it doesn´t detect devices from the FW800.

 On system hardware I can see the main Fw400 firewire integrated one (Ricoch chipset) that doesn´t work well on windows. Couln´t try it on Mavericks because my device is FW800, so need to buy a cable, but maybe a waste of money, since isn´t fast enouth on windows I doubt will work well on Mavericks.


  Any suggestion that I could make Maverkiks "see" the FW ports of the Expresscard?, the card is detected and I even can shutdown it from the top bar, but the Fw800 ports are not detected, so I guess it must be added manually maybe?

 Thanks in advance.

 Any suggestion will be wellcome.

Link to comment
Share on other sites


 I installed Mavericks 10.9.1 that seems have some kext problems with expresscard on some 2010 models (even on mac).

 So I found this thread:



 Page 3, last post, nasachusetts  user put this link  that´s an intaller/unistaller that solves it.

 Seems that it was solved on Mavericks 10.9.2 (but I didn´t tried it yet).

 For now I´m having now full working the two FW800 of my expresscard on my Lenovo T410, intel hd graphics and Mavericks 10.9.1 with this installer driver.

 Hope it helps.

Link to comment
Share on other sites

  • Create New...