Jump to content

Black screen after reboot OS X Yosemite 10.10.4 latitude E6520


Winstun
 Share

Recommended Posts

Hi there

spec: Dell Latitude E6520 i7-2640m Intel HD 3000 2nd Gen Sandybrigde. "NO Nvidia card"

My Problem is i cannot get into desktop, black screen on everything i've tried.

What i have tried and done: Making Bootable USB with Chameleon

Done Bios Load Default and only chance SATA to ACHI "apply"

i have install OS X 10.10.4 on my harddrive and made diskutil cs revert in terminal.

Booted up with all these in different combinations: DSDT=0 -x -v -f DarkWake=0 EnableDualLink=Yes GraphicsEnabler=No kext-dev-mode=1 nv_Disable=0 PciRootUID=0

i have also tried to chance code info.plist AppleIntelSNBGraphicsFB.kext so it would support Intel HD 3000 from C to E
<key>IOPCIPrimaryMatch</key><string>0x1E3A8086</string>

And checked AppleIntelframebufferCabri.kext info.plist i should b a "C" 
<key>IOPCIPrimaryMatch</key><string>0x1C3A8086</string>

I have tried to copy my extra folder from USB to Install drive in terminal like this:

cp -R /Volumes/OS\ X\ Base\ System/Extra /Volumes/Msk\ Mac/Extra
i says: usage : cp -R -H -L -P -fi -n -apvx source_file target_file cp -R -H -L -P -fi -n -apvx source_file ... target_directory

btw when boot is finish and black screen is up, i can tell you Fn+F1 = sleepmode and Fn+up and down arrow control brightness are working 

And with an other version of Chameleon and a mixed up folder with 2 different bootpacks it worked to get into desktop 4 times but did not know what to back then. And it automaticly booted into safemode but with this info i will only make it clear that it is possible to make it to work

I can only think of a Graphic kext that i may need ore a specifik version of a kext that needs to be rebuilded 

 

Have to say all this work is thanks to "Jake Lo"

post-80915-0-92436200-1438945456_thumb.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...