Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 07/27/20 in Posts

  1. 2 points
    Success: HP840 G3 with DW1830 Works: Sleep / Wake SD card reader Internal speaker / Headphone Keyboard / Touchpad Ethernet / Wifi (replaced with DW1830) DP video / Audio USB 3.0 Ports VGA (not tested, don't care for it)
  2. 1 point
    I'm not familiar with Chris1111's installer but do remember Pokenuygen has a Probook Installer back in the days. I did the build the vanilla way, using createinstallmedia command to create the installer and adding the EFI OpenCore boot files files. Hotpatched SSDT are based mainly from Rehabman's GitHub. There's a strange issue where the internal drive is not detected by Big Sur but no issue with Catalina and below using the same files. A member in Insanelymac also had this very same issue who also has an HP. He has a newer model that has an I2C touchpad, so in adding support for the touchpad, he discovered that it also enabled the Internal drive to be detected by Big Sur. So even though the Elitebook 840 G3 doesn't have an I2C touchpad, enabling that driver does indeed enable the Internal drives to be detected by Big Sur...I'm still scratching my head around that but hey, as long as it works. Currently the TrackPoint is not working, touchpad works just fine with Rehabman's voodoops2Controller, but no multitouch gestures. I'm currently looking at this new kext call VoodooSMBus + VoodooRMI, that's suppose to give better support. This model is suppose to be supported according to the description. We'll see how it goes.
  3. 1 point
    I do know from my experience that the HP Pro Books and Elite books are some of the easiest hacks out there. Chris1111 has done a lot of work creating the Pro Book installer, which he did update to work with BS and OC. What Open Core method did you use? Just did a quick google search and that is one very popular Hack-Book. That is why I really like HP.
  4. 1 point
    Here you go E5450_BS_Ready.zip
  5. 1 point
    @Jake Lo Hey man I thought I'd let you know I you are the best -- stumbled upon your config here and used it for Catalina, eons more than the progress I had made so far. I really appreciate it
  6. 1 point
    @mtviewer That file is a bit outdated. Make sure to install latest Clover v5119, v5120 still have some glitches Replace the attached contents into /EFI/Clover and try again Post screenshot of KP if you encounter it. Make sure to set BIOS accordingly. See Hervé's Latitude 7490 BIOS settings. E7480_HD520.zip
  7. 1 point
    Thank you very much as I was able to get it to boot on my M6700 and my E6540 which are completely different laptops but I have been trying for days without luck but now with your OC folder, I able to boot it on both!!! THANK YOU!!! I usually never install to /L/E, I just put it in kexts but I guess I will need to put in /L/E now. Thank you for all of the hard work, very much appreciated!!
  8. 1 point
    @fabio64370 I have M4800 with AMD M5100, I am not sure it has the same your configuration. You can try my EFI, wifi does not work, I buy Atheros 9380 wifi card. Duc Cao. EFI_5116_MBP2016.zip
  9. 1 point
    It really depends on which generic USB3.0 kext you use but, yeah, not seeing the card listed as USB3.0 controller in SysInfo->USB section is to be expected in Catalina. However, that's not indicative of the EC controller not working. I've posted a copy of the kext I use in the other thread published in this section. If you appear to have reached the limit of USB port numbers, apply the patch that lifts it. Check what is listed in SysInfo->PCI and lookup your IOReg with IORegistryExplorer app. You may post a zipped copy of your saved IOReg. What computer are you using?
  10. 1 point
    @DeLaGhetto You must be big fan of The Fresh Prince of Bel-Air I just uploaded new files that'll run on Big Sur as well. No issue upgrading Catalina to 10.15.6 https://osxlatitude.com/forums/topic/13155-solved-e7440-no-usb-port-working-with-opencore/?do=findComment&comment=101900
  11. 1 point
    Here's the files I use, no issue with sleep / wake Disable the DW1820a in the Config if you have other wifi devices E7270_OC.zip
  12. 1 point
    @bebetoalves You incorrectly added the injection for graphics. Try this config. Fixed injection and added the patch Hervé mentioned config.plist.zip
  13. 1 point
    Better later than never... As explained in past system/model-specific threads, there are further patches that may be used to modify the framebuffer memory size (useful on Latitude E6x30) and the VRAM allocation (nice to increase). Those parameters are defined in the 2nd line of the sample Capri layouts we've illustrated throughout this thread (bearing in mind the reversed byte order of kexts' binary code). For instance: LoRes mobile layout 0x01660003: 03006601 01020402 00000004 00000001 00000060 10070000 HiRes mobile layout 0x01660004: 04006601 01030101 00000002 00000001 00000060 10070000 Desktop layout 0x0166000a: 0A006601 00020302 00000002 00000001 00000060 10070000 Desktop layout 0x0166000b: 0B006601 00020302 00000002 00000001 00000060 10070000 1) Framebuffer memory size: This is defined in the 4th 32bit parameter of the layouts. Default value is 0x01000000 (reversed code 00000001), i.e. 16777216 in decimal which, when divided by 1024*1024 (=1MBytes), equates to 16MB. Some laptops such as the Dell Latitude E6x30 models suffer from corrupt/garbled display on screen unless this value is reduced to 8MB, i.e. 0x00800000. The patch required to change this is: Find: xxxxxxxx [...] xxxxxxxx 00000001 xxxxxxxx [...] xxxxxxxx Replace xxxxxxxx [...] xxxxxxxx 00008000 xxxxxxxx [...] xxxxxxxx For instance, to reduce the FB mem. size of layout 0x01660003 to 8MB, use this patch: \/\/ Find: 03006601010204020000000400000001 Replace: 03006601010204020000000400008000 /\/\ 2) VRAM allocation: This is defined in the 5th 32bit parameter of the layouts. In most recent versions of OS X/macOS, the default value usually is 0x60000000 (reversed code 00000060), i.e. 1610612736 in decimal which, when divided by 1024*1024 (=1MBytes), equates to 1536MB (i.e. 1.5GB). This is shared memory and systems with, say, 8GB of RAM, may want to increase this. The patch required to do this is: Find: xxxxxxxx [...] xxxxxxxx 00000060 xxxxxxxx [...] xxxxxxxx Replace xxxxxxxx [...] xxxxxxxx 000000YY xxxxxxxx [...] xxxxxxxx -> where YY = desired VRAM Qty Reminder: 256MB = 1000 0000 in hex 384MB = 1800 0000 in hex 512MB = 2000 0000 in hex 768MB = 3000 0000 in hex 1024MB = 4000 0000 in hex 1536MB = 6000 0000 in hex 1792MB = 7000 0000 in hex 2048MB = 8000 0000 in hex For instance, to increase VRAM allocation of layout 0x01660003 to 2048MB (i.e. 2GB), use this patch: \/ Find: 0300660101020402000000040000000100000060 Replace: 0300660101020402000000040000000100000080 /\ Naturally, those framebuffer modifications can be combined in a single patch. For instance, to reduce FB mem. size to 8MB and increase VRAM to 2GB, layout 0x01660003 is patched as follows: \/\/ \/ Find: 030066010102040200000004000000010000006010070000 Replace: 030066010102040200000004000080000000008010070000 /\/\ /\
  14. 1 point
    Dear All, Managed to install Beta 3. Apparently the installer app downloaded via Software Update is bad. Redownloaded the app via terminal method as mentioned in earlier post.
  15. 1 point
    Dear All, Beta 3 has been released. vsmcgen=1 boot flag is required to boot. So far managed to enter installer but exited premature. Still investigating the problem and will report back.
  16. 1 point
    It had not been that difficult to install OS X/macOS on a Hack for years. Apple have really gone to great lengths to modify their OS this time. We've not tried to duplicate the work engaged at InsanelyMac (and other forums) here. At this particular stage , OpenCore 0.6.0 is required on all systems. Clover not ready yet, if ever... And, despite OC 0.6.0, BS still requires much tricks and preparatory tuning before it can be installed and run on a Hack. Also, given the level of bugs in BS b2 to date, I'd wait for a (long) while if I were you. To me, it's not worth it at the moment and what's the rush anyway? Patience, I'm sure a suitable general installation method will be developed in time.
  17. 1 point
    @ahalol Depending on which version you're using, it might not have the sleep/wake fix. The version known to work after sleep is R6 found on the 1st page
  18. 1 point
    Hi Friends Install macOS Catalina on Dell Latitude E6440. Install with my uploaded EFI.zip. if problem with USB Ports, Block GenericUSBXHCI.kext in Clover. USBInjectall.kext and USBinjecter.kext not worked for me. SSDT.aml is Already Present in ACPI Patched Folder for Solved the USB ports Problem in macOS Catalina 10.15 Beta. I updated my Bios version to A-23 I Attached my EFI.zip and After install.zip Folders. and Pics Also. EFI.zip After Install.zip
  19. 1 point
    Can't expect stuff to work if you're using files for another model. Try this, replace contents into /EFI/Clover 7480_HD520.zip
  20. 0 points
    @Tinhcdmt13 At OC boot screen, select Reset NVRam and then try again. If you don't see the option, the press spacebar to review the option
This leaderboard is set to Amsterdam/GMT+02:00
×
×
  • Create New...