Jump to content

a219810

Members
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

1 Neutral

About a219810

  • Rank
    Private First Class

Recent Profile Visitors

967 profile views
  1. Hi Cyclib, I have the same exact laptop as you do. What version of OS X are you trying to run? I found that 10.10.5 is completely different than 10.10.3. I get the same error as you when trying to boot into OS X. My solution for that error message is to boot using Clover using the NullCPU kext. This kext will tell OS X to bypass the AICPM kext which is where your laptop is crashing. Once you are at the desktop, you will have to patch your AICPM kext using this guide: http://www.insanelymac.com/forum/files/file/132-aicpmpatch/ Since you have Sandybridge, you DO NOT have to do the extra steps that other guides tell you to do.
  2. Thank you for your suggestion. I will report back shortly with a progress report.
  3. I got it working with Chameleon. Here's a list of my progress. Once everything is in order I'll look into switching to Clover. Anyone have ideas on how to fix the last few issues? I suspect those require DSDT edits. Dell Precision M4600 WORKING Intel Core i7 2820QM @ 2.3Ghz Sandybridge | Native Power Management / Speed stepping 8GB DDR3 RAM | Recognized but shows 0 Hz for RAM Speed - cosmetic? OCZ ARC 100 240GB SSD | Works OOB 320GB TOSHIBA HDD | Works OOB NVIDIA Quadro 2GB 10000M | Working Full QE/CI but only 1GB showing - cosmetic? Intel HD 3000 | Disabled by disabling Optimus Alps Touchpad | Voodoo PS2 Controller Kext from Jake Lo's HP 8560w pack. Multi-touch is a little wonky. Intel 82579LM Gigabit Ethernet | Apple1000e kext from Jake Lo's HP 8560w pack Intel Centro Ultimate N6300 AGN Replaced w/Azurewave AW-CE123H - use toleda's guide 2xUSB 2.0 | Works OOB 1xUSB2.0/eSATA | Works OOB (USB), haven't tested eSATA 2xRenesas USB 3.0 | Generic USB Kext from Rehabman's Repo FW 1394 | Recognized but haven't tested Battery Indicator | Rehabman's Battery guide + Voodoo Battery kext Brightness Keys/Volume buttons | Works OOB NOT WORKING HDMI | Haven't tested VGA| Haven't tested O2 SD Card Reader Express card Port | Haven't tested Mini Display Port | Haven't tested Microphone Shutdown Reboot Sleep/Hibernate Lid-close sleep ANNOYING -"Rebooting" seems to disable the BCM94352 wifi card and the only way to fix it is by doing a full shutdown and power on.
  4. Yes there is an EFI folder in the root of the USB stick and it is reading that one but it cannot navigate past that directory. I switched to a legacy Clover USB installer and that loaded fine. I had to use "nv_disable=1" in my boot args to get the installer to load but now I have zero graphics lol. I think it's a limitation of the BIOS that it cannot boot EFI partitions from USB sticks.
  5. I still get the same error above in the dropbox pictures and I re-did the USB installer guide. For some reason the BIOS utility cannot read the EFI partition on the USB stick or navigate past the "EFI" folder. I checked it in Ubuntu and it is indeed formatted to FAT32.
  6. I'm trying to install OS X Yosemite on my workstation using Clover UEFI as the bootloader. I used this guide to create the USB installer: http://www.insanelymac.com/forum/topic/305255-making-a-yosemite-usb-installer-w-clover-uefi-and-legacythe-correct-way/ The problem is when I'm setting up the UEFI BIOS to boot from the USB. I cannot navigate through the EFI partition on the USB stick to select the "CLOVERX64.efi" file to add to my boot options. I get these weird font errors when I try: https://www.dropbox.com/sh/luchxh7437m9ylg/AAA1940HujKI8d_NQElzKMjqa?dl=0 I was able to get the UEFI BIOS to navigate the EFI partition on my hard drive to select the "Windows" .EFI file and that boots just fine. Any idea why I can't select the one on the USB installer? WORKING! I'm using Chameleon for the time being since it's easier. Dell Precision M4600 WORKING Intel Core i7 2820QM @ 2.3Ghz Sandybridge | Native Power Management / Speed stepping 8GB DDR3 RAM | Recognized but shows 0 Hz for RAM Speed - cosmetic? OCZ ARC 100 240GB SSD | Works OOB 320GB TOSHIBA HDD | Works OOB NVIDIA Quadro 2GB 10000M | Working Full QE/CI but only 1GB showing - cosmetic? Intel HD 3000 | Disabled by disabling Optimus Alps Touchpad | Voodoo PS2 Controller Kext from Jake Lo's HP 8560w pack. Multi-touch is a little wonky. Intel 82579LM Gigabit Ethernet | Apple1000e kext from Jake Lo's HP 8560w pack Intel Centro Ultimate N6300 AGN Replaced w/Azurewave AW-CE123H - use toleda's guide 2xUSB 2.0 | Works OOB 1xUSB2.0/eSATA | Works OOB (USB), haven't tested eSATA 2xRenesas USB 3.0 | Generic USB Kext from Rehabman's Repo FW 1394 | Recognized but haven't tested Battery Indicator | Rehabman's Battery guide + Voodoo Battery kext Brightness Keys/Volume buttons | Works OOB NOT WORKING HDMI | Haven't tested VGA| Haven't tested O2 SD Card Reader Express card Port | Haven't tested Mini Display Port | Haven't tested Microphone Shutdown Reboot Sleep/Hibernate Lid-close sleep ANNOYING -"Rebooting" seems to disable the BCM94352 wifi card and the only way to fix it is by doing a full shutdown and power on. EDIT1 6/6/2015: I'm attempting Mavericks for now using the myHack method and the "Extra" folder from page 2 of this thread: https://osxlatitude.com/index.php?/topic/5558-extra-folder-for-m4600-setup-for-os-x-mavericks-setup/page-2&do=findComment&comment=50393 I have the same hardware configuration as thanhphongasd. I have Optimus disabled. Booting with -v -f -x GraphicsEnabler=Yes results in a black screen after "[iOBluetoothHCIController][start] -- completed". EDIT2 6/6/2015 *Extracted DSDT and SSDT in Ubuntu. *Attached raw DSDT/SSDTs, decompiled DSDT/SSDTs, and edited DSDT/SSDTs. See edit_log.rtf for info. *I did not apply any patches. EDIT3 6/7/2015 *Changed Clover on my Yosemite Insaller from UEFI to Legacy and now it properly loads. *Encountered black screen after [iOBluetoothHCIController][start] -- completed From reading around the forums this seems to be a video card issue. Disabling nvidia injection (from Clover Option menu) and booting with nv_disable=1 and nvda_drv=1 args works! But the graphical installer is extremely buggy in terms of animations. Will report back once I get this installed. EDIT4 6/7/2015 No internal hard disks are detected with Disk Utility using Clover... no idea at this point. So in the Dell BIOS, the SATA option "Raid On" is supposed to support both RAID and AHCI. As it turns out, switching "Raid On" fixes the disk issue and now everything shows up under Disk Utility. I have switched Raid On to AHCI before in the past and that always borked my Windows installation. Oh well. I'll fix it later. >_> EDIT5 6/7/2015 Fixed the Raid to AHCI switch on Windows. Yosemite installed and boots up with full QE/CI on Quadro 1000M with EnableBacklight=Yes GraphicsEnabler=Yes flags. Only 1GB of VRAM shows up (out of the 2GB) but that may be a cosmetic issue. I'm not too concerned right now because Yosemite is really smooth now. EDIT6 6/8/2015 Ordered new wifi + BT card ->Azurewave CE-123H. It should be coming in today. It's basically a Dell 1550 wifi card which Dell has confirmed to be working on the M4600. Will report back later. raw_dsdt_ssdt_aml.zip decompiled_dsdt_ssdt_dsl.zip edited_dsdt_ssdt.zip
  7. The E6420 does not have USB 3.0, 1080p LCD, swappable graphics (the M4800 GFX card is compatible w/M4600), or Quad i7 w/HT. Don't get me wrong. The E6420 is a great notebook but it lacks so many things that I'd want in a laptop in 2015. Regardless, I think the E6420 even beats some of the newer MBPs and I'd definitely recommend it for a budget Hackintosh.
  8. I went with the Dell Precision M4600. The E6420 is a great notebook but I personally think it's too old for 2015. The E6430's price is around the same as the M4600, but the M4600 has better specs. I'll be working on getting Yosemite working on this thing. Thanks for the feedback Jake Lo!
  9. All of these have the nvidia card. I intend to swap out the HDD for an SSD. They are all Grade A but the E6430 has a 768p display. A 1600x900 display replacement costs ~$53. Generally the E6420 w/4GB, i5 costs $250 refurb and E6430 w/4GB i5 $350. I'm coming from a 7 year old HP Pavilion C2D and I'm hoping to make one of these Dell Latitudes a daily driver for at least 5 years. What do you think?
  10. Would it be worth picking up a refurb Dell E6420 on Newegg to Hackintosh? Or would it be better to jump to the E6430 since that model is a generation newer? A Dell E6420 refurb goes for about $250 on Newegg with the lowest specs and a Dell E6430 is $100 more.
×
×
  • Create New...