Jump to content

Gigabyte H81M DS2 + i3 4330 + HD7750 - Sierra / High Sierra / Mojave / Catalina / Big Sur / Monterey


Syonagar
 Share

Recommended Posts

  • Administrators

Hi all,

 

Just built my first budget desktop hackintosh and pleased to share the bootpack.

 

Specification

 

Gigabyte H81M DS2

 

4th Gen 3.5 GHz i3-4330

 

8 GB DDR3 1600 MHz Memory

 

Intel Graphics HD 4600

(Working but unusable. See notes below.)

 

AMD Radeon 7750 1GB

(See other post here https://osxlatitude.com/forums/topic/11048-amd-radeon-hd-7750-supported-by-mac-os-mojave-catalina/)

 

Note: This bootpack should also be compatible with any supported 4th Gen Intel CPU on H81 Intel Chipset Motherboard.

 

OpenCore Bootpack

 

The OpenCore bootpack can be downloaded from the following link:-

 

  • macOS Monterey 12 Beta (21A5248p)  (OpenCore 0.7.0):-
    • OpenCore-12-Beta-0.7.0.zip
    • Updated all kexts to latest versions
    • Changed SMBIOS to Mac Mini Late 2014 as Intel 4th Gen Haswell iMacs no longer supported

 

 

 

 

 

 

 

 

       (Note: These bootpacks can also be used to boot macOS Catalina)

 

Clover Bootpack

 

The Clover bootpack can be downloaded from the following link:-

 

  • Mac OS Monterey 12 Beta (21A5248p) (Clover v5135)
    • CLOVER-11.3.1.zip
    • So far installer and new install booted nicely with this boot pack after six restarts lol

 

 

 

 

 

  • Mac OS Catalina 10.15 (Clover v5070) :-

 

  • Mac OS Mojave 10.14.4 (Clover v4910) :-

 

  • Mac OS Sierra 10.12.6 / Mac OS High Sierra 10.13 (Clover v4241) :-

 

Credits goes to Jake Lo, Bronx Teck & Herve 

 

Notes on Big Sur 11.3.1 (OpenCore & Clover)

 

(1) So everything should works.

(2) Updated all kexts to latest version.

 

Notes on Big Sur 11.0.1 (OpenCore)

 

(1) This bootpack is able to boot Mac OS Big Sur Beta 10. However, it is still getting issue where installer will exit prematurely after starting. If anyone managed to resolve this issue do give me a buzz. Found the cause of installer exiting prematurely after start. Its a hard disk issue. Also had issue similar issue when installing windows on the same hard disk.

(2) So everything should works except sleep. integrated graphics need to be disabled in bios in order for sleep to work (i.e. no desktop freeze after wake).

(3) Updated all kexts to latest version.

 

Notes on Big Sur Beta 4 (20A5343i) (OpenCore)

 

(1) So far everything works except sleep. System freezes after wake.

(2) This bootpack is based on latest OC and lilu & friends kext release based on OC 0.6.0

 

Notes on Big Sur Beta 2 (20A4300b) (OpenCore)

 

(1) So far everything works except sleep. System freezes after wake.

(2) This bootpack allow both updating of existing beta 1 to beta 2 and installing new hard drive by running the installer app from an existing Mac OS system.

(3) USB installer created from createmediainstall still cannot be booted. Resolved. As @Jake Lo advise, with latest lilu we can omit "-lilubetaall vsmcgen=1 booter-fileset-kernel booter-fileset-basesystem" stuff. Make sure to reset nvram on first OC boot and boot the usb installer on reboot. However, looks like "booter-fileset-kernel & booter-fileset-basesystem" need to be remove when booting usb only and 1st stage installation. 2nd stage looks like it still need those to boot.

 

Notes on Big Sur 11.0 Beta (20A4299v) (OpenCore)

 

(1) USB installer still cannot be booted using clover or opencore. Big Sur need to be cloned from existing real mac disk image.

(2) So far everything works except for sleep.

(3) Downloaded the real mac disk image and followed installation guide from here: https://www.olarila.com/topic/8977-guide-installrestore-bigsur-with-opencore/

(4) Initial bootpack for OpenCore obtained from here: https://www.reddit.com/r/hackintosh/comments/fuf6z7/open_core_056_catalina_10154_gaz87mxd3h_i74770/. Updated network card kext from my clover bootpack and updated OpenCore to version 0.6.0.

 

Notes on Catalina 10.15.7 (Clover)

 

(1) Updated Clover and kexts to latest versions.

(2) Clover is already using the Quirks features which are normally required for Intel 4th Haswell desktops.

(3) Clover bootpack is able to boot Mac OS Big Sur 11.0.1 after it has been installed. Still not able to boot installer. 

 

Notes on Catalina 10.15.4 (Clover)

 

(1) Updated Clover, Lilu.kext, VirtualSMC.kexts & Whatevergreen.kext to latest versions.

 

Notes on Catalina 10.15.1 (Clover)

 

(1) Whatevergreen.kext updated to 1.3.4 to resolve blank screen after boot.

 

Notes on Mac OS Sierra 10.12 / Mac OS High Sierra 10.13 / Mojave 10.14 / Catalina 10.15 (Clover)

 

(1) So far, everything works including sleep with power nap! So far this motherboard is very compatible with Mac OS and patched DSDT / SSDT is not required.

 
Notes on Integrated HD4600 GPU
 
(1) Although the integrated HD4600 GPU can be enabled by simply injecting intel from clover, the GPU cannot be utilized since the motherboard does not have a HDMI output! Using dedicated GPU such as RX 560 while the integrated HD4600 GPU is enabled may cause video playback in chrome to be jibrish and iTunes video playback to freeze the desktop. The integrated GPU need to be disabled from bios to resolve this.

 

Let me know if the clover bootpack works for you.

 

Cheers!

Edited by Syonagar
Support for Mac OS Monterey 12 Beta (21A5248p) (OpenCore & Clover)
  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...