Jump to content
black.dragon74

[UPDATED] [Nov. 2017] Fix BTFirmwareUploader in macOS High Sierra

Recommended Posts

Thank you for a great solution, it works with my Dell DW1707 Atheros 9565 card.

The virtual machine based on Ubuntu takes up to 4++ GB disk space and 30s to load, I found it too expensive to just enable a bluetooth card.

After several days of research, I found a way to prepare a very tiny (40 MB) and very fast (10s load) virtual machine that load firmware to atheros card. The solution is based on Tiny Core Linux. Here is how:

1. Download CorePlus from website

2. In VMWare, create a virtual machine:

- Use the downloaded CorePlus ISO file.

- Template: Linux 4x...

- Config: CPU & RAM: 1 core, RAM: 256 MB, Hard Disk: 1GB, SATA (not SCSI !!!, if SCSI you can not install Tiny Core on HDD)

3. On the first run, install TinyCore following exactly this instruction except for the step when select Install Type you need to select Core and X/GUI Destop and select Wifi Support.

4. After installing, install Bluez extension by the following steps:

4.1 Run Apps (middle icon at the bottom), click App -> Cloud (remote) -> Browser

4.2. Install Bluez:

- Wait a bit, when list of extensions appear, type bluez and Enter in Search text box.

- Select bluez.tcz, wait a bit until detailed information appear. After that, on the bottom left of App Windows, select OnBoot and click Go.

- Wait until bluez is being installed (see attached image).

4.3. Install atheros firmware

- Similarly, install firmware-atheros.tcz.

- Note: in this way, you can install firmware for other manufacturers. Actualy, in step 3, if you select an option to install firmware than all firmware for all manufacturers will be installed, but in this case, the VM size grow up from 39MB to 267MB.

4.4. Reboot virtual machine and you are finished !

5. For lazy people, here is the prepared virtual machine.

 

image001.png

Share this post


Link to post
Share on other sites

New version here: faster boot time (7-8s vs 15s), less size: 25MB vs 39MB

The idea is to remove graphical desktop and wifi support.

 

Steps 1 and 2 are the same as in my previous tutorial.

Step 3: On the first run, install TinyCore following exactly this instruction (for Install Type select Core Only (Text based Interface) and don't select Wifi Support).

 

Step 4 (after reboot to installed OS, the command line appears instead of desktop GUI): Install Bluez and Atheros firmware by the following procedure:

- Run tce-ab command, on the prompt, type S for entering search mode.

- On the next screen, type Bluez as search string.

- All packages containing word "bluez" will appear (there will be three packages).

- Enter the number corresponding to package bluez.tcz

- The content of readme file will appear, type Q to quit, you will be asked for installation mode, type I (i).

- Wait for installation to finish.

In the similar way, install firmware-atheros.tcz package.

Reboot machine by entering command sudo poweroff and you are ready to go.

 

Link to a prepared virtual machine.

Share this post


Link to post
Share on other sites

I made an AppleScript to automatic running virtual machine and connect / disconnect bluetooth to load firmware. See comments at the top of attached script file. 

Now every thing is automatic. You don't need any USB mouse or keyboard to enable bluetooth.

Run TinyCore.zip

Share this post


Link to post
Share on other sites

 @black.dragon74
Thanks for this Virtual machine workaround.
 @tqbinh
Tiny core method and the script running flawlessly. One suggestion, instead of shutting down the machine, if you `Suspend` it, it is much faster. I am using this command to start the VMWare: `vmrun start "/pathtovmware"` I am able to get the bluetooth up and running in 10 seconds with your script and suspending the machine.

Also, please post any updates if there are any for the bluetooth firware uploader.

Share this post


Link to post
Share on other sites
On 10/27/2017 at 11:14 PM, Hervé said:

Old Dell DW3x0 modules were based on CSR chips and worked OOB without the options to turn them on and/or off through the BT icon in the Firnder's bar. Once their ids are added to the CSR transport kext, these options become available... You could try the same, there aren't that many transport PlugIn kext that apply here.

 

Another example with the Intel combo wireless/Bluetooth card in my Latitude E6440. No support for the wireless but the BT module is supported OOB with the generic kexts. There are options to turn it on and off:

Intel _Bluetooth_module.png

Loaded_BT_kexts.png

Transport_kext.png

After several years registered in Osxlatitude I get ready to write my first post. Before I must explain that, after more than ten years with hackintosh, I had no need of it; but I do have to recognize that through the readings in their different forums I have solved numerous numerous problems in the different S.O of mac in these years. 


The purpose of this my first post is, that having verified that your Latitude E6440 has the same Bluetooth HCI - Wireless Centrino N-2230 - than my Tosihba Qosmio Px30t--Imac14,2--, I would like to be able to solve with your help the possibility of fixing at once forever the bluetooth formware, and not having to load Windows 10 or my Ubuntu first. After using various injectors and changes in the DSDT I have not succeeded.


However, in my other Lenovo G50 80--MacBookAir7,2-- notebook that tremble has an Intel / combo, in this case, Wireless 3180, the bluetooth is injected without any previous necessary action, or injectors, ctc.OOB, I think you call it here. The only difference I see in both cases is that Lenovo injects bluetooth into a USB 3.0 port via DSDT and a Toshiba into a USB 2.0 port. I have tried, therefore, that the Toshiba inject the BT into USB 3.0 port, like the other devices, but I have not succeeded, and I do not even know if that is possible. Is this the last and small problem that I still have to solve in my Toshiba Qosmio after 6 years of use
Therefore, I help you to solve this problem, if it has a possible solution.

 

Thank you very much and congratulations for the high level of this hackintosh forum, which has given me so much help in these years.

I am currently at macOS Catalina 10.15.1 beta2

 

Regards.1265382541_Capturadepantalla2019-10-22alas10_36_03.png.3a32b9f01b56937988289711ec9dae7f.png1622554848_Capturadepantalla2019-10-22alas15_08_30.thumb.png.ae016b0bb9377f1251feb8074e0344aa.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...