Jump to content

[SOLVED] Hibernation keeps coming back


viking1304
 Share

Recommended Posts

I have very strange problem. My system goes to sleep without issue if I am on battery, but it wakes up instantly on power adapter. Looks like that cause of the problem is hibernation that keeps coming back.

 

Hibernation was disabled, but somehow it's enabled again?!

System-wide power settings:
Currently in use:
 standbydelaylow      10800
 standby              1
 womp                 0
 hibernatefile        /var/vm/sleepimage
 powernap             0
 gpuswitch            2
 halfdim              1
 networkoversleep     0
 disksleep            10
 standbydelayhigh     86400
 sleep                1
 autopoweroffdelay    28800
 hibernatemode        3
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         10
 Standby Battery Threshold 50
 lidwake              1

 I disabled it again. Let's see will it be reseted again.

System-wide power settings:
Currently in use:
 standbydelaylow      10800
 standby              1
 halfdim              1
 hibernatefile        /dev/null
 powernap             0
 gpuswitch            2
 disksleep            10
 standbydelayhigh     86400
 sleep                1 (sleep prevented by coreaudiod)
 autopoweroffdelay    28800
 hibernatemode        0
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         2
 Standby Battery Threshold 50
 lidwake              1

I was writing the message about sleep issue that I have when I noticed this. I was confused, since there is nothing strange in my log related to Wake reason, and I was sure that my hibernation was disabled.

 

I actually already seen this few days ago and disabled hibernation. I thought I messed something up in some of my experiments, but now I see that this coming back.

 

EDIT:

 

I just remembered that I restored defaults in Energy Saver last night while I was trying to figure out what's wrong with my sleep. That reseted my hibernation to defaults.

 

If you ever reset Energy Saver settings to defaults, you need to disable hibernation again.

 

EDIT 2:

 

Any change in Energy Saver setting will cause restore of default hibernation settings. I just disabled Power Nap and hibernatemode is back to 3.

Link to comment
Share on other sites

 Share

×
×
  • Create New...