Jump to content
PayPal donations: [email protected] ×

Recommended Posts

KAzSnVX.png

Acer Aspire V15 V5-591G - Catalina 10.15.4

 

(Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)

Specifications:

- Motherboard: USOPP_SLS (Skylake-H PCH)

- BIOS: Insyde Corp. v 1.15

- CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)

- GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530

- RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz

- WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)

- Audio: Realtek HD Audio: ALC 255 

- Ethernet: Realtek RTL8168/8111

- Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)

- Webcam: HD Webcam

- HDD: TOSHIBA MQ01ACF032 320 GB HDD

- SSD: KINGSTON A2000 NVMe PCI-e SSD

- Display: 1366x768 (15.6", Matte)

- Battery: 6 cell 56Wh / 5040mAh

- Connectors: 

  • 1x SD Card Reader
  • 2x USB 3.0 (1x USB Charging), 1x USB 2.0
  • 1x VGA
  • 1x HDMI
  • 1x 3.5mm microphone/audio combined jack connector
  • 1x Ethernet (Rj-45)

- Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.

Working:  

- Wi-Fi (with BCM94352Z)

- Bluetooth hand-off (With BCM94352Z)

- Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)

- Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)

- HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch

- Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)

- Ethernet Realtek 8168/8111: RealtekRTL8111.kext

- App Store, Messages, FaceTime, Siri, iCloud (native)

- Integrated webcam (native)

- 3.0 USB (patched SSDT-UIAC.aml)

- Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try remapping in System Preferences (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers

- Battery info

- Sleep Mode

- NVMe PCI-e x4 SSD

- Power Management by SSDT, HWP, PluginType

- Hardware decoding/encoding on HD 530

Not working:

- Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.

- NVIDIA GeForce GTX 950M: Optimus not supported.

- Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"

For Wi-Fi:

- 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it

- 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon

 

Issues:

- None

BIOS Settings:

- BIOS version 1.15 (irrelevant)

- Secure Boot: Disabled

- Touchpad: Advanced

- Boot mode: UEFI

Getting ready for Installation:

Download the install zip (bootpack & postinstall):

Click here for Catalina (v5112)-> Acer-V591G_Cata.zip

Installation:

- Create an installer with any method you know (- Mac: createinstallmedia, gibMacOS - Windows: Transmac, Vmware, Win32diskimager, gibMacOS)

- Copy my Clover folder to the USB's EFI folder

- Boot with the Installer USB

- If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze

 

Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!

On Catalina the System folder is read-only, so you need to remount in rw to modify System/Library, and need to disable SIP (note: try to avoid modifying S/L/E, use Clover/kexts/Other instead)

If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):

->Edit "Frequency" and "Size" to match your RAM values

<key>Version</key>
		<string>1.0</string>
		<key>Memory</key>
		<dict>
			<key>Channels</key>
			<integer>1</integer>
			<key>SlotCount</key>
			<integer>1</integer>
			<key>Modules</key>
			<array>
				<dict>
					<key>Slot</key>
					<integer>0</integer>
					<key>Size</key>
					<integer>8192</integer>
					<key>Frequency</key>
					<integer>2133</integer>
					<key>Type</key>
					<string>DDR4</string>
				</dict>
			</array>
			</dict>
		</dict>

 

 

Elan SmartTouchpad

I only use scrolling, one-, double- & tripletap

If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES

Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).

You can remap Brightness keys in System Preferences -> Keyboard -> Shortcuts/Display (I use "Alt+Shift+←" to decrease, "Alt+Shift+→" to increase) 

 

Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.

Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)

 

Catalina & Windows 10 Dual-Boot:

Dual-boot clean install (on one drive), UEFI Only:

 

  1.  Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac), 
  2.  Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,
  3.  Boot into your Win installer, Format the partition you created for Win, install. 
  4.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi

      5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).

 

IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):

- Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)

 

IF YOU CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):

- It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)

- You also could "mount" the EFI from Windows:

1st method: open cmd in administrator mode and type:

diskpart

list vol (Now select the "System" volume,(FAT 32) For example I select 4)

sel vol 4

list part (Select System type partition, for example 2)

sel part 2

assign letter=b (This will "mount" your EFI partition)

Open Explorer++ or TotalCommander in administrator mode to manage EFI

remove letter=b (This will "unmount" your EFI)

2nd method: open cmd in administrator mode and type:

mountvol b: /s (This will mount your EFI)

Open Explorer++ or TotalCommander in administrator mode to manage EFI

mountvol b: /d (This will unmount your EFI)

Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!

 

 

Useful Applications for Mac:

 

Useful Applications for Windows:

Notes:

2020.04.21: Removed unnecessary/outdated boot-args from config.plist, can boot without any boot-args, updated bootpack

2020.04.20: Removed unnecessary lines from config.plist, fixed USB audio timing issues, updated bootpack, removed Mojave bootpack (outdated)

2020.04.17: Replaced FakeSMC with VirtualSMC because FakeSMC is outdated (to see your frequencies use Intel Power Gadget) -> Updated all necessary kexts, updated Clover to v5112, updated bootpack, enabled SIP (with allowing unsigned kexts), deleted bootcamp theme, moved SmartTouchpad driver to L/E (sometimes scrolling stopped working when used from Clover/kexts/Other)

2020.04.11: changed SATA M.2 SSD to an NVMe SSD -> added to "Working" list, native, no need to change anything

2020.04.06: Removed unnecessary SSDT-*.aml files, added patched SSDT for Power Management, updated Catalina install folder, updated Clover to v5108, removed unnecessary lines from the Guide, removed "Dual-boot on one drive with Windows already installed" because it's outdated, fixed ALCPlugFix for Catalina, Enabled SIP with allowing unsigned kexts

2020.03.26: Updated to 10.15.4 -> updated Lilu, WhateverGreen, updated Clover to v5107 -> updated bootpack

2020.02.11: Updated to 10.15.3 -> no problem when/after installing

2019.12.19: Updated to 10.15.2 -> no problem when/after installing

2019.11.03: Enabled SIP caused a lots of issue, so now it's disabled -> updated bootpack

2019.11.02: Updated to 10.15.1 -> no problem when/after installing

2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far

2019.08.18: Updated to 10.14.6 -> no problem when/after installing

2019.06.01: Updated to 10.14.5 -> no problem when/after installing

2019.04.25: Optimized touchpad scrolling -> updated install files

2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack

2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.

2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 

2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.

2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast)also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).

2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)

2018.12.09: Updated to 10.14.2 -> did without any complication

2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext

2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.

2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working

Edited by kushwavez
Removed unnecessary boot-args

Share this post


Link to post
Share on other sites

×
×
  • Create New...