Jump to content

Help! Newbie with D830 (Intel 1680x1050) with black screen before installation GUI


gosar
 Share

Recommended Posts

Hello @all...

 

after wasting the last 6 nights with endless loops of trying to install lion on my Dell D830 I gladly found this board which deals specially with my kind of notebooks.

In order not to spam unprepared newbie questions here, i tried as best a i can to fullfill the wiki tutorials and read the postings here.

I created a USB pen with osx lion installtion as the wiki described.

I tried some of the supported bootpacks (Dell Latitude D630, Intel graphics --- Dell Latitude D830, Intel graphics (1280x800) --- Dell Latitude D830, Intel graphics (2) (1920x1080)) all with the same result:

The USB booting runs fine.. I fired -v -x (sometimes in variation with GraphicsEnabler=no and PCIRootUID=0) and at the end of the booting process, i shortly can see the grey wallpaper of the installation gui (only grey, nothing else on it) and then my screen went blank. I put an external TFT (1920x1200) to the D830 and tried to switch to the external screen, but there's no picture at all...

 

Where is my fault? Did I missed a step or is the screen resolution (1680x1050) in combination with intel graphic X3100 the main problem?

What can i do to reach the installation gui?

 

Thank you for support...

 

gosar

Link to comment
Share on other sites

Well... after rechecking my bios settings and using the 830 intel 1920x1080 bootpack i finally see the installation gui and now lion is installing..

I'll wait to see if it will survive a reboot ;-)

if yours is anything like mine, it will not boot unless you do a -x.

i had to disable Intel Wifi in BIOS to be able to boot.

i ended actually buying and installing a broadcom wifi.

there's a wifi kext out there (link by Mariusz) for the wifi to actually work.

good luck.

Link to comment
Share on other sites

Gosar, Follow my instructions in creating the Lion Install USB in my Getting Lion To Run on my D530 Within you will see that there are three files that need to be overwritten on the Install USB stick you create so that you when have glitches or freezing when trying to install Lion.

 

https://osxlatitude.com/index.php?/topic/1212-dell-latitude-d530-running-lion-73/

 

Best, Darren

Link to comment
Share on other sites

Thank you all for your posts...

 

Update:

First, the installation processes failed at about 10 min. Looking into the log i saw that the BSD.pkg was corrupt..

So i recreated the boot pen and again put the Intel2 (1920x1080) bootpack extra on it.

Booted with -v (only). Created a single partition of my 80GB Harddrive (this is the old drive) as a Mac OS Extended Journaled filesystem with GUID-partition table.

Installation runs fine.

When rebooting, i only get a blank screen instead of a bootmanager etc.

Even booting with the pen, i can only choose to boot further with the pen. The system installed on harddrive is not listed.

Where is the mistake?

 

nypoet: I will test your instructions soon, but because I'm much further than ever since with the current pen and bootpack, i first wanted to look if there is a way to get the installed lion system to be detected and bootable.

 

Do you have a hint how i could boot the installed system?

 

Thank you.

Link to comment
Share on other sites

A new update...

I recreated the pen, booted USB and then I could choose the lion harddisk installation which booted well..

But... I have to connect an external mouse, the internal touchpad isn't recognized.

No network device has been detected.

As I activate my onboard lan in bios, i can't boot lion because of a kernel panic..

I also do have a Nec Aterm WL54AG Atheros PCMCIA card which I could use for wifi connections.

I'm not firm with this kext-things (<-Newbie)...

 

So a few questions:

 

1) How can i manage to install only the bootloader on harddisc again so i could boot lion without the usb pen?

2) What could i do to let lion recognize my D830 Keyboard and Touchpad?

3) Is there a way to get wifi with the builtin wifi card or do i have to use an external card like my atheros card?

Ovi1: Do you have a link to that "link by Mariusz"?

 

Thank you very much..

Link to comment
Share on other sites

Since I couldn't change the title of this topic and I could install lion with the gui, i will open a new topic for further questions after a fresh install of lion on my D830.

This thread could be closed because the problem described in the title is solved.

Thank you...

Link to comment
Share on other sites

 Share

×
×
  • Create New...