Jump to content

Dell Latitude D620 can't find mach_kernel


Recommended Posts

I've been trying for about 3-4 days now, always getting the exact same error. I'm using the newest Myhack, and a 10.7 lion dgm. Every single time I have tried to boot into my flash, it will give me the loading screen, then says "can't find mach_kernel." I'm pretty much a beginner at macs altogether, and have been trying to get this working for a friend. If there is any other information you need, let me know.

Also, I've been following the Myhack guide, and also the osx latitude pen installation guide. Neither have helped. Currently my OS is ubuntu 11.10, and I'm borrowing a macbook pro for all the usb handling.

Link to comment
Share on other sites

  • Administrators

Hi Sabata,


Myhack should have copied the mach_kernel to the usb installer. You can manually copy the mach_kernel from the install app to the installer usb by:


(1) From Finder, right click the install app and pick 'Show Packages Contents'

(2) Goto Contents/ShareSupport and mount the InstallESD.dmg by double clicking it

(3) Open Terminal app, type 'sudo su' and enter your password

(4) Type 'cp /Volumes/'Mac OS X Install ESD'/mach_kernel /Volumes/'USB'/ (replacing USB with the label of your lion usb installer)

(5) Close Terminal, reboot and try to boot the lion usb.



Link to comment
Share on other sites

  • Create New...