Jump to content
PayPal donations: [email protected] ×
edydanila96

Dell 3480 Catalina issues

Recommended Posts

Hello,

I searched your whole forum and I couldn't find the kexts for my model,

So I got the ones from another lattitude but I have lots of issues (sleep, HDMI, Touchpad, wireless)

MY system is i5 7500, 8gb ram ddr4, 256 m.2 2280 ssd, Qualcomm qca61x4a

I tried running the gen_debug but due to Catalina read only implementation I cannot move it to usr/bin

Find my clover attached.

Please help.

Eduard.

CLOVER.zip

Share this post


Link to post
Share on other sites

Looks like you're using files from gengstapo, files looks good

 

HDMI - HDMI patch is in place for port 105. Post new IOReg file or debug file with HDMI monitor plugged in

Touchpad - According to the IOReg file, it's loaded and working. Check the preference pane

Wireless - Your Qualcomm is not supported. Replace with supported device like DW1560, DW1820a or DW1830. Stay away from Atheros...Catalina had dropped support.

Sleep - Disable hibernation. Run from Terminal

  • sudo pmset hibernatemode 0
  • sudo rm -f /var/vm/sleepimage
  • sudo pmset hibernatefile /dev/null

Share this post


Link to post
Share on other sites

21563.zipEvery time I connect the HDMI to the laptop the system crashes.

And the touchpad works intermittently.

I had to start the laptop with the HDMI connected to the laptop to be able to use the laptop and even then the screen is not showing in the setting or either showing anything on the screen.

After the system crashes and I restart I get the error why the system crashes.

I added the zip and the debug with the hdmi in.

 

error.zip

Share this post


Link to post
Share on other sites

What ACPI error, post screenshot.

Are you connecting HDMI to HDMI? What resolution?

or HDMI to USB-C adaptor or Thunderbolt

Share this post


Link to post
Share on other sites

Right, I managed to fix my touchpad by using gengstapo's kexts and I tried using his config list in my EFI and my HDMI works but the touchpad isn't so I put my config list back.

 

I included gengstapos config list, mine and the screenshot with the ACPI error.

Thanks so your help, I appreciate it.

Eduard.

IMG20200227192004.jpg

gengstapoconfig.plist.zip MYconfig.plist.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...