Jump to content
PayPal donations: [email protected] ×
calutron

Lenovo T470s: Battery Status on OpenCore 0.5.9

Recommended Posts

Hi all. 

 

I've manage to install OSX Catalina 10.15.5 on a Lenovo T470s and have it mostly functioning. The one thing I can't solve is the battery status. Let me explain

 

1. The battery status icon only sits at 0% and never updates on OpenCore

2. I have to use ACPIbatterymanager.kext for the the status indicator to even appear. Furthermore if I load SMCbatterymanager.kext instead I get a series of errors show in the included picture. 

3. The same kexts when used in Clover are able to show some battery status, including charging even though even then it's not perfect. 

4. I've tried every combination of kexts and SSDT's that I can find lying around but none of them fix this problem. 

 

Configuration:

 

Lenovo T470s

Intel Core i5 6300u

1 TB HPEX920 NVMe SSD

12 GB of RAM

 

 

Git Repo with current EFI: https://github.com/Elemiel-K/Opencore-T470s

 

Any help or advice would be appreciated. 

 

IMG_3473.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...