Jump to content

Optiplex 5040: graphics issue, can't boot


mefflecakes
 Share

Recommended Posts

Hi all

 

I've been happily using my Optiplex 5040 (skylake, 16gb ram, Intel HD530) with big sur installed, although now when I boot, I see the apple logo and the screen goes blank with no DP or HDMI signal and I can't do anything but force power off.

 

I decided to make a fresh efi/installer with OpenCore 0.6.5 as I had a strange suspicion that this could be related to an OS update.

 

I've attached 2 pictures, one where you can read the text and the other one is about a minute later, with what I assume is a kernel panic.

 

If I use my newly created usb to boot to the opencore menu, then select the SSD-installed OS, it just boots with the blank screen as described in the first line of this post.

 

Really not sure what I can do here, any ideas would be appreciated.

 

PXL_20210202_153748600.MP.jpg

 

PXL_20210202_153841315.MP.jpg

 

EFI.zip

Link to comment
Share on other sites

  • Administrators

As always, please post your detailed system's specs or add them in signature. We're in the dark without those!

 

Difficult to make much out of those screenshots. KP seems to happen after "Still waiting for root device" which would suggest USB-related issue. You've placed USBInjectall in your kexts folder but you're not injecting it in your OC config, so...

 

Please note that I'm pretty certain you're injecting the wrong ig-platform-id for your HD530 iGPU, usually it's just 0x19120000. You may refer to this InsanelyMac thread for reference. Injecting iGPU device-id may not be required either but it'll depend on the specifics of your CPU, so no further comment possible in the absence of detailed specs...

 

I also suggest you follow the guidance posted at Dortania for Skylake desktop so that you have an ideally configured system. Good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...