Jump to content

D520 post install EDP problem


Recommended Posts

Hi all,


I'm new here so first up let me say thanks for a great website with an awesome set of tools and guides.


Following the instructions here I've just installed Snow Lion on my Dell Latitude D520. The install went without error and I was able to boot into OSX from the hard disc without any problem. However, following the post-install guide I ran the EDP app and it broke something so the laptop would no longer boot without the -x switch at the bootloader. I tried running myFix from the myHack USB drive but this didn't help. I deleted the partition and ran the myHack installer again from scratch - but the same problem occurred (the initial install goes fine, but there is no audio driver and no battery icon on the menu bar etc. then after running EDP, selecting Latitude D520 & the predefined configuration as per the guide, it fails to boot).


Booting with the -v flag, I can see that it stops at:


RTC: Only single RAM bank (128 bytes)
mbinit: done (64 MB memory set for mbuf pool)
rooting via boot-uuid from /chosen: 63EAD4BD-EFFF-3B8D-AA37-6DBF7B7A552D
From path: "uuid", Waiting on <dict ID=0><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
Still waiting for root device
Still waiting for root device
Still waiting for root device
Still waiting for root device
Still waiting for root device


Any ideas what I can try to get it functional? (preferably with the additional kexts such as battery and audio left intact)


Thanks :)


P.S. I googled the problem a little and read that it might be to do with the SATA mode (ATA / AHCI) but unless I've somehow overlooked it I don't think I have any option to change that setting in the D520 BIOS (A08).

Link to comment
Share on other sites

  • Create New...