Jump to content

[Solved] Dell Latitude 7300: Bluetooth (DW1830) and audio jack problems


Go to solution Solved by BillDH2k,

Recommended Posts

I return to the forum with a new project. A Dell Latitude 7300 laptop (specs attached below). With my Opencore 0.9 setup, everything works perfectly in Monterey and Ventura 13.2.1, including the trackpad buttons. I have just replaced the wifi card, with a Broadcom DW1830 and here is my problem.

I can't get bluetooth  and jack audio to work. It appears enabled but does not find any device and does not appear in the "Network" section.

my Specs:

Dell latitude 7300

  • Intel Whiskey Lake i5-8365U CPU
  • Intel UHD620 graphics
  • 16GB RAM
  • DW1830 (Broadcom) Wifi and Bluetooth


**In order for the trackpad buttons to work, you need to disable the "Strong click and tactile feedback" option in the trackpad settings menu.


My EFI folder https://drive.google.com/file/d/1apnUmoamG_KqMDdQX1PfP-U-wj8fGGpe/view?usp=share_link


MacBook Pro.ioreg

Link to comment
Share on other sites

Hello @Eddar_Stark,


In order to get DW1830 fully working you need to place the appropriate kexts in EFI/OC/Kexts and config.plist accordingly. Easy to find as it is discussed many times. Your EFI contains kexts for Intel WiFi/BT card so I suggest to remove them. 

As for the audio jack - use alcid=77 and alcverb=1 as boot flags and apply the fix from this repo - ALCPlugFix-Swift 


@BillDH2k kindly provided the config file for the fix ALC295-DELL7400.plist.zip

Link to comment
Share on other sites

Thank you very much Jazzoo, I have now gotten the Bluetooth to work. I just need to fix the audio jack. I have read the guide and I have added the boot args, but I don't quite understand how to edit the sample.list and what should I do next. Sorry for my poor knowledge.





  • Like 1
Link to comment
Share on other sites

IM so sorry. I had already read your post but it's not entirely clear to me, it must be super simple but I can't get it. I know that your sample.list file is already edited with the ALC295 parameters, but if you would detail the steps to follow with the files please.

I managed to run install sh, drag your edited sample.list and AlcPlugFix appeared in Usr/local/bin. I have run it again inside the folder but still the same.

Link to comment
Share on other sites

  • Solution

1. Download the appropriate version from the Releases and extract the zip file.

Let’s assume that you downloaded “ALCPlugFix-Swift-RELEASE-1.5.zip” to download folder, and extracted the zip file in the same place (by double-clicking). You would have a new folder “ALCPlugFix-Swift-RELEASE-1.5” created. Right-Mouse-Click on the new folder icon -> Services -> New Terminal at Folder.  A new terminal window would be opened at the current folder path: /Users/YOURNAME/Downloads/ALCPlugFix-Swift-RELEASE-1.5  (You can type “pwd” to verify it)


2. Copy the edited sample.plist file (in this case: ALC295-DELL7400.plist) to somewhere safe.

I placed it in “Monterey HD\users\shared”, where Monterey HD is the name for my macOS drive. You may have a different name.


3. At the terminal (opened in step 1), type: ./install.sh

Follow the instruction. When it asked for .plist file, drag “ALC295-DELL7400.plist” icon to the terminal, from the location you stored in step 2 above (in my case, it is from “Monterey HD\users\shared\”).


You may encounter message like "ALCPlugFix is from unknown source” (1st time install) , just ignore it. After install is completed, go to folder: /usr/local/bin  (this is where ALCPlugFix is installed).  Right-Mouse-Click on ALCPlugFix icon -> Open, then Open again to allow it to run. This would give it the permission to run.


Add "alcverbs=1 alcid=77" to the boot args.  Reboot. 

  • Like 2
Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...