Jump to content

Inspiron 660


Recommended Posts

I need some help.


I have installed OS X 10.8.4 using unifail and currently I am only able to boot into Safe mode using the -x boot parameter.


I am running on:


Inspiron 660

i5 3330 3.0 GHz

8 GB DDR3 1600 RAM

Intel HD 2500 Graphics Controller

Realtek GBE Family Controller (RTL811F)

Dell DW1506 Wireless

Cirrus Logic HD Audio



I have a patched DSDT and SSDT thanks to EMlyDinEsh at OSXLatitude (attached), and can get the OS to recognize my graphics controller and load at full resolution using safe mode (connected with HDMI).  However, when I attempt a normal boot I get a loop of com.apple.LoginWindow, com.apple.Backupd, and com.apple.metdata.mds.  I have attempted to use different SMBIOS combos (including the one provided by OSXLatitude) as well as using the GraphicsEnabler=Yes and directly injecting my device ID in the PLIST.  I have also tried with just the patched DSDT and SSDT with no reference to graphics in the PLIST (same results).


(see attached system.log.txt)


Selected multifail Options (screenshot



I am using the AppleIntelCPUPowerManagement.Kext from EMlyDinEsH at https://osxlatitude.com/index.php?/topic/1945-dsdtssdt-patching/


Attached in the ZIP are the DSDT, SSDT, PLIST, multifail and Sysinfo screenshots, system report dump, and System.Log for this issue.  Any help would be greatly appreciated.


Link to comment
Share on other sites

use the MyHack+EDP method then we can help you!


So far this looks more promising.  I have re-installed OS X 10.8.4 using MyHack and EDP.  Now when I boot I go from the MyHack logo -> Apple Logo with arrow -> Black screen (white top left corner).  If I push the power button twice I get a white screen with no response.  I am attaching my new System.log, please let me know if there is any other information that I can provide to assist.


Currently using

Patched SSDT

SMBIOS iMac 12,1

Graphics Recognized as HD 2500 with 512 MB shared RAM


Link to comment
Share on other sites

reboot with your flash drive. do not patch your ssdt and make sure you selected your model, and i think you blacked them out. please don't because that is what we need for the hackintosh. btw, i think it's because mach_kernel is not loading. try a different one and boot with your flash drive for now. just boot off it and select the hard drive you installed to. you can constantly do that or we can try to get mach_kernel to work, which will be a new experience for the both of us, though i know the filesystem.

Link to comment
Share on other sites

Thank you for the response, however I am a little confused by your instructions.  Please forgive me if this is basic stuff, this is my first real attempt at doing a hackintosh.


In your first instruction, you suggest "make sure you select your model."  Are you referring to the SMBIOS, or EDT patching?  If you mean the EDT patches, my system is not listed (not sure if I'm even supportable by this forum).  Also, I did try booting from the USB without anything loaded for SMBIOS, as well as configuring a few tests.  MacMini6,2, MacMini6,1, iMac13,1, iMac12,1 with the iMac having the same result and MacMini not getting to the second Apple logo.


I should also note that when I used MyHack to perform the installation, I had to boot using the -x parameter.  When the installer went to the second apple screen I got the color wheel spinning.  I left it like this for an hour, but never went to the installer.

Link to comment
Share on other sites

Mach_kernel is the base kernel u r loading. Your issue is that it is missing files. Thus, it won't boot. Try your install drive which has the full kernel. Boot off of it, and push tge right arrow until you select your hard drive. I can't get simpler than that! ;)

Link to comment
Share on other sites

Sorry I misunderstood your post.  I followed your instructions and used the USB bootloader to select my OSX HD rather than using the HD boot loader, with the same results.


Attached is my zipped up extra folder. 


When performing the install I had the installer use the default rather than specifying one.


Link to comment
Share on other sites

If you screen share with my computer if you install team viewer on the other computer you are posting on. Also btw I will have to email the zip to you. I would like you to private message me to set up times and all that stuff. First find out your screen resolution and all the hardware in your computer. Use the messenger on your account and I will set up a time for this. It's not too hard if u get the swing of it, after all it's only been 3 years for me!


Ill pick it apart with u watching so u learn


Moderator: Please use the edit button, instead of posting new reactions!

Link to comment
Share on other sites

It isn't a "Mach_Kernel" problem, because it is just booting fine. According to your story, it is a graphics issue.

MyHack logo -> Apple Logo with arrow -> Black screen (white top left corner).


HD 2500 can be a bitch to set up, but it should be possible. Can you still boot in safe mode? (-x).

You can have a look here also: http://www.macbreaker.com/2013/05/enable-hd-2500-graphics-on-your.html


You should use the Macmini6,2 SMBios btw! And add the EFI properties from my link above. I didn't had time to check your DSDT, so I don't know which IGPU edit are done already.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...