Jump to content

myHack Lion USB stick not booting


pkumar
 Share

Recommended Posts

I have prepared the Mac OS X Lion USB stick as per the procedure detailed in the guide. Once I try to boot from the USB stick, the boot process terminates midway with the error given below. I can post more of the output if required.

 

using 64-bit bootcache playlist

BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 No such file or directory

Bug: launchctl.c:2408 (24957):30: (dbfd = open(g_job_overrides_db_path,....

launchctl: Dubious ownership on file (skipping): /System/Library/LaunchDaemons

nothing found to load

 

Since all the steps in creating the bootable USB stick are done by the myHack app, I am not sure what else to try. Can someone help?

Thanks in advance.

 

The system specs:

Intel Core 2 Duo T7300 2.0 GHz

Intel GMA X3100

3 GB RAM

64 GB MBR partition on a 160 GB HDD

Link to comment
Share on other sites

It's not always that I get to quote the General of the Army, but here goes:

"you can enable permissions from the terminal by typing vsdbutil -a /Volumes/yourinstallervolume then run the chown -R 0:0 /Volumes/yourinstallervolume again"

 

Give it a twirl, it helped in my case.

 

T.

Link to comment
Share on other sites

From the comments on the release page I wrote:

 

@Everyone having permissions/ownership problem:

 

That error happens when permissions were not correctly enabled during the file transfer… And yes this is a symptom of using tonyfail crap (you do know he has no real programming skill other than copying and pasting other peoples work and passing it off as his own right?) – there are a few things you can try however before you simply wipe it out and stat over.

 

As I said in a previous comment the first thing u can try is:

 

sudo chown -R 0:0 /Volumes/Your Installer/

 

Note: This should not be necessary as the app will enable permissions on source and destination volumes prior to transferring the data and it preserves all permissions, attributes and ownerships – I only suggest it as a last resort.

 

That isn’t ideal, but it may at least get you booting, at which point you can at least get things installed and have a clean start. I do suggest using the minimal /Extra/Extensions you can to boot your system and then layer by layer add one thing at a time until you have the rest of your hardware working – that way you can easily tell when something is working and when something is not – makes finding the source of a problem much easier.

 

For the chown command to work you must first enable permissions on the device, this should have when the command was sent from myHack during the creation of the USB stick, it is unclear why it failed without you providing me your console logs to review – you can enable permissions from the terminal by typing vsdbutil -a /Volumes/yourinstallervolume – then run the chown -R 0:0 /Volumes/yourinstallervolume again.

 

I also suggest you run diskutil repairPermissions / prior to doing this or to attempting the following…

 

Ideally, you could just wipe out the boot sector, repartition and reformat the usb stick and try to start over – this has worked for most people.

Link to comment
Share on other sites

Thanks for your replies rockingturtle, Tiberiu and conti

 

I tried the solution suggested by Tiberiu and was able to successfully complete the installation.

 

Since the error was referring to a folder I had initially tried to fix the permissions on the folder, not the volume.

 

After reading conti's post I realized how it could have happened. I was trying different methods to create a bootable USB stick before I came across myHack and must have screwed up the permissions somehow.

 

The notebooks's keyboard and trackpad are not working after first boot - using a wireless keyboard and mouse now. Will try and fix these tomorrow. I'll post my full experience when done.

Link to comment
Share on other sites

Finally my Acer Travelmate 4720 is usable with correct screen resolution, network and sound.

 

I could not get the following to work though:

1. WiFi

2. Webcam (Acer crystal eye)

3. Quartz Extreme (graphics is Intel GMA X3100)

 

In case anyone has been able to get these to work, please help.

Thanks in advance.

Link to comment
Share on other sites

 Share

×
×
  • Create New...