Jump to content

Stuck at PCI Configuration Begin


Captain America
 Share

Recommended Posts

So I have an MSI GX740 235-US and when I run the USB, I get stuck on PCI Configuration Begin when I do it with Lion. When I try Snow Leopard, it just reboots. I tried npci=2000 (and 3000) and that didn't do anything. This has been driving me nuts and any help would be much appreciated. Thanks.

Link to comment
Share on other sites

Will do. I don't know anything about replacing kexts though.

 

EDIT: Nevermind, I read the Troubleshooting section about it and dropped the files in the folder. Is there anything wrong with the fact that the particular kext didn't already exist? Also, it didn't work when I booted it...still getting stuck on PCI Configuration Begin.

 

EDIT2: Tried the kext on Snow Leopard. Still reboots.

Link to comment
Share on other sites

Alright, I'll give it a shot after work. Thing is though, how do I get it?

 

EDIT: Got it from this site: http://www.osx86.net/view/1481-appleacp ... 0.6.6.html

 

Didn't work still getting the PCI Configuration Begin.

 

EDIT2: I managed to get it working! I used the flags -v -x npci=0x3000 pci=off GraphicsEnabler=No

 

But I have new problems. My trackpad doesn't work, I don't have Wifi or Ethernet drivers, I need the MyHack USB to boot with the flags that I mentioned before. Not only that but no other USB devices work, my disc drive won't open, the graphics are kind of laggy. I think pretty much everything except the operating system itself aren't working. When I try to run MyHack it tells me that it can't be run in safe boot mode. I have so many problems right now its ridiculous.

 

EDIT3: a little hardware background might help you

 

Intel Core i5 450M

ATI Mobility Radeon HD 5870

Ralink RT3090 (wifi card)

8GB DDR3 1333MHz

Intel HM55 Chipset

 

EDIT 4: Trackpad works now, still no ethernet, sound or wifi. I got it to boot without MyHack by installing Chameleon and editing the plist to add the pci=off (which I think is the reason I can't use my wifi).I tried downloading OS X drivers from RaLink's website but the wireless utility doesn't detect the wifi card probably because PCI is disabled. Other USB devices work now thanks to myfix, disc drive seems to work. Safe mode isn't an issue anymore. But like I just said, I still need:

 

WiFi

Ethernet

Sound

 

thanks for the help.

Link to comment
Share on other sites

 Share

×
×
  • Create New...