Jump to content

Issues with Installation on GA-P55A-UD3


Recommended Posts

I'm going to start off by saying that I have been hunting for answers for what seems like hours straight. 3 hours of hunting = 1 tweak = no new results. I'd like to apologize if this is answered elsewhere in the forums and would appreciate a link if that's the case. That being said: :D


Let's start off with my Specs:


i7 860

EVGA Nvidia 560ti (probably going to be a major pita)

8gb 1333 ddr3 (down to 4 for install)


I've created the install disk with flying colors.

I boot and it freezes on the MAC apple...

I then research and find the npci0x2000 switch and it boots to a "Select Your Language" screen

At this point I have no response from my mouse or keyboard.

:::I have tried:::

LegacyUSB Switch

Disabling all USB3 on mobo

safe mode


Then I find a site that has a DSDT for my motherboard... I download it and hope it will tweak the installation environment just enough for a successful boot but I am having trouble figuring out how to update the myhack USB drive with the new DSDT. I put it in the /EXTRA/EXTENSIONS folder and run my fix to rebuild the Chameleon boot plst but I am definitely missing a step... it boots the same every time. If you're familiar with this issue please help a n00b out.


Thanks a ton for even looking at this.

Link to comment
Share on other sites

** Update**

- DSDT DL'd from another site

- Unlocked the file to rename it to "DSDT.aml"

- Thinking back, I did not re-lock the file, would that affect anything?

- DSDT has been injected into my /Extras folder

- myfix ran on drive to fix it all up

- Boot switches: -v DSDT=Extras/DSDT.aml npci=0x3000

--- This errors out with the DSDT file showing a size of 0 bytes and a DEADBEEF error.


This is as far as I have gotten... I'll research more about this DEADBEEF and try to figure out why my DSDT is showing 0 bytes (could be because I left it unlocked). If anybody who reads this has a suggestion or link, I'd appreciate it.

Link to comment
Share on other sites



I ran multifail from a VM and selected the Rollback IOUSBFamily.kext

I was able to install Lion no problem as this fixed my mouse and keyboard issue from above.

I boot into Lion via the Hard Drive, and my FN USB issue is back.

Going to hook the drive up so my VM can see it and run multifail on it just like it did for the install...


As always, if anybody know's a better way to fix this... lemme know. :D


I with there was a rescue disk that allowed you to run multifail off of it (I know, different creator)... This would solve many issues.


myHack rocks btw... I am loving how convenient it makes things... I fear I do not fully understand all of the extras it installs automatically.


Great work!

Link to comment
Share on other sites

Well right off the bat I noticed one thing related to the boot switches you used, there is no such location as Extras/DSDT.aml - the DSDT.aml will be loaded automatically if it is placed in / or /Extra/ there is no need to add a boot flag.


Additionally if you are having issues related to USB you should have attempted to use the USBBusFix flag - also I would have suggested attempting to remove the usb keyboard and connect it on various usb ports to see if any of them worked and there is also a USB Keyboard/Mouse flag in most bios that I would have attempted to toggle on/off.


myHack doesn't install many extras automatically and they are well documented - the main purpose of myhack is to help you get started and then help you to learn how to fine tune your system - becoming a more skilled hackintosh'er in the process.

Link to comment
Share on other sites

Thanks for the reply Conti.


And thanks to myhack I was able to get everything installed and working.


- Created myhack install drive

- Ran multifail fix IOUSBFamily Rollback on the install drive

- Booted the installed with flag -v npci=0x3000

- Had usb mouse and KB for the install!! YAY

- After the install, I did not have mouse or KB for the actual OS

- Pulled the drive and hooked it up to the mac vm via usb converter for sata drives

- Ran the same multifail fix on the OS drive I installed to

- I was able to boot up and continue configuration as normal! YAY AGAIN!


Having issues with getting sound directly from the MOBO but I am using a workaround for the time being. Also WPD600 Linksys wireless card does not have any support for 64-bit Mac OS's. I just bought a D-Link 556 and it worked perfectly out of the box.

Link to comment
Share on other sites

  • Create New...