Jump to content

10.8 installation hangs on white screen


Recommended Posts

Hi all,


Running 10.8 installer as downloaded from the Mac App Store. MyHack installation goes normally but when I boot the Hackintosh from the modified 10.8 installer it shows Apple logo and spinning gear as normal then hangs on a plain white screen with a mouse pointer instead of starting the conventional OSX installer interface. My Hackintosh works perfectly in 10.7.4. Any ideas what might be causing the installer to hang?


System details:

- Gigabyte GA-G41MT-S2P, rev 1.3, BIOS rev F1

- Realtek ALC889 audio codec

- Atheros AR8151 Gbit ethernet

- Intel Core 2 Quad 6600

- XFX Radeon HD 6870 Black Edition

- OS X Source Media: Install OS X Mountain Lion.app

Link to comment
Share on other sites

Thanks! I'll give that a try.


I don't use a DSDT yet - still using a motley collection of kexts. In fact I don't really understand DSDTs at all, and I don't think I've ever seen one for my board.

Link to comment
Share on other sites

I ran into this problem myself when I was setting up my new Ivy Bridge system tonight. Was the first time I tested the HD6870 in ML, worked fine in Lion in the past. The solution was actually not an obvious one as suggested by some of the responders here - but I did work one out which I will discribe briefly.


Basically, force VESA mode by simply removing the ATI6000Controller.kext from the myHack OS X Install Disk. I would suggest doing it as follows:


In a terminal with the OS X 10.8 myHack OS X Install Disk connected to the system run the following:


sudo mv /Volumes/myHack\ OS\ X\ Install\ Disk/System/Library/Extensions/ATI6000Controller.kext /Volumes/myHack\ OS\ X\ Install\ Disk/Extra/RemovedExtensions/


Then run myfix on the myHack OS X Install Disk via the myHack application or terminal.


Now boot the myHack OS X Install Disk on the system you were having issues with, use the following Chameleon boot flags:


GraphicsEnabler=No -v


You will now get to a GUI, with limited and ugly resolution - but it will function. - Don't worry, the HD6870 actually works great in ML itself, this is only an issue with the ML Installer.


After installing ML, boot the system to it. You will once again have to boot with the GraphicsEnabler=No -v boot flag.


After you get through the initial setup, account creation, etc and login - pop open a terminal and reverse the process you did before.


Make sure the myHack OS X Install Disk is attached to the system and run the following command:


sudo mv /Volumes/myHack\ OS\ X\ Install\ Disk/Extra/RemovedExtensions/ATI6000Controller.kext /System/Library/Extensions/


This will put the extension back in it's place. Then run myfix again - this time targeting /


Once completed, reboot the system - Use GraphicsEnabler=Yes (this is the default value in myhack org.chameleon.Boot.plist so you will not have to type it unless you modified the value in the plist) and enjoy your fully functional HD6870 in ML.



Link to comment
Share on other sites

Another solution would be to inject your ATI card into your DSDT and then place your DSDT in your Extra folder of the installer. Worked for me.


This would be a good solution for people who already have lion on their systems, in my case this was a new build and I had not yet extracted the DSDT (nor did i bother installing linux or windows to do so), and since it was Ivy Bridge, Lion wasn't really an option for me.

Link to comment
Share on other sites

Sorry for the delay in responding, I've been away.


Thanks especially to Conti - your advice worked perfectly, and 10.8.1 is now installed! :) Now I just have to play "hunt the kext..."


I still don't understand DSDTs - I have a text file for my motherboard but I don't understand how to install it as a DSDT, or how to "inject" things like my graphics card data into it. Is there a FAQ or workshop anyone can point me towards?

Link to comment
Share on other sites

  • Create New...