Jump to content

Mountain Lion won't install


lerenoamp
 Share

Recommended Posts

This is my first attempt at a Hackintosh, my system is written in my signature.

 

The install hangs at the point shown in the attached picture. I got to this stage by selecting one processor in the BIOS, and typing -x -v in the command line before running myHack.

 

Same result if I type -x -v cpus=0

 

However, if I type -x -v cpus=1 it gets a bit further, then the screen goes into power-saving mode.

 

The computer is still on, but obviously I can't see if it gets to the install page.

 

This happens whether my monitor is connected via the vga port or via the dvi to vga adaptor.

 

Have tried PCIRootUID=1 / PCIROOTUID =0 with no success.

 

 

Any ideas out there as to what could be wrong? A different Graphics Card may be what's needed here?

post-2402-13826558088979_thumb.jpg

Link to comment
Share on other sites

  • Replies 31
  • Created
  • Last Reply

Top Posters In This Topic

Further to this, I managed to get a picture of the verbose mode just as the screen went off.

 

Not sure if this is any help because the camera caught it mid-transition and the last few lines are blurred by ghosts of the upcoming lines.

 

Best Regards

 

lerenoamp

post-2402-13826558090542_thumb.jpg

Link to comment
Share on other sites

I support all x79 motherboards via my blog:

 

http://rampagedev.wordpress.com/2012/07 ... dati-gpus/

 

Use my install guide here:

 

http://rampagedev.wordpress.com/os-x-10 ... tain-lion/

 

Boot with:

 

-v npci=0x2000 cpus=1 GraphicsEnabler=No

 

Then follow exactly what my guide says to do. I do not think I have a DSDT for your motherboard yet but I can make you one post install.

Link to comment
Share on other sites

OK, I found this following command line:

 

-v npci=0x2000 GraphicsEnabler=No darkwake=0 busratio=36 PCIRootUID=1

 

(I'm using a bus ratio of 36 because I have the i7 3820 cpu and I believe that is the bus ratio)

 

It didn't work, but went further before hanging - no message saying 'waiting on root device'

 

So I tried -v npci=0x2000 GraphicsEnabler=No darkwake=0 busratio=36 PCIRootUID=0 pcis=1

 

This time the install goes further, but my monitor goes to sleep and I cannot see if I am getting to the 'install Mountain Lion' screen.

 

I tried using another popular Hackintosh install software and the screen going to sleep mode is the exact same problem I had with that.

 

I've tried both the vga and hd outs, no difference.

 

Not sure what else I can try.

Link to comment
Share on other sites

I was just waking up when i first read this this morning and I thought he had tried cpus=1 but it turned out on closer inspection to be pcis=1 lol... my bad.

 

Anyway yes GE=Y is default in myHack so what Beta suggested should be the correct string to boot your system.

Link to comment
Share on other sites

 Share


×
×
  • Create New...