Jump to content
VTCop

OSX Mavericks on Lenovo Thinkpad T430s

Recommended Posts

Hi, I'm trying to install OSX Mavericks into my Thinkpad T430s. I've seen T430 (without final 's') is in your compatibility list, and the two computer are basicaly the same. 

 

I've prepared a USB stick with myHack and I select the T430 boot pack download from OSXLatitude, all looks ok through Chamaleon, but when I get the installation "select language" window the screen changes into something weird. I've attached a photo.

 

My laptop has an Intel HD4000 vga, and any other VGA (not dedicated vga). The resolution of my integrated LCD is 1600x1900.

 

However, if I use the T440 boot pack (later model but with the same VGA) I get to the installation "select language" window with perfect resolution, but it gives me an error and can't continue

 

Could I use the graphic driver of T440 boot pack into T430 boot pack??

 

Thanks

 

PD: After prepare a USB stick and install on it my own Extra with myHack, Can I then install a new custom Extra with myHack without start the process from the begining (without copy again the full OSX with myHack)?

post-67707-0-68103300-1414681436_thumb.jpg

Share this post


Link to post
Share on other sites

How? Apply t430s boot pack and the new manually copy dsdt.aml to /Extra in the USB? should I use my fix after?

 

Or should I use generic extra?

Share this post


Link to post
Share on other sites

You mean T430s boot pack, I suppose, isn't it?

 

I want to learn. What is the difference from your dsdt and the one provided with the boot pack? What has you modified?

 

Thanks, I will try in a pair of hours and report.

Share this post


Link to post
Share on other sites

Yes, of course, I did it.

 

I've realized that I get this error with your custom DSDT or without it. 

 

If I try to install with the t430 boot pack (without your DSDT) the screen is distorted, but I can select the language and then the installer crash in the same way.

 

So it's not your DSDT, it corrects the resolution perfectly.

Share this post


Link to post
Share on other sites

The MBR patch from myHack has some dependency issue. If you really need to build on an MBR partition, then you'll need to replace the MBR patch file.

Use the version of patch for the version you're installing from here. No need to rebuild the installer.

Otherwise, just use GUID and select no when you build the USB Installer. 

Share this post


Link to post
Share on other sites

×
×
  • Create New...