Jump to content

Asus G75VW help topic


Recommended Posts

what do you do with the 670m.hex file after you download it???


In chameleons boot.plist file in E/E, create a new string called device-properties.

Then open the hex file with textedit, then copy the contents of it to the device-properties in the boot.plist

Link to comment
Share on other sites

  • Replies 25
  • Created
  • Last Reply

Top Posters In This Topic

thank you for the info but im using clover in uefi and would like to know where to put it in clover configurator, if you could help that would be great. im trying to get my dsdt patched for working backlit keyboard function buttons and screen backlight function buttons to work (all other function buttons work with kext), but when i use my stock or patched dsdt it doesnt load the gtx670m like it does when i dont use a dsdt and just inject nvidia as well as us an smbios of 10,1 mackbook pro retina display 2012 model. I get the black screen and looks like its going to keep loading. any help would be greatly appreciated.

Link to comment
Share on other sites

That's the same problem I ran into with clover which is why I ended up using chameleon. Then my laptop died before I got the chance to figure it out. But there is a device properties box in clover I think under boot or GUI or something like that along with a checkbox under it.

Link to comment
Share on other sites

In the graphics section there is a section for hex code called edid and then inject edid check box under it instead of intel, ati, or nvidia. That didnt work for me though in clover booting yosemite or el capitan. I am using clover version 3292 (3280 also worked fine) and clover configurator version 4.22.5.
I used a clover guide to get 10.11 on the flash drive make 2 partitions, make disk gpt, make one partition fat32 and the other osx journeled run the long termial command, wait till its done, install clover with only OsxAptioFix2Drv-64, then afterward delete vbox64.efi from drivers64uefi and copy hfsplus.efi into the same folder so now it should only have fsinject.efi, hfsplus.efi, osxaptiofixdrv-64.efi and osxfatbinarydrv-64.efi in it.
My 10.11 kexts folder contains fakesmc.kext, asusnbfnkeys.kext(function keys(screen brightness and keyboard backlight adjustment not working), AtherosL1cEthernet.kext(ethernet), Voodoohda 2.8.6(sound no hdmi sound and its kinda crappy but better than nothing), BrcmBluetoothInjector.kext(broadcom bluetooth), FakePCIID_BCM94352Z_as_BCM94360CS2.kext(my bcm94325hmb wifi a/b/g/n/ac dual band wifi half hieght combo card that i swapped out) and ApplePS2SmartTouchPad.kext(keyboard and trackpad)
My clover config is as follows:
-nothing checked or enabled aka toally blank acpi section,
-boot only has dart=0 checked,
-cpu section is blank,
-devices has inject, add clock, and fixownership checked
-disabled drivers is empty
-gui has my custom settings for dual booting win10 and osx 10.11 on same drive (havent figured out how to change name in clover of the secondary ssd which   has win 7 on it in uefi, i also couldnt get windows 7 mbr/legacy to boot from clover at all and ended up reinstalling win 7 in uefi just to use clover menu).
-graphIcs has only inject nvidia checked
-kernel and kext patches has apple rtc, asus aicpupm, and kernel pm checked with name=appleahciport, find=45787465726E616C, replace=496E7465726E616C, comment=External Icons Patch, and type/key=string
-rt variables is blank(no where to put in the string for sip diasable so everytime you modify the config.plist via clover configurator you have to manually re-add it?)
-smbios is set to macbookpro 10,1 macbook pro retina display
-system parameters has inject system id checked and inject kexts=detect
To disable sip completely for use of cdock, extrafinder etc. The code to add to the end (before the last <dict> but after the secnd to last <dict> of config.plist is
To get your weather/stocks/etc back, if they have dissappeared the weather app is located in system/librabry/coreservices, just double click weather app and it should come back, there is some glitch when disabling sip that makes the notification center act weird and this gets it back ot normal, i havent had to do this after the one time to get it come back on.
I have tuxera installed in osx to write to my ntfs partion and i have paragon hfs+ in windows to read and write to my os x partion. very handy!!
With this setup i can boot even the 10.11 installer usb to full 1080p with accelaration, keyboard, trackpad, usb 3.0 (2-ports on right side only), function keys (minus screen brightness and backlit keyboard), sound, my bluetooth/wifi with 5gh band working, and ethernet working.
There is a way to use the old disk utility from 10.10 on 10.11 which I and many others greatly favor over the 10.11 version which is not useable formany functions. http://www.insanelymac.com/forum/files/file/480-disk-utility-patched-v2/is the easiest way to do it.
Hopefully this helps others with their g75vw with 670m graphics cards get to a pretty usable os x 10.11 
I could still use some help to get the backlit keyboardkeys and screen brightness working, sleep, etc. i have tried using dsdt patches for those fixes but when i boot using dsdt i get a black screen when it reachs the point of loading the graphics card. dont know how to get around it yet. Any help with the setup needed to be able to use a dsdt and have it boot to desktop with full graphics would be appreciated. 
I have a working 10.10 install usb that boots to full 1080p and everything working also. The whole guide is different than this 10.11 guide and took me a week to get it working. I will post that shortly

Link to comment
Share on other sites

To get yosemite working on the g75vw you need all the kexts listed above for el capitan 10.11 and genericusbxhci.kext (yosemite version), and AHCIPortInjector.kext


in the drivers64uefi folder you need FSInject.efi, hfsplus.efi, OSXAptioFixDrv-64.efi(not OSXAptioFix2Drv-64.efi), and OsxFatBinaryDrv-64.efi.


the config.plist is the same as el captians. usb installer will boot with full 1080p and everything working besides the same things that I listed above that dont work in el capitan yet.

Link to comment
Share on other sites

Hi I used Neris ML worked almost perfect, no wifi and sleep but everything else worked great. But now my mother board

seems to be dead. Worked good for about three weeks, freezing sometimes for no reason at random, now a 800 dollar

brick, the reason im saying something is I've read in forums about g75vw with gtx670m and osx is somebody will say their

motherboard is dead. Is it ML or all osx. btw. still using g71 SL and g74 ML both working for years with out fail. :shock: 

Link to comment
Share on other sites

  • Administrators

Afaik, installing or running OS X on PC hardware has never killed a motherboard! You'd have to run on seriously incorrect settings to damage the underlying hardware, like incorrect power management leading to sustained/prolonged overheating or something to that effect.

Link to comment
Share on other sites

  • Create New...