Jump to content
PayPal donations: [email protected] ×
fweak

TurboBoost on AC Adapter E6520

Recommended Posts

Hello,

 

I isolated my turboboost problem and I found out that when I'm using the battery, the cpu works as intended (min x8 max x32) multiplier but as soon as I plug the AC Adapter, max ratio drops to x22.

 

I tried every E6x20 dsdt but now I'm using my own patched one and I'm using ssdt from ssdtprgen. 

 

Anyone could come up with a fix?!

 

Thank you very much!

Share this post


Link to post
Share on other sites

Maybe it's not DSDT related then. Can you please post the list of kexts you're using and detail of your SMBIOS + boot plist (whether Chameleon boot plist or Clover config.plist)?

 

What kind of power adapter is it by the way? 45W, 65W or 90W ?

Share this post


Link to post
Share on other sites

This is the list of the kexts I use:

- ACPIBatteryManager.kext

- FakeSMC.kext

 -VoodooPS2Controller.kext

- AppleIntelE1000e.kext

- VoodooHDA.kext

 

SMBios MBP8,1

 

The AC adapter is not the original one but is Dell branded 65w... Could it be related? I find this interesting since I had POST messages about it before.

 

Thank you!!

config.plist.zip

Share this post


Link to post
Share on other sites

Some Latitude E Series (like the E6440) require a 90W adapter. Check whether this applies to the E6520. Nothing wrong with your kexts or config.plist. At this stage, on the basis that you're getting POST messages about it, I'd suspect your adapter is not suitable...

Share this post


Link to post
Share on other sites

I found a temporary fix... To let people know if they have the same issue... When the computer wake up from sleep turbo works again even on a.c. adapter!

Share this post


Link to post
Share on other sites

You mean you put the computer to sleep and wake it to gain Turbo boost again? I'd say this is ACPI, i.e. DSDT or ACPIBatteryManager related... Which version of the kext do you use?

Share this post


Link to post
Share on other sites

Yes, when I put the computer to sleep (which only works when I boot with HD3000) and wakes up, the cpu frequencies are ok.

 

I doubt that ACPIBatteryManager is the problem because I have the same problem without it.

 

Kexts related (from kexstat)

org.netkas.driver.FakeSMC (1394) 2DBA2F88-A115-386A-85D0-F88021A4D2E3 <11 7 5 4 3 1>

org.rehabman.driver.AppleSmartBatteryManager (1.60.5) 75A24811-F4EB-3665-AD7F-E46DF06E538C <11 4 3>

 

I don't know what to think anymore!

 

Merci beaucoup pour votre support!

dsdt.aml.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...