Jump to content
dpw95

[SOLVED] 10.11.4 + No Audio on E7440 & E5530

Recommended Posts

Have any of you had any breakthroughs with getting audio to work again with either your E7440 or E5530 Dell Latitude hackintoshes following the 10.11.4 update?

 

I found the thread below, but frankly I haven't been able to piece together specific steps that resulted in improvement:

 

Link:  https://osxlatitude.com/index.php?/topic/8491-dell-latitude-e5530-installation-working-approach/

 

I installed El Capitan via the following threads, with a LOT of help from the kind people who participate in this forum:

 

E7440:  https://osxlatitude.com/index.php?/topic/6461-guide-e7440-with-clover/

 

E5530:  https://osxlatitude.com/index.php?/topic/8491-dell-latitude-e5530-installation-working-approach/

 

From what I've seen in other places, there are mentions of other HDA files to use, but my installation approaches didn't seem to involve that from what I recall.

 

Any tips for measures I should take a run at?

 

Thinking forward, if I can get something to work successfully, I can post a guide for others to follow that one day find themselves in the same spot I am in at present.

 

Interestingly enough, I noticed that some people on Apple's own support forums mentioned issues with actual Apple-made computers following the 10.11.4 update, where they had been using USB audio devices which now are failing them.

Share this post


Link to post
Share on other sites

Thanks Jake!  Since it's been a couple of months since I was doing installs, can you refresh my memory on the approach to take to use these different files?

 

Which approach do you favor?

Share this post


Link to post
Share on other sites

Looks like you're using Pokenguyen's guide for both Hacks.

For E7440, the audio kext = AppleHDAALC.kext

For E6430, the audio kext = AppleHDAIDT.kext

Both found in /System/Library/Extensions

 

You could do it 2 ways. Either use mine pre-prepared kexts or update them yourself.

1) For E7440, Find in Update section, download AppleHDA_ALC292, rename it to AppleHDAALC and overwrite it in /S/L/E with kextwizard

    For E6430, download AppleHDA_IDT and rename it to AppleHDAIDT.kext and overwrite it to /S/L/E with kextwizard

   

2) Follow guide here. Editing the 2 kexts mentioned

Share this post


Link to post
Share on other sites

Are the two kext files you called out hidden in the directory you referenced?  I ask because I do not see that they're listed.

 

I only have "AppleHDA.kext" listed under /S/L/E

Share this post


Link to post
Share on other sites

No, they are not hidden. Perhaps you missed that step to add audio so you might not have it install. You could do a search for AppleHDA and see it shows up.

Otherwise just install the ones pertaining to your model from my Update section. The config files from those 2 guides don't have the updated patches for audio, so check my bootpack in post #2 for the patches or replace your bootpacks with mine.

Share this post


Link to post
Share on other sites

Would this approach be correct?

 

1) Download the E7440 boot back zip file.

 

2)  Copy its contents to the EFI directory on the hidden EFI volume.

 

3)  Extract the AppleHDA_ALC292.kext.zip file, and rename the file within to AppleHDAALC.kext

 

4)  Install AppleHDAALC.kext using KextWizard

 

5)  Reboot

Share this post


Link to post
Share on other sites

If you're going to be using my bootpack, then do this

1) Download the E7440 boot back zip file.

 

2)  Copy its contents to the EFI/Clover directory on the hidden EFI volume.

 

3)  Download AppleHDA_ALC292 from updated section, place in /EFI/Clover/Kexts/Other/LE

 

4)  Copy all kexts from /EFI/Clover/Kexts/Other/LE to /Library/Extensions

 

5)  Repair permission and rebuild cache, run from terminal

     sudo chmod -Rf 755 /L*/E*

      sudo chown -Rf 0:0 /L*/E*
      sudo touch -f /L*/E*
      sudo chmod -Rf 755 /S*/L*/E*
      sudo chown -Rf 0:0 /S*/L*/E*
      sudo touch -f /S*/L*/E*
      sudo kextcache -Boot -U /

Share this post


Link to post
Share on other sites

Thanks Jake!

 

Quick confirmation on step 4 you listed....

 

Should those kexts be copied to /Library/Extensions, or should they instead go to System/Library/Extensions ?

Share this post


Link to post
Share on other sites

×
×
  • Create New...