Jump to content

[SOLVED] Getting DW1550 / DW1560 / DW1830 to work on Sierra


bigahega
 Share

Recommended Posts

Hello,

 

finally I got my DW1560. Replaced the Intel 7265. I got the Bluetooth working but Wifi is just not working. Here is what I have done so far:

 

version (1.3.3 or greater)

 

* Installed latest version of FakePCIID.kext from Rehabman

* Installed latest version of FacePCIID_Broadcom_WiFi.kext from Rehabman

* Installed latest version of BrcmPatchRam2.kext from Rehabman

* Installed latest version of BrcmFirmwareRepo.kext from Rehabman

 

Now they are all installed and the Bluetooth is working fine I can search for devices etc. However, the Wifi part is not working no AirPort device or whatsoever. What am I missing? BTW all of the kexts are located in SLE.

 

Thank you

Link to comment
Share on other sites

  • Moderators

If you're on Sierra, make sure to add this additional hot patch to KextToPatch

<dict><key>Comment</key>
<string>AirPortBrcm4360 - fcvo</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>gflSqgAAdSk=</data>
<key>Name</key>
<string>AirPortBrcm4360</string>
<key>Replace</key>
<data>gflSqgAAZpA=</data>
</dict>
  • Like 1
Link to comment
Share on other sites

  • Moderators

Open your Config.plist with a Plist editor (Xcode or plistedit pro). Add the patch in post #2 to KextToPatch section.

Add the 4 kexts posted in post #1 to /Library/Extensions and run the permission fix and rebuild cache 

 

sudo chmod -Rf 755 /L*/E*

sudo chown -Rf 0:0 /L*/E*
sudo chmod -Rf 755 /S*/L*/E*
sudo chown -Rf 0:0 /S*/L*/E*
sudo touch -f /L*/E*
sudo touch -f /S*/L*/E*
sudo kextcache -Boot -U /
 
Note: if you don't know how to edit Config with with plist editor, you could use Clover Configuration (latest version 4.43)
Add the highlighted patch as the diagram.
 
DW1550.png
Link to comment
Share on other sites

I just got a DW1560 card and I have the opposite problem: My wifi works fine, but I have no Bluetooth. No icon in System Preferences, and "No Information Found" in System Information.

 

I have BrcmFirmwareRepo.kext, BrcmPathRAM2.kext, FakePCIID.kext and FakePCIID_Broadcom_WiFi.kext in /S/L/E, and I ran the commands here. Does it matter they are in /S/L/E and not /L/E?

 

Along with saying DW1560 on the card itself, it also says 2202024552-07 and CN06XRYC-773614-6CL-011Q-A02.

Link to comment
Share on other sites

  • Moderators

Try adding FakePCIID_XHCIMux.kext if you have USB 2.0 and USB 3.0. If this doesn't work, then add USBInjectAll + port limit patch as well.

If only USB 3.0, then add just  USBInjectAll + port limit patch.

Link to comment
Share on other sites

so i have to install latest version of FakePCIID.kext from Rehabman

 latest version of FacePCIID_Broadcom_WiFi.kext from Rehabman

 latest version of BrcmPatchRam2.kext from Rehabman latest version of BrcmFirmwareRepo.kext from Rehabman . using kext utility to S/L/E

then using plist pro editor to add kext to patch then run the terminal with sudo chmod  etc for clearing kext cache then reboot?

do i have to put the 4 kext file inside  efi/clover/kexts/other folder ? please help

Link to comment
Share on other sites

 Share

×
×
  • Create New...