Jump to content

viking1304

Members
  • Posts

    144
  • Joined

  • Last visited

  • Days Won

    4

Posts posted by viking1304

  1. You have two configs and two patched folders which is not a problem by itself, but you can easily make things wrong (as you did). In one of those CpuSsdt is SSDT-6.aml and in second CpuSsdt is SSDT-5.aml

     

    When you sent files first time you send this folder only:

    SSDT-0.aml
    SSDT-1.aml
    SSDT-2.aml
    SSDT-3.aml
    SSDT-4.aml
    SSDT-5.aml
    SSDT-13.aml
    

    and I wrote to you to remove SSDT-5.aml, since I checked all of them to see which one is CpuSsdt

     

    You use another folder now

    SSDT-0.aml
    SSDT-1.aml
    SSDT-2.aml
    SSDT-3.aml
    SSDT-4.aml
    SSDT-5.aml
    SSDT-6.aml
    SSDT-14.aml
    

    and you removed wrong table from Sort order. You need to remove SSDT-6.aml here, not SSDT-5.aml. You also need to remove SSDT-6.aml file itself from patched folder.

     

    This should fix your hang/kp problems.

     

    I updated all my kexts tonight and brightness stoped working for me too. Looks like AppleBacklightFixup.kext doesn't work with latest Lilu.kext for some reason. I had to remove AppleBacklightFixup.kext and to restore AppleBacklightInjector.kext and to re-enable change F%uT%04x to F%uTxxxx patch again. This works fine.

     

    You have this patch in your config, so just replace AppleBacklightFixup.kext with AppleBacklightInjector.kext and rebuild kext cache. After reboot go to Displays in System Preferences and check if you have Brightness slider there or not. It is possible that your keyboard shortcut doesn't work even if brightness itself works.

     

    p.s. /Library/Extensions is preferred location for adding kexts, not /System/Library/Extensions. It's not a problem if you add them there, but it would be hard for you to keep track of them later. I recommend to remove your kexts from there and to move them to /L/E. Always rebuild kext cache when you add or remove anything to/from /L/E or /S/L/E. 

  2. For hangup issues, you will probably have to drop CpuSsdt and (or) Cpu0Ist in your config. Something like this

     

    image.png.ba59b87b2cc2329a91ada63ff36ca68a.png

     

    SSDT-5.aml (CpuSsdt) should be removed from patched folder in that case.

     

    Drop OEM is needed if you are using patched aml files.

     

    Your sort order section should match existing files in your patched folder. 

  3. You probably would not get proper help until you at least send your config. Ideally send proper problem reporting file.

     

    I can tell you this so far - remove EAPDFix.kext (not needed with lates AppleALC) and FakePCIID_Intel_HD_Graphics.kext (not needed with lates WhateverGreen). You have FakePCIID_Broadcom_WiFi.kext that you do not need (remove it), but you removed BrcmPatchRAM2.kext and BrcmFirmwareRepo.kext that are actually need for working BT.

     

    For brightness try AppleBacklightFixup.kext. I prefer this one over AppleBacklightInjector.kext (which also need patch in config).

  4. Whatever you do, be sure that you are using latest Clover and kext files. ApfsDriverLoader-64.efi from older Clover versions will not load APFS drivers from 10.14.1 and you will not be able to boot, since conversion to APFS can not be avoided anymore.

     

    If you want smooth update, always update clover and kexts in advance and be sure that everything works. After that update should be painless.

     

    I attached my config with modified serials and latest kexts. If you want to try this, you have to replace complete ACPI/patched folder since I am using "hot patch" ACPI and yours is "static".

     

    Since you have DW1560 I added two kexts that I am not using AirportBrcmFixup.kext and FakePCIID_Broadcom_WiFi.kext.

     

    Do not add FakePCIID_Intel_HD_Graphics.kext, Shiki.kext nor IntelGraphicsDVMTFixup.kext. 

     

    I hope I didn't missed anything.

     

    btw. you can safely update your BIOS to A20.

     

    E7450 with NV.zip

     

    Edit: if you have model without NV, just remove SSDT-DDGPU.aml from ACPI/patched folder. That's all.

  5. Those are latest stable (non beta) drivers for (probably all) TP-Link USB devices. You will find two archives inside Mac OS X10.13.zip and Mac OS X10.8_10.12.zip. Mac OS X10.13.zip actually works just fine on Mojave too.

     

    I have no idea why they have so many different versions of driver packages on their site. When you start digging, you will find that you have same drivers on download page for several models. For some crazy reason only packages on latest hw versions of some device are updated.

     

    Those are supported TP Link devices:

    Spoiler
    TPLink_010C_88EUS (TL-WN722N v2)
    USB\VID_2357&PID_010C
    
    TPLink_0111_88EUS
    USB\VID_2357&PID_0111
    
    TPLink_011E_8811AU
    USB\VID_2357&PID_011E
    
    TPLink_011F_8811AU
    USB\VID_2357&PID_011F
    
    TPLink_0120_8811AU (TL-WN822N)
    USB\VID_2357&PID_0120
    
    TPLink_0121_8811AU
    USB\VID_2357&PID_0121
    
    TPLink_0126_92EU
    USB\VID_2357&PID_0126
    
    TPLink_821v5_92EU (TL-WN821N v5)
    USB\VID_2357&PID_0107
    
    TPLink_822v4_92EU (TL-WN821N v4)
    USB\VID_2357&PID_0108
    
    TPLink_823v2_92EU (TL-WN823N v2)
    USB\VID_2357&PID_0109
    
    TPLink_8812AU_0122
    USB\VID_2357&PID_0122
    
    TPLink_8812AU_1
    USB\VID_2357&PID_010D
    
    TPLink_8812AU_2 (Archer T4UH v2)
    USB\VID_2357&PID_010E
    
    TPLink_8812AU_3 (Archer T4UH v3)
    USB\VID_2357&PID_010F
    
    TPLink_8812BU_0101_1
    USB\VID_2357&PID_0115
    
    TPLink_8812BU_0101_2
    USB\VID_2357&PID_0116
    
    TPLink_8812BU_0117
    USB\VID_2357&PID_0117
    
    TPLink_T4UH_8812AU (Archer T4UH)
    USB\VID_2357&PID_0103
    
    TPLink_T4U_8812AU (Archer T4U)
    USB\VID_2357&PID_0101
    
    TPLink_T9UH_8814AU (Archer T9UH)
    USB\VID_2357&PID_0106
    
    RTL8188EU (TL-WN725N v2 or v3)
    USB\VID_0BDA&PID_8179

     

     

    Those are other RTL models supported by those drivers:

    Spoiler
    RTL8188EU_ETV
    USB\VID_0BDA&PID_0179
    
    RTL8188EU_VAU
    USB\VID_0BDA&PID_A179
    
    RTL8192EU
    USB\VID_0BDA&PID_818B
    
    RTL8192EU-2
    USB\VID_0BDA&PID_818C
    
    RTL8723BU
    USB\VID_0BDA&PID_B720
    
    RTL8811AU
    USB\VID_0BDA&PID_0811
    
    RTL8812AU
    USB\VID_0BDA&PID_8812
    
    RTL8812AU-VL
    USB\VID_0BDA&PID_881B
    
    RTL8812AU-VN
    USB\VID_0BDA&PID_881C
    
    RTL8812AU-VS
    USB\VID_0BDA&PID_881A
    
    RTL8812BU
    USB\VID_0BDA&PID_B812
    
    RTL8814AU
    USB\VID_0BDA&PID_8813
    
    RTL8821AU
    USB\VID_0BDA&PID_0823
    
    RTL8822BU
    USB\VID_0BDA&PID_B82C

     

     

     

    Edit: 28 Nov. 2021. Updated the link for TP-Link WN725N V3 drivers set, the original one being deprecated. It's the package for Mac OS 10.8 to 10.13, published 2018-08-20. 

    TL-WN725N_V3.jpg

     

    And just in case...

    TL-WN725N(EUUSES)_V3_180807_Mac.zip

     

    Generally speaking, visit manufacturer's web site for drivers.

  6. Quote

    Tap twice to enable capLock and twice to release. 

     

    There is nothing wrong with "just press Caps Lock two times instead of once" approach. I used it myself in the beginning.

     

    Later I came to conclusion that it's probably better to use "press caps once to turn it on, but 3 times to turn it off" instead. As you know, when you press Caps Lock first time case is changed and LED is lit, and that is expected behavior. Problem occurs when you try to turn it off. To accomplish expected behavior (both caps and LED turned off) you need to press that key 3 times. With this approach I have "working" Caps Lock including "proper" LED. :)

  7. Even with trackpad speed set to maximum in preferences, cursor movement is still too slow for my taste. I need to swipe my finger at least 2 times to accomplish same cursor movement as with one swipe with ApplePS2Controller. Do you have any idea what I could try to change in Info.plist inside trakpad kext?

     

    Apple keyboards do not have those keys, thats not questionable (I have one on my table right now). I am just not sure why those keys are disabled in this kext. They work just fine with ApplePS2Controller. Everyone would benefit with two more working keys. People could change those to anything they want with Karabiner-Elements, but they are currently completely dead. I hope that there is a simple way to enable them by changing Info.plist inside keyboard kext, and that there is no need for code modification.

     

    PtrScr key is mapped to Shit+Command+4 and Insert is mapped to Home with ApplePS2Controller, but I would be satisfied with any two codes that Karabiner could see.

     

  8. Remove AppleBacklightInjector.kext, but you do not have to remove patch from config right away. Just check Disable checkbox for start, so you can revert it back if you have any problem with AppleBacklightFixup.kext. When you see that everything works, you can remove it completely.

     

    I never had any problem with battery indicator. Inject Kext is on Detect in all my configs.

  9. On 10/29/2018 at 7:41 PM, Hervé said:

    On the other hand, the kext, as previously compiled, works without issues on my E6220, E6230 or E6440 under Mojave. I've not had to use a Mojave-compiled version.

     

    I honestly envy you now. I actually like this driver the most of all that I tried, but it doesn't work as expected on my system. I have few questions.

     

    1. Can you please confirm that you do not have any problem with caps lock LED? On my system, once LED is turned on (first time when I press caps lock), it can't be turned off. It's very annoying when I do not know if my caps is turned on or not.

     

    2. Is there a way to make cursor moving faster? It's too slow for my taste. It's almost twice slower than with ApplePS2Controller. Can I change anything in plist to make it faster?

     

    3. Is there any way to make PrtScr and Insert keys to work? I need those two keys, but they are dead on my system. Karbiner EventViewer doesn't register a keystroke when I press any of them. I am using VI editor a lot on linux servers so I absolutely need this key. I am using PrtScr to initiate a screenshot with Karabiner complex modification. Can I activate those dead keys with some change in plist or code change + recompile is needed?

     

    4. How can I find my APLS version?

     

    5, Does any complex gesture works for you? For example, 4 finger gesture like Pinch to restore.

     

    EDIT:

     

    I have v7 version.

    2018-11-01 22:58:50.637303+0100 0x100      Default     0x0                  0      0    kernel: (kernel) ALPS: Found a V7 TouchPad with ID: E7=0x73 0x03 0x0a, EC=0x88 0xba 0x2a
    2018-11-01 22:58:50.678168+0100 0x100      Default     0x0                  0      0    kernel: (kernel) ALPS: TrackStick detected... (WARNING: V7 TrackStick disabled)
    2018-11-01 22:58:50.678172+0100 0x100      Default     0x0                  0      0    kernel: (kernel) ALPS: TouchPad driver started...

     

  10. For me, ApplePS2Controller.kext actually works best of all mentioned ones. Your system will treat your touchpad as a mouse, so you would not be able to use gestures, but cursor movement is fast and smooth. Keyboard works flawlessly except mentioned caps issue.If you just remember that you need to press caps once to turn caps on, but 3 times to turn it off, you can easily live with this one.

     

    Original VoodooPS2 can be used (with a little plist tweak), but your touchpad will be treated as mouse, same as with ApplePS2Controler. It's much better to use first one in my opinion.

     

    You can use  R6Bronxteck version of ALPS touchpad driver on HS. Gestures will work (or at least some of them), but cursor movement is almost two times slower than with ApplePS2Controler. PrintScr and Insert keys will be dead. If you need insert key for any reason, avoid this one. There is also an issue with caps lock led (at least on my system). Once led is turned on, it will never be turned off until you reboot.


    For help related to DSDT patching, you need to post your origin folder.

     

    On Clover GUI screen press F4. Boot to OSX and compress and attach the origin folder from EFI/Clover/ACPI/Origin

     

    Since you have working Windows you might even mount EFI partition from there and comperes and post your origin if you can't use OSX to do that.

  11. I had a copy of A19 origin folder from your model, so I checked DSDT and it turns out that required patch for XPRW should be same as mine.

     

    I removed SSDT-DDGPU.aml, since you do not have nVidia. I also removed Legacy_Sierra_QMI.kext and all sensors kexts. You can add any of those later if you need them.

     

    This should work just fine, but if it turns out that you have any problem related to USB ports, remove USBPorts.kext from kexts/Other folder. 

     

    Even iMessage and FaceTime should work if your account is not one of those that require genuine MLB/ROM.

     

    Only thing that really require your attention is your Wi-Fi. I am using external TP link USB Wi-Fi device, so I do not have kext for Broadcom Wi-Fi. You need to add those yourself.

     

    BT kexts are there and those works fine.

     

    Let me know if it works for you.

     

    CLOVER E7450.zip

     

    btw. when you are replying to the last post in any thread, do not quote that whole message. That will just make reading harder, not easier as you probably wanted.

  12. Sure, no problem, but you need to be aware that some things in my Clover folder are system dependent. I have E7450 with nVidia and I have A20 BIOS (released two days ago). What is your system? I do not see that info.

     

    In patched folder I have those AML files:

    SSDT-PNLF.aml is same as the one that you already have - needed for Intel brightness control
    
    SSDT-GPRW.aml, SSDT-EH01.aml, SSDT-EH02.aml and SSDT-XHC.aml - those 4 are needed to fix instant wake issues
    
    SSDT-DDGPU.aml is needed only on model with nVidia - this patch will disable nVidia 

    SSDT-DDGPU is not same as in Rehabman's repo. This one is for RP05, not for PEG0.

     

    I am using WhateverGreen with 32MB framebuffer patch (the one from WG Intel FAQ). This one fully replace IntelGraphicsDVMTFixup. Since I have 16GB of RAM, I am also using patch to increase VRAM to 2560MB.

     

    Patch in config that is required in order to replace GPRW with XPRW method (for wake issues) is dependent on A20 version of E7450 BIOS for nVidia model.

     

    I am using AppleBacklightFixup.kext, so I do not need to patch com.apple.driver.AppleBacklight in config. 

     

    I am using Legacy_Sierra_QMI.kext that I made. It's for DW5809e LTE.

     

    I am using MacBookAir7,2, but I consider switching to MacBookPro12,1 SMBIOS.

     

    Everything else is same as it would be for any other similar laptop.

     

    Since I need to replace my serials with new generated ones before send,  send me your origin and I will also fix wake patch to match your DSDT, so you do not have to do that yourself.

     

    EDIT:

     

    Almost forgot. I am also using USBPorts.kext created with FBPatcher. This one is for MacBookAir7,2 and will not work on any other SMBIOS. For MacBookPro12,1, new kext should be created. If your ports are different than mine, you might also need to create this kext again.

     

    You need to add USBInjectAll.kext before using FBPatcher, but USBInjectAll.kext SHOULD BE REMOVED before using generated kext.

     

    Do not use Clover USB port patches. FakePCIID_XHCIMux.kext is not needed with USBPorts.kext.

     

    Do not combine those kexts in any way, this only can make your life a living Hell.

  13. @Jake Lo I finally managed to properly apply USB3 _PRW 0x6D (instant wake) hotpatch alternative.

     

    SSDT-GPRW.dsl and SSDT-UPRW.dsl are basically same. Only difference is that one replaces GPRW method and other replaces UPRW method. That's was clear from the beginning, but I overlooked some very important things.

     

    Static patch actually have 4 parts. First part is related to patching of _PRW calls and other 3 parts are related to injection of some Apple USB properties into EHC1, EHC2 and XHC. Hotpatch alternative to those 3 parts are SSDT-EH01.dsl, SSDT-EH02.dsl and SSDT-XHC.dsl.


    So, we need those 4 files in patched folder: SSDT-GPRW.amlSSDT-EH01.amlSSDT-EH02.aml and SSDT-XHC.aml.

     

    SSDT-EH01.aml and SSDT-EH02.aml needs two additional patches in Clover - change EHC1 to EH01 and change EHC2 to EH02. That's easy part.

     

    Critical and a little tricky part is replacing GPRW with XPRW method. Tricky part (at lest when you do it for the first time) is that we need to change method itself, but not calls to the method. This part is BIOS dependent, so it's not universal and needs to be found.

     

    DSDT should be decompiled with -l option in oder to get mixed view.

    $ iasl -l DSDT.aml

    You need to find GPRW method. In A20 BIOS that I installed tonight, this looks like this

            Method (GPRW, 2, NotSerialized)
            {
                PRWP [Zero] = Arg0
                Local0 = 
      B728: 14 40 06 47 50 52 57 02 70 68 88 50 52 57 50 00  // [email protected]
      B738: 00 70                                            // .p

    Method calls stats with 0x14, so we need to replace 14400647 505257 with 14400658 505257 in Clover.

     

    If I open MaciASL from Launcpad it will open system DSDT. If I search for XPRW, it is changes just in one place, where it should be changed.

        Scope (\)
        {
            Name (PICM, Zero)
            Name (PRWP, Package (0x02)
            {
                Zero, 
                Zero
            })
            Method (XPRW, 2, NotSerialized)
            {
                Store (Arg0, Index (PRWP, Zero))
                Store (ShiftLeft (SS1, One), Local0)
                Or (Local0, ShiftLeft (SS2, 0x02), Local0)
                Or (Local0, ShiftLeft (SS3, 0x03), Local0)
                Or (Local0, ShiftLeft (SS4, 0x04), Local0)
                If (And (ShiftLeft (One, Arg1), Local0))
                {
                    Store (Arg1, Index (PRWP, One))
                }
                Else
                {
                    ShiftRight (Local0, One, Local0)
                    FindSetLeftBit (Local0, Index (PRWP, One))
                }
    
                Return (PRWP)
            }
        }

    Sleep now works even when I am on power adapter, not only when I am on battery. Same as with static patch version.

     

  14. AppleBacklightFixup.kext and AppleBacklightInjector.kext are very similar. Difference is that AppleBacklightInjector.kext requires additional patch in config (change F%uT%04x to F%uTxxxx). AppleBacklightFixup.kext doesn't require that patch. You need only one of those.

  15. I have very strange problem. My system goes to sleep without issue if I am on battery, but it wakes up instantly on power adapter. Looks like that cause of the problem is hibernation that keeps coming back.

     

    Hibernation was disabled, but somehow it's enabled again?!

    System-wide power settings:
    Currently in use:
     standbydelaylow      10800
     standby              1
     womp                 0
     hibernatefile        /var/vm/sleepimage
     powernap             0
     gpuswitch            2
     halfdim              1
     networkoversleep     0
     disksleep            10
     standbydelayhigh     86400
     sleep                1
     autopoweroffdelay    28800
     hibernatemode        3
     autopoweroff         1
     ttyskeepawake        1
     displaysleep         10
     Standby Battery Threshold 50
     lidwake              1

     I disabled it again. Let's see will it be reseted again.

    System-wide power settings:
    Currently in use:
     standbydelaylow      10800
     standby              1
     halfdim              1
     hibernatefile        /dev/null
     powernap             0
     gpuswitch            2
     disksleep            10
     standbydelayhigh     86400
     sleep                1 (sleep prevented by coreaudiod)
     autopoweroffdelay    28800
     hibernatemode        0
     autopoweroff         1
     ttyskeepawake        1
     displaysleep         2
     Standby Battery Threshold 50
     lidwake              1

    I was writing the message about sleep issue that I have when I noticed this. I was confused, since there is nothing strange in my log related to Wake reason, and I was sure that my hibernation was disabled.

     

    I actually already seen this few days ago and disabled hibernation. I thought I messed something up in some of my experiments, but now I see that this coming back.

     

    EDIT:

     

    I just remembered that I restored defaults in Energy Saver last night while I was trying to figure out what's wrong with my sleep. That reseted my hibernation to defaults.

     

    If you ever reset Energy Saver settings to defaults, you need to disable hibernation again.

     

    EDIT 2:

     

    Any change in Energy Saver setting will cause restore of default hibernation settings. I just disabled Power Nap and hibernatemode is back to 3.

  16. That's fine. That folder is there just to help you to copy those files after you finish your installation to proper place. Those kexts are not injected with Clover from that folder.

     

    I just noticed that you are using A19 BIOS with patched files that are not from A19 for your model.

     

    Replace patched folder and config with those from this archive. I took A19 files from Jakes bootpack for your model and changed config to use proper sort order of those.

     

    A19.zip

  17. What FakePCIID_XHCIMux.kext do in /S/L/E? Remove it from there.

    Why do you have a folder called 4297 in /S/L/E?! Remove that folder and it's content. Looks like you have another copy of FakePCIID_XHCIMux.kext there.

     

    Having USBInjectAll.kext and FakePCIID_XHCIMux.kext on same machine is straight way to hell. Remove them both. You can add FakePCIID_XHCIMux.kext if you really need it to /S/E later. 

     

    Remove EAPDFix.kext, you do not need it anymore.

     

    If it still doesn't work, try to temporary remove intelhaxm.kext and see will it help.

     

  18. I know that you do not have nVidia. That's why I put your AML files from your patched folder there and not mine.

     

    Can you please post list of your files in /Library/Extensions? Did you put any kext in /System/Library/Extensions? I suspect that you have something there that makes problems to your system.

     

     

  19. Backup your complete Clover folder and put this one from archive instead. I copied my Clover folder, replaced my AML files with yours and combined things that you need from one or another folder. I also changed model to 12,1 (i am using 7,2) and generate new serials for you.

    CLOVER.zip

     

    EDIT: Please copy themers and tools folders from your Clover.

  20. Jake already told you that your DropTables is not good in another thread. You still have CpuPm instead of CpuSsdt there. Fix that first.

    Remove AptioMemoryFix.efi from drivers64UEFI. Where that came from?

    Remove ssdt.aml from your ACPI/patched and do not generate new one.

     

  21. What is the status of your WWAN card? ONLINE, LOW POWER MODE or something else?

     

    It is possible your device is not properly initialized. Can you post Legacy_Sierra_QMI.kext that you are using? Info inside must match your device.


    If your device is in ONLINE mode send PPP log, so we can try to figure out what is wrong.

     

    If your device is in LOW POWER MODE, you can try to bring it to ONLINE mode. Check BIOS and try with WiFi keyboard switch like would you do in Windows (FN + button with WiFi icon).

     

     

  22. I am sorry, I think I made an oversight.

                    Method (_PRW, 0, NotSerialized)  // _PRW: Power Resources for Wake
                    {
                        Return (GPRW (0x69, 0x04))
                    }

    Can you try to rename GPRW instead of UPRW in config

    change GPRW to XPRW     47505257     58505257

    and to replace SSDT-UPRW.aml with SSDT-GPRW.aml?

     

    SSDT-GPRW.aml.zip

     

    EDIT:

     

    I just tried this on my machine and my hot patched DSDT looks promising:

                    Method (_PRW, 0, NotSerialized)  // _PRW: Power Resources for Wake
                    {
                        Return (XPRW (0x69, 0x04))
                    }

    Please let us know if it works for you.

×
×
  • Create New...