Jump to content

Search the Community

Showing results for tags 'sd card'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OSXLatitude
    • Announcements & News
    • Feedback
    • The Archive
    • Team blogs
  • OS X Installation Guides
    • Asus
    • Acer
    • Dell
    • HP
    • Samsung
    • Lenovo
    • Gigabyte
    • Toshiba
  • Help and Support
    • FAQs & Tutorials
    • Dell Systems
    • Acer Systems
    • Asus Systems
    • HP Systems
    • Lenovo systems
    • Samsung Systems
    • Toshiba systems
    • Intel-based Systems
    • AMD-based Systems
    • Software matters or issues
    • macOS previews (dev & public beta)
  • Technical Information, Projects and other Research & Development,
    • Hardware technical information
    • Projects
    • Other Research
    • Compatibility Query
  • Linux & ChromeOS
    • ChromeOS
  • E.D.P (Limited Read-Only access)
    • About EDP
    • Issues and bugs
    • Models under research for EDP
    • EDP Development

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Twitter


FaceBook


GitHub


Location


Interests

Found 3 results

  1. My E6420 does not recognize SD cards. There is no response when a card is inserted.
  2. Hi everyone, first of all I wanna thank Hervé for his fantastic guide on how to hackintosh our Latitude E6220. I want to start saying that I'm running Sierra, but I haven't followed the guide entirely, because, after the installation completed and I booted into the main HDD, I installed Clover instead of Enoch. I did this because I basically hate those legacy bootloaders, as they gave me lots of problems when I hackintoshed my other laptop, an Acer Aspire 5750G, so I don't want to use them if it's not mandatory. Also, I don't want to tamper with S/L/E if I can. Right now almost everything is working, but I have a little strange problem. When I first boot up the laptop, the eSata port does not work, and the SD card reader, even though is recognized, doesn't show any card in it. However, if I put the computer to sleep, then I wake it up, both start working without a hitch, I can hotplug the eSata port and the reader mounts without any problem. Is there a way to fix this under Clover? My lappy: Dell Latitude E6220 i5-2520M, HD3000 8GB 1333MHz RAM macOS 10.12.5 Sierra Clover r4077, using Hervé's DSDT and generated SSDT Boot args: darkwake=0 slide=0 I attach my config.plist, I think it could be useful. Thanks in advance config.plist.zip
  3. Hello all, This topic will cover how to enable the SD Card reader in the Latitude E6410. The information below try to describe my Latitude E6410 configuration: 2.4GHz Intel Core i5 4GB 1067 Ghz DDR3 NVS 3100M 512 MB (1440x900) BIOS version A13 This information worked for me in Mavericks and Mountain Lion. PLEASE, BACKUP YOUR MEMORY CARD BEFORE TRYING THIS PROCEDURE. I CAN'T GUARANTEE IF THE DATA WILL BE SAFE AFTER YOU TEST WITH THE INFORMATION DESCRIBED BELOW. First, you need to find out the "Vendor ID" and the "Device ID" of your SD card controller. I used the "System Info" tool from El Coniglio and Oldnapalm. Another way to get this info is using the "lspci" command in the terminal: (you need to have the "lspcidrv.kext" in S/L/E) localhost:/ piglesias$ lspci -nn | grep SD pcilib: 0000:01:00.0 64-bit device address ignored. pcilib: 0000:01:00.0 64-bit device address ignored. 04:00.0 SD Host controller [0805]: Ricoh Co Ltd MMC/SD Host Controller [1180:e822] (rev 03) In my case, the SD card reader has the Vendor ID = 1180 and the Device ID = e822, as you can see in red above. With this information in hands, you can edit the "Info.plist" file from VoodooSDHC.kext (version 1.1.2b1). VoodooSDHC.kext.zip - Edit the file "VoodooSDHC.kext/Contents/Info.plist": In order to edit the Info.plist file, you can use any text editor. In my case, I used "vim". Inside the "Info.plist" file, search for the string "IONameMatch". You will find something like this: <key>IONameMatch</key> <array> <string>pciVVVV,DDDD</string> </array> Replace the "VVVV" by the Vendor ID and the "DDDD" by the Device ID you got from your hardware. Copy the VoodooSDHC.kext to /System/Library/Extensions and then repair the permissions and rebuild the S/L/E cache with your preferred tool. I used Kext Wizard. Reboot the machine in order to load the VoodooSDHC.kext. After the reboot, insert the SD card and check inside the Finder. Let me know if it works for you. Troubleshooting: Check if the VoodooSDHC.kext loaded. Type in the command line: localhost:~ piglesias$ kextstat | grep VoodooSDHC 53 0 0xffffff7f80b1e000 0x4000 0x4000 org.voodoo.VoodooSDHC (1.1.2b1) <15 11 5 4 3 1> If not loaded, check the /var/log/system.log file and try to find the reasons why the "VoodooSDHC.kext" didn't load. Check the session "OSBundleLibraries" in the bottom of "VoodooSDHC.kext/Contents/Info.plist". There you will see the dependencies of the kext. Verify if you satisfy all the dependency versions with your installed kexts. Another way to check if your kexts are satisfying the "VoodooSDHC.kext" dependencies, you can try in the command line: localhost:~ piglesias$ kextlibs -undef-symbols /System/Library/Extensions/VoodooSDHC.kext For x86_64: com.apple.iokit.IOStorageFamily = 1.9 com.apple.kpi.iokit = 13.0 com.apple.kpi.libkern = 13.0 com.apple.kpi.mach = 13.0 2 symbols not found in any library kext: __ZN9IOService19_RESERVEDIOService0Ev __ZN9IOService19_RESERVEDIOService1Ev In my case, these last two symbols not found, don't disturb the kext to be loaded.
×
×
  • Create New...