Jump to content

Help needed for ASUS K556UR Fn Keys DSDT Patch


Recommended Posts

Can anyone help me with post installation of my ASUS K556UR Laptop.


I already installed macOS Sierra 10.12.6. Everything working fine with different kexts found from so many places.


My Issues are

(1). PS2 Keyboard working fine with RehabMan's Voodoo PS2 Controller.kext. But Trackpad not working. I can use USB Mouse.

(2). My Ethernet is working, Tried to install kexts for Atheros 9565 Wifi. Wifi is On, but cannot find any networks.

(2). Installed ASUSNBFnKeys.kext and got most of the function keys working (Fn+f1 - Sleep, Fn+f10 - Mute, Fn+f11 - Decrease Volume, Fn+f12 - Increase Volume, Fn+Down Arrow - Play etc). But some other not working (Fn+f2 - Wifi / BT, Fn+f5 - Lower Brightness, Fn+f6 - Increase Brightness, Fn+f9 - Touchpad). I strongly believe because of this my Touchpad and Wifi not working.


I have read DSDT need to be patched to get al the Fn keys to work. I need help for getting it done. Currently I am not using any DSDTs.


My Laptop Configuration is as below.


Intel Core i7 7500 Kaby Lake

24 GB of RAM (8GB Built in + 16GB)


2 TB Seagate FireCuda SSHD

Intel HD 620 / Nvidia G930MX


  • Thanks 1
Link to comment
Share on other sites

  • Moderators

Most likely your Asus has Elantech touchpad and will require ApplePS2SmartTouchPad.kext and some DSDT patching.

You'll need DSDT patching to disable your Nvidia card as well to maximum battery life.

Boot to Clover GUI. Hit F4 on the keyboard. Continue booting to OSX

Compress and attach the Clover folder here for review.

List the version of BIOS you're running too.

Link to comment
Share on other sites

Tried it, got kernel panic. Error message below.


panic(cpu 2 caller 0xffffff80076355be): "A kext releasing a(n) ApplePS2MouseDevice has currupted the registry. "@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3789.70.16/libkern/c++/OSObject.cpp:200

Debugger called: <panic>

Backtrace (CPU 2), Frame : Return Address

0xffffff82d3173ec0 : 0xffffff80070e953c

Link to comment
Share on other sites

I removed the VoodooPS2Controller.kext. Cant even Boot when I put the Patched folder in ACPI inside Clover. Boots correctly if I remove all the files from it. Also with ApplePS2SmartTouchPad.kext not even my Keyboard is recognized. So I put back VoodooPS2Controller.kext in Kexts > Other folder and its working. 

But still the Touchpad and some function keys not working (Brightness Incr. Decr & Wifi/Bluetooth On Off functions as I notice)

Link to comment
Share on other sites


  • Create New...