Jump to content

e7270: Can't make NVME disk appear for installation


dsarch
 Share

Recommended Posts

Hello Friends!

 

I have two NVME SSDs here, both 512gb, which have windows installed and working:

  • Samsung NVME 960 Pro m.2
  • WD Black NVME PCIe (which I changed from 512k to 4k but the installer still can't see it)

I have been trying to make them work (one at a time) for the past two weeks and I'm exhausted, since I tried everything that saw in many, many forums and blog posts.

 

The hardware is a Dell Latitude e7270 with i7-6600u and 16GB DDR4, but for some reason, the OSX installer seems to always load IONVMeFamily.kext and ignore any kind of patch that I try to use, so I can't use any of the NVME disks with a OSX Sierra USB stick.

 

Here are my clover files: clover_dsarch.zip

 

Please, can some help me with this? I literally don't know what to do to fix this and install OSX on these disks.

 

Thanks a million for any help!

Link to comment
Share on other sites

Hey Jake! I'm trying to install 10.12.6.

 

I tried to install High Sierra before but could not get the installer to boot and got stuck in different parts of the HS boot.

 

Here is what I tried:

 

1) Created HS pendrive

2) Plugged the NVME disk on the motherboard slot

3) Installed Clover from RehabMan: Clover_v2.4k_r4359.RM-4506.7036cf0a

4) Decompressed EFI_4359.zip and put on /EFI

5) Tried with these bootpacks:

     - E7270_1.17.5_HS.zip

     - E7470_1.17.5_HS.zip

     - E7470_1.17.5_alternate.zip

 

When I booted, none of them worked and had different errors, what kind of information can I provide for help?

Link to comment
Share on other sites

Hey Jake! It worked! Seems it is installing right now!!!!!

 

What was wrong? You did something that it recognized the drive during boot, whereas with my files it seemed to load IONVMEFamily every time, ignoring the patches.

 

I have been trying to fix this for the past two weeks and you fixed that in a snap!

 

I will try with High Sierra as well - could you generate a bootpack for High Sierra?

Link to comment
Share on other sites

Update: It does the initial installation (disk partition and installation) but when it reboots it goes to the installer again =(

 

Seems it was just hidden and it is installing now =)

 

What was wrong in the files I sent you? This is the files I used when I was following Rehabman's post: clover_dsarch_hacknvme.zip

 

Thanks for everything, Jake!

Link to comment
Share on other sites

Hmmmmm, now it makes sense! Thanks a lot, Jake!

 

In your opinion, is Sierra more stable than High Sierra in your hackintoshes? Is there any problem with High Sierra? 

 

Also, do you recommend some guide on how to generate the DSDT/SSDTs so I can generate them myself?

 

Thanks again for everything!

Link to comment
Share on other sites

Hey Jake!

 

Just finished the installation, bluetooth is working but wifi is not.

 

Do you have any idea on what can I do to fix it?

 

Nevermind, the problem is that I added the kexts in Library/Extensions instead of System/Library/Extensions.

 

Thanks a lot!

Link to comment
Share on other sites

 Share

×
×
  • Create New...