Jump to content

[FIXED] E7450: issues with audio and trackpad after sleep


Recommended Posts

E7450 A18 5500HD MacbookAir7,1 10.13.3


Have successfully installed and am using High Sierra on this hardware by doing the following:
Follow the guide combining files from the generic efi package  along with the 

E7450_HD5500_Only_A17_HS.zip bootpack to create your clover image.

Tweak the plist to a MacBook Air 7,1 and turn on AGLowPowerState in devices and

add 0x64 to HorizontalSyncPulseWidth and add 0xA5 to VideoInputSignal.
In bios,  Legacy options on, Hard drive in AHCI mode.


Full Installer created by running the stub wizard until it prompts for a reboot, killing it before reboot,

Then running

sudo mkdir /Applications/Install\ macOS\ High\ Sierra.app/Contents/Shared\ Support
sudo cp -r /macOS\ Install\ Data  /Applications/Install\ macOS\ High\ Sierra.app/Contents/Shared\ Support

Following the guide, I continued on my merry way,

using the files from both the A17 High Sierra Hotpack and also the Sierra EFI pack.

After booting the USB key, formatting the drive, and running the first part of the installer,
it fails with "osinstall.mpkg appears to be missing or damaged". But this isn't the bug.
Opening the terminal and running 'cat /var/log/installer.log' reveals that the installer 

Cannot find /macOS\ Install\ Data\/InstallESDDmg.pkg. The file simply isn't present.

However, it IS present on the USB key. I guess the installer is buggy and doesn't copy the file?

sudo cp  /Volumes/"Name of Install USB Drive"/Install\ macOS\ High\ Sierra.app/Contents/Shared\ Support /InstallESDDmg.pkg /Volumes/"Name of drive to be installed to"/macOS\ Install\ Data/

Follow by a reboot, and the installer continues to work.

Now for my only problem so far: When I close the lid and open it, the trackpad doesn't work anymore.
I have tried the latest VoodooPs2Controller from Rehabman(after removing ApplePs2Controller from clover, otherwise the

AppleACPI will stall perpetually).

It doesn't work after sleep either. Is there something I need to change?

Fixed, text in bold- thank you viking1304 and Jake Lo!

Link to comment
Share on other sites

Causes graphical corruption during late boot phase followed by computer immediately going into standby.

When resumed from standby, graphical corruption no longer evident but pad/point still don't work.
Note: this is with appleps2controller from bootpack in clover/kexts/other, if I try this with voodoo it just stalls.
Also I no longer have sound. also brightness hotkeys don't work. 

Link to comment
Share on other sites

ACPIPoller experiment was a mistake. 

Alright. SMBIOS reset, clover configured to emulate MacBook Air 7,2 now.
Wifi, sound, trackpad working before and after Sleep-

but still. On boot, graphical corruption until lid is closed for a moment. But otherwise very good now!

Link to comment
Share on other sites

Few days ago I installed A18 for a quick test and I was prepared to restore A17 immediately, but everything works the same, so I decided to keep it. I have few slight issues, but those issues are same with both versions of BIOS.


I also have a slight screen glitch on boot when progress bar is around 50%. It lasts about half of a second, but I still can notice itSecond stage boot patch just doesn't work for me. I am using 10.13 version of that patch (since I am on 10.13.2). I even tried to add new Clover flag HorizontalSyncPulseWidth (witch is introduced as second part of solution for that specific issue) with values of 100, 32 and 35, but none of them worked for me. I tired with Clover 4369 and Clover 4380. I have no idea what else to try, but you can try to use that patch alone or with  HorizontalSyncPulseWidth=100 in boot params. Maybe it would work for you.


I also have a slight problem with sound, but only if I close the lid when I am on battery. You can try to experiment with values inside EAPDFix.kext as Jake suggested to me to resolve similar issue.


Brightness and trackpad works just fine here with both A18 and A17.

Link to comment
Share on other sites

The audio, trackpad issues are fixed.  I have little/no corruption on boot, only for a flash of a second halfway

up the boot process.
I Enabled AFGLowpowerstate. 

I Added 0x64 to HorizontalPulseWidth and 0xA5 to VideoInputSignal.


Link to comment
Share on other sites


  • Create New...