Jump to content

E7440: trouble updating High Sierra to 10.13.1


bartl
 Share

Recommended Posts

I cannot execute any updates? Do I have a sort of NVram problem?

 

I tried to update from Sierra to HS by just using the installer app. (Preparation like adding apps.efi, updating clover etc. done in front certainly).

The update started and after a short time it rebooted the system. Then my Sierra started again acting like nothing has been done before.

 

Then I installed HS via an USB installer. So, to keep my Sierra partition, I shrinked it and installed HS to the free rest space. This worked fine. HS started up like expected. It looks like it is working fine on my hardware. 

 

The problem occurs after 13.1 has been released. I run the update and once again the system reboots but started with 13.0 like nothing has happened in between.

 

My thought are currently that a special NVram entry is being placed by the installer/updater but it does not persist a reboot of my machine? Or does any one knows whats is going on with my system - because I also do not find any similar behaviour being posted in any forums?

 

What I have done so far:

1. I tried to add a boot parameter via shell command to the nvram - was not recognised at new boot.

2. I tried to create a /etc/shutdown... script to copy nvram to disk but no luck. Clover is always saying: "PutNvramPlistToRtVars: nvram.plist not found"

 

No further idea on my side.

Link to comment
Share on other sites

 Share

×
×
  • Create New...