Jump to content

E7470 with Skylake CPU getting KP


freeuser616
 Share

Recommended Posts

Hi guys, 

 

it's been a while since dealing with hackintoshs..

 

Last time i used el capitan on my old E6230 and at least i was able to have it up and running.

 

I tried to install high sierra 13.0.64 and even 13.1.5 (cant find any newer for download) on my E7470 but had no luck so far.

Whenever i try to boot from the stick i get KP.

 

I must admit that it's still damn hard going through all those guides and (cross)links in order understand what exactly is needed, how things work and which files are the right ones.

 

I did a detailed list of all steps i went trough hoping someone can find the missing puzzle / error i did:

  • Hardware (see attached screenshot):
    • Dell Latitude E7470
    • CPU = Intel Core i7-6600U Skylake-U
    • GPU = Intel HD Graphics 520 Skylake-U GT2
    • RAM = SK Hynix HMA81GS6AFR8N-UH
    • SSD = SanDisk X400 M.2 2280 256GB
    • Motherboard = Dell
  • BIOS Settings (got them from here):
    • restore bios = default
    • TPM = Disabled
    • Secure Boot = Disabled
    • UEFI = Enabled
    • SATA Operation = AHCI
    • Wake on Lan /WLan = Disabled
    • Enable Legacy Option ROMs = Enabled
    • TV for Direct I/O = off
  • Installation with macOS High Sierra on a VM:
    • Format USB Stick with Disk Utility
      • erase
      • format = Mac OS Extended (Journaled)
      • scheme = GUID Partition Map
      • format = HFS+
  • Install High Sierra on USB Stick SanDisk 32GB with command:
    • sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction
  • Install Clover as described here
    • selected USB Stick as install location
    • customize
    • Install for UEFI booting only
    • Install Clover in the ESP
    • Drivers64UEFI\OsxAptioFixDrv-64
  • add Sierra bootpacks Only + Generic EFI for E7470 from this link
  • cobined (not deleted EFI folder)  bootpack EFI from here with generic EFI from here
  • deleted the EFI folder from EFI partition and added the one created with bootpack and generic EFI
  • added Lilu.kext, Lilu.kext.dSYM & IntelGraphicsDVMTFixup.kext to /EFI/Clover/kexts/Other
 
 
thank you in advance

post-118867-0-62524300-1520187250_thumb.jpeg

post-118867-0-03535900-1520187256_thumb.png

Link to comment
Share on other sites

thanks jake lo, 

 

i started from the usb stick to enter Clover... should something happen/appear when pressing F4?

i dont see anything happening...nonetheless i attached the EFI folder from the Stick.

 

currenty i have no access to my VM so i copied tghe EFI folder from within windows.. hope thats OK?

EFI.zip

Link to comment
Share on other sites

Thanks Jake Lo, 

 

finally i was able to boot from the stick and as a next step i did install macOS on my SSD drive without any problems.  8-)

 

  • nonetheless I'd really like to know / understand what the problem was / how it works.
  • further more, where can i find the guide for the next steps, in order to
    • have all drivers installed (especially for my WiFi Card),
    • booting to macOS without the USB stick
    • giving the mac the chance to come back from (sleep / black screen).. it freezes when the screen turns off.. or is it because of the hard drive that turns off after a couple of minutes?
Link to comment
Share on other sites

  • Moderators

Could be many things, different version of BiOS, different configuration, so the addresses are different. So patching from your extracted files is the way to go

 

Intel Wireless is not supported if that what you have. Click on my signature Wireless Cards for more info, you need an M.2 card

 

See my Clover guide here for Sleep and boot without USB stick

Link to comment
Share on other sites

thank you jake lo, unfotunately i do have an intel card.. what a shame dell using intel instead of their own dell cards. i will give it a try with the clover guide later.

 

jblparisi, why dont you just download both zip files already attached in the posts above?

Link to comment
Share on other sites

 Share

×
×
  • Create New...