Jump to content

[SOLVED] E7470 High Sierra Unable to Boot to Installer


kyle morton
 Share

Recommended Posts

Hi folks. 

 

I've set Bios to defaults, enabled AHCI, disabled virtualization options. 

 

I was never able to get the createinstallmedia option to work, so I've been using the macOS High Sierra Patcher to write the image to USB drives and then proceed from there to install clover. 

 

Bios version: 1.17.5

Specs: i5-6300u

1x8GB DDR4 Module

Intel 8260 (waiting on wifi card purchased to replace this)

256gb m.2 Sata

 

Used the method for High Sierra here and the E7470_1.17.5_HS.zip boot pack found in This Post.

 

Using a USB 2.0 drive, installed clover v2 4k_r4429, setting up for UEFI and selecting the necessary driver as notated in the above guide. 

 

if I leave things stock, I get various kernel panics. I have tried various versions and mixes of different kexts and config.plist modifications, and it either get's stuck somewhere, or it KP's with various kexts loaded. 

 

I'm in the process of starting over with a completely different USB Drive from scratch. 

 

I've attached my current compressed EFI.zip folder that includes the latest DSDT extraction from clover. 

 

Thanks in advance for any help!

EFI.zip

Link to comment
Share on other sites

I'm attempting that now. Currently, it's been sitting on the attached screen for the last 10 minutes...how long should I give it before I call it a failed boot?

 

Also, Should I be modifying the config.plist or should I be leaving it as-is? I saw a few changes that were mentioned in the tutorials I was attempting to follow, but I couldn't see exactly where I was supposed to modify what and the versions of configurator were different so mentioned locations weren't the same. 

IMG_1131.JPG

Link to comment
Share on other sites

18 hours ago, Jake Lo said:

Try this, replace contents into /EFI/Clover

E7470_morton.zip

 

You are a master at this. if I may ask, what did you change? What do you look for? How do you edit your files/configs? I've always been fascinated by this world but never have had the time to dig into it very deeply. 

To give a status update, I am successfully and typing from a seemingly fully-working instance of High Sierra 10.13.6 with clover v2 r4449. As far as I can tell it's working as well as I'd hope. Now just to wait for the WiFi card to come in. Thank you so much!

Link to comment
Share on other sites

  • Moderators

Even though you have the same model, different BIOS version /settings and hardware configuration would require re-patching of your native files (DSDT/SSDT). That being said, when you replace your Wifi card later and it's not detecting, we'll have to re-patch again with new native files since the change in hardware.

Link to comment
Share on other sites

  • Moderators

Well, let's see what happens after you replaced the card. If it doesn't detect it, then just send me the Origin folder after you hit F4 from Clover. Of course clear it first before doing so no duplicate files.

Link to comment
Share on other sites

Purchased and received a DW1830, installed it with literally zero changes to any of the settings and everything just worked OOB. 

 

So now, I am looking at what seems to be a fully-working install on this e7470. 

 

Is there anything else I should check? What are the typical "ok, I'm set" check list items? 

I haven't tested sleep, I haven't tested external displays. 

 

What's working: 

 

Wifi

Mouse (both track pad and track point)

Keyboard

Sound

Backlighting

Booting from internal

Webcam

Hotkeys (although they're mapped to a Mac keyboard, not a huge issue, and I'm sure this can be changed later)

 

What else should I be checking for functionality?

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...