Jump to content

[SOLVED] E7250 - booting High Sierra 10.13.4 installer impossible - gets stuck/hangs w/o panic


abottwool
 Share

Recommended Posts

Hello community,

Please lend me a hand with the following issue, I spent a while trying to fix this on my own but cannot:

 

Dell Latitude e7250

Broadwell

Intel Core i7-5600U

Intel HD Graphics 5500

Firmware A17

UEFI/BIOS settings correctly set (as working with sierra previously)

 

Previous state: Running MacOS Sierra on the internal SATA M2 SSD without any issues

Current state: Wiped the internal SSD with dd, empty and no partition table yet in preparation of fresh High Sierra install

 

Steps to create boot medium (all the official steps from guides):

1) Used Apple provided command line tool for creating boot media

2) Installed the latest (official, no fork) Clover bootloader

3) Merged the generic EFI folder EFI_4439.zip

4) Updated to newest lilu 1.2.3

5) Installed specific High Sierra bootpack

5a) Tried bootpack E7450_HD5500_Only_A17_HS.zip from https://osxlatitude.com/forums/topic/8514-dell-latitude-e7450-clover-uefi-only/?tab=comments#comment-76261

5b) Tried bootpack E7450_HD5500_Only_A19_HS.zip from same source as above

5c) Tried bootpack E7250_A17.zip from https://osxlatitude.com/forums/topic/10318-solved-e7250-unable-to-boot-high-sierra-installer/?tab=comments#comment-76635

 

The install USB thumbdrive is currently using the clover config from 5c and the bootpack from 5c.

 

Leaving out step 5 altogether leads to a kernel panic like here: https://osxlatitude.com/forums/topic/10318-solved-e7250-unable-to-boot-high-sierra-installer/?tab=comments#comment-76617

 

With step 5a, 5b, and 5c the installer just stops and hangs at a random point during boot (after selecting the installer partition with Clover), always around 3 seconds after choosing the installer partition in clover. It is not a kernel panic, the verbose mode just stops scrolling and hangs there, the CPU gets hot after a few minutes with the fan spinning and there is nothing that can be done other than turning it off.

 

I narrowed the issue down to the ACPI/patched folder, when it is empty I get a kernel panic and when I fill it with the files from the bootpacks, the hang occurs.

 

It seems that for my specific hardware, re-patching of the native files (DSDT/SSDT) might solve the problem. I have attached the origin folder after dumping the files with F4 in Clover. Now I know how to do basic troubleshooting, and I have learned a bit from having 3 other Hackintoshes at home all working fine after crying a lot. But I have never patched the native files myself. Can you refer me to a guide on how I can do that? Or could you patch them for me, if you are willing to? I do not know how time consuming that is - I saw a guide earlier this morning but can't find it again now.

 

I am not sure if my assessment of the problem source is correct though, perhaps I need to use an older High Sierra installer like 10.13.3? I really don't know and I could use your help. Thank you very much for your time!

origin.zip

Link to comment
Share on other sites

Hello and thank you very much - this immediately fixed the issue and the installation went through fine, all hardware except bluetooth is recognised ouf of the box (I don't really need bluetooth, not sure if the wifi card even includes it). May I ask whether this DSDT/SSDT patching is something I could do myself in the future? I will soon replace the bad low-res screen of this laptop with the better fullHD IPS version and I am not sure if it might require patching again. It might be useful for future MacOS versions too.

Link to comment
Share on other sites

  • Moderators

It your wireless is Intel, it's not supported, replace it with a DW1560.

No need to repatch the DSDT/SSDT for later OS X unless you have made hardware changes for BIOS changes.

Replacing the display will not need any change, should work right away.

  • Thanks 1
Link to comment
Share on other sites

I do have the DW1560 and Wifi works out of the box but it does not find a Bluetooth adapter. I checked and that card has Bluetooth included and apparently it should work on a Hackintosh. As I won't use it, I don't mind. I think it might require DSDT/SSDT modification but please do not bother with it, I don't want to spend more time on it myself, and you certainly have done enough on your own time to assist me. Thanks again!

 

FYI, kudos to you for making the sd card reader actually work as well. I was never able to do it but it works now :-)

Link to comment
Share on other sites

  • Moderators

don't forget to copy the kext in /EFI/Clover/kexts/Other/CopyTo/L/E to /Library/Extensions

Repair permission and rebuild cache

      sudo chmod -Rf 755 /L*/E*

      sudo chown -Rf 0:0 /L*/E*

      sudo touch -f /L*/E*

      sudo kextcache -Boot -U /

 

That should get the Bluetooth to work. Also check in system information under Bluetooth and USB to see if it appears.

  • Thanks 1
Link to comment
Share on other sites

I did that, and I verified with kextstat that the kexts I copied to /Library/Extensions are actually loaded, which they are. There is no Bluetooth found in the system information.

 

/Edit: More important to me would be using Filevault with APFS. I now did that, but Clover does not find the "filevault prebooter" partition to boot from, like it works on my other Hackintoshes with High Sierra and Clover. Only the recovery partition is listed and Clover can successfully boot that. In recovery, I can unlock the encrypted Macintosh HD, so the encryption should have been successful. It seem that the configuration of Clover somehow prevents the partition to show up. Is this fixable? It works out of the box with my other desktop hackintoshes...

 

This should work fine because High Sierras Filevault does not change the partition layout of the disk, it keeps the EFI partition with clover on it (thus I can enter Clover upon turning on the laptop), and AFAIK HS with AFPS is the first macOS version ever that supports native encryption with Clover out of the box...

Link to comment
Share on other sites

 Share

×
×
  • Create New...