Jump to content
mcintosh

E7270 Ultrabook i5

Recommended Posts

Because when I use High Sierra (even Mojave), there are several applications (at least 4 applications until I decide to change to El Capitan again) that I use to work with El Capitan on a previous laptop, which cannot run properly in High Sierra (even on Mojave, there are around 5 applications that cannot run properly). And this is a specific application. Not an easily updated / upgraded application.

 

I really apologize if you feel like spending time on this issue to helping me.

Share this post


Link to post
Share on other sites

boot to Clover, press F4.

Attach your USB to a working system, compress and attach /EFI/Clover/ACPI/Origin folder

I'll need to patch your files unique to your system

Share this post


Link to post
Share on other sites

Hmm, those are not the files I sent you for El Capitan. The Config and ACPI /Patched folder are not updated.

Have you tried with those files first?

Share this post


Link to post
Share on other sites

Yes, I already used EFI El Capitan that you sent both on the FD Installer and on the SSD that has El Capitan installed. And both of them can't boot normally to the desktop. Even if I use boot arg -igfxvesa and / or -no_compat_check. The result is like the picture I sent earlier.

 

20190612_004353.jpg

 

Why do I use the current EFI, because it can install and enter the SSD installed El Capitan. But the problem are :

1. I have to use boot arg -igfxvesa to boot until it enters the desktop.

2. The display is still 4MB after enter the desktop.

 

Maybe this can help a little :

When I execute ssdtPRGen.sh from terminal to generated SSDT.aml

 

ssdtPRGen.sh v0.9  Copyright (c) 2011-2012 by † RevoGirl

             v6.6  Copyright (c) 2013 by † Jeroen

             v21.5 Copyright (c) 2013-2019 by Pike R. Alpha

-----------------------------------------------------------

Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <

/Users/aufannada/Downloads/MASTERS/MAC/SYSTEMS/INSTALLER DELL LATITUDE E7270/TOOLS/ssdtPRGen.sh: line 3877: /Users/aufannada/Library/ssdtPRGen/Data/Versions.cfg: No such file or directory

 

System information: Mac OS X 10.11.6 (15G31)

Brandstring: "Intel(R) Core(TM) i7-6600U CPU @ 2.60GHz"

 

Notice: Downloading extractACPITables.zip ...

Notice: Downloading User Defined.cfg ...

Notice: Downloading Sandy Bridge.cfg ...

Notice: Downloading Ivy Bridge.cfg ...

Notice: Downloading Haswell.cfg ...

Notice: Downloading Broadwell.cfg ...

Notice: Downloading Skylake.cfg ...

Version: models.cfg v171 / Skylake.cfg v195

 

 

Scope (_PR_) {222 bytes} with ACPI Processor declarations found in DSDT (ACPI 1.0 compliant)

Notice: Downloading Restrictions.cfg ...

 

Notice: The LFM frequency in Mac-E43C1C25D4880AD6.plist is set to 1300 MHz!

    This restriction can be lifted with help of freqVectorsEdit.sh from:

   https://github.com/Piker-Alpha/freqVectorsEdit.sh

 

Generating ssdt.dsl for a 'MacBookPro12,1' with board-id [Mac-E43C1C25D4880AD6]

Skylake Core i7-6600U processor [0x406E3] setup [0x0705]

With a maximum TDP of 15 Watt, as specified by Intel

Number logical CPU's: 4 (Core Frequency: 2600 MHz)

Number of Turbo States: 8 (2700-3400 MHz)

Number of P-States: 30 (500-3400 MHz)

Adjusting C-States for detected (mobile) processor

Injected C-States for CPU0 (C1,C3,C6,C7)

Injected C-States for CPU1 (C1,C2,C3,C6,C7)

Warning: 'cpu-type' may be set improperly (0x0705 instead of 0x0905)

     - Clover users should read https://clover-wiki.zetam.org/Configuration/CPU#cpu_type

Error: board-id [Mac-E43C1C25D4880AD6] not supported by Skylake – check SMBIOS data / use the -target option

 

Screen Shot 2019-06-12 at 4.19.04 AM.png

It says that :

1. 'cpu-type' may be set improperly (0x0705 instead of 0x0905)

2. Error: board-id [Mac-E43C1C25D4880AD6] not supported by Skylake

 

In Clover Configurator - SMBIOS, Mac-E43C1C25D4880AD6 is MacBookPro12,1 - MacBook Pro (13-inch, Retina, Early 2015) Intel Core i5-5257U @ 2.70 GHz.

 

5257 is not Skylake

Share this post


Link to post
Share on other sites

Ok, try this, replace into /EFI/Clover. Files patched from your Origin folder. You can continue using the kexts folders as is, but maybe remove NoTouchID.kext.

Don't need to generate SSDT.aml, Clover Config has pluginType enable which does the same thing.

E7270_aufannada.zip

  • Thanks 1

Share this post


Link to post
Share on other sites

Oh God, I'm very grateful to you Jake. Now it works and booting is very fast entering the desktop. Just a few seconds. The display is now full to 1536MB. I am very happy. Thank you very much, Jake. You are the best.

 

Screen Shot 2019-06-12 at 6.37.10 AM.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...