Jump to content

Latitude 5414 Rugged - High Sierra 10.13.6


FoxND001
 Share

Recommended Posts

TLDR: Trying to get HS 10.13.6 running on a Latitude 5414 Rugged.  Most of it works.  Need some help patching DSDT/SSDT files in particular.

----------

Hello Everyone!  I've had some success with getting HS 10.13.6 running on a Latitude 5414 Rugged.  I'm working on getting a full how-to write-up going for this machine, but I need some help.

 

Some basic specs:
- Dell Latitude 5414 Rugged
- Intel Core i5-6300U @ 2.50 GHz
- 32GB DDR4 @ 2133 MHz
- 256 GB Solid State Drive
- 14" 1920x1080 touchscreen display
- Impact and water resistant

- BIOS version 1.18.0; BIOS was set to default settings, and then these tweaks were made (as of 2018-08-20):

  1) SATA mode set to AHCI

  2) Keyboard LED color set to green

  3) Legacy option ROM is disabled (e.g. box is unchecked)

  All other BIOS settings left at defaults for 1.18.0

 

Here's what is working thus far:
- Intel HD 520 graphics full acceleration (1536MB detected)
- Internal laptop display @ 1920x1080 (not at the same time with external HDMI)
- External HDMI output to monitor (not at the same time with internal laptop display)
- Internal keyboard and touchpad
- Audio out to speaker, headphone, and HDMI; HDMI Audio works if you connect to and external HDMI monitor with the power off, and then boot the system with the lid closed.
- Intel I219LM Ethernet
- Broadcom BCM93252Z WiFi and Bluetooth
- Built-in web camera
- SATA connector for HDD and DVD-ROM in AHCI mode
- SD card reader (macOS is bootable from SD Card)
- All USB ports
- Touchscreen (very basic single-point touch support only - NO multi-touch)

- 2018-08-19 - Audio in via microphone now working thanks to Jake Lo's patches and edits to config.plist.

- 2018-08-20 - Sleep, but only if you manually select the "Sleep" entry in the apple menu; once the system sleeps, and you get the "breathing" light, if you press the power button then the system successfully wakes up and appears to function normally

- 2018-08-20 - Inserting and/or removing the power adapter cable works correctly (and you get the chime sound when you plug in the power cable)

- 2018-08-20 - Brightness controls work in System Preferences -> Display; if you install Karabiner Elements, then you can control brightness via keyboard.

- 2018-08-21 - Multiple displays work with HDMI if you

   1) boot the system with no external connected

   2) connect an external display via HDMI

   3) wait for the external display to come up; the built-in will go black

   4) close the lid

   5) wait 5 seconds, then open the lid

   6) observe the internal display come on as primary, and the external display come on as secondary

- 2018-08-22 - Multiple displays work flawlessly with VGA

- 2018-08-22 - Radeon M360 is correctly disabled via patch

- 2018-08-22 - System will sleep consistently by selecting sleep from the Apple menu or by closing the lid; however, the system will not wake-up properly (see below for details on "not wake-up properly")

- 2018-08-26 - Sleep works as expected when booting from the SATA devices.

- 2018-08-26 - ExpressCard slot works as expected; was tested with ExpressCard 54 to USB adapter.  USB disable port limit patch was needed.

 

Here is what is NOT working:
- Sleep/power management - cannot suspend the system; it tries to go to sleep and the screen goes blank, then immediately tries to wake up but the screen does not come on; have to disable screen blanking to keep the screen from turning off; the OS immediately freezes if you remove or plug in the power adapter at any time. Closing the lid will blank the screen, but the system won't actually sleep; raising the lid from this state results in a black screen.  Also, if you sleep the system by manually selecting the "Sleep" entry in the apple menu and then you close the lid, when you open the lid the system will appear to try to wake-up, but the screen never comes back on.  System will sleep consistently by selecting sleep from the Apple menu or by closing the lid; however, the system will not wake-up properly.  When the system comes back up, it is sluggish, the keyboard will become unresponsive, and the system will freeze after a few mouse clicks.  Additionally, the WiFi menu is incorrect after the system wakes-up, with multiple entries similar to "kAirPortTurnOffKey" being shown if you click the WiFi icon.  Sleep does NOT work if booting from SD Card; since the SD Card is on the USB bus, it is likely that sleep will not work from USB-based drives/flash media either (this is untested, but likely).
- Multiple monitors - you can use either the internal laptop display or an external monitor via HDMI, but not both at the same time.
- Screen backlight / brightness control - not present in System Preferences -> Displays; system freezes if you press Fn+F11 or Fn+F12 to try to manually change the brightness.
- Microphone - shows up as present in System Preferences -> Sound; setting the Input Volume to max will get you a slight response, but not much and is not usable (maybe the mic needs to be initialized or have the input gain adjusted somehow?) 
- Radeon M360 - I know that this will never work; I'm putting it here because I have not yet figured out how to disable it and/or verify it is disabled (maybe there is a patch for this?)

- HDMI Audio - does NOT work if you boot the system with the lid open.

 

Here is was is not yet tested:
- VGA output - just need to find a VGA cable and connect to a VGA monitor; will report back with result once that's done.
- 9-pin RS-232 serial port - need to find a serial device to test this against; once I do, will test and report back.  This will remain un-tested for now, as I have no devices to test this with.
- ExpressCard 54 slot - not sure if there is a way to test this, but will look into it an report back here if I find anything useful.

 

For reference, I've attached both clover.zip and debug_12760.zip files.

 

To get this far, I used most of the files from OS X Latitude Generic EFI Folder EFI_4617 and OS X Latitude Boot Pack E5470 v1.18.6_HS.  In addition, I hunted around online and found found the config_HD515_520_530_540.plist for Skylake laptops, and then modified it to allow the Intel HD 520 and the onboard audio to work.

 

So that's where it stands.  Pretty good progress, but definitely need some help.  I'm not good at patching DSDT/SSDT files (as in I haven't figured out how to patch), so if anyone can patch the DSDT/SSDT files, I'd be very appreciative.  

 

If anyone needs any more information please let me know and I'll be happy to provide whatever I can.

 

Thanks in advance for any assistance or pointers.  Once everything is figured out, I'll be contributing back by writing up a good how-to.

 

debug_12760.zip

CLOVER.zip

Edited by FoxND001
2018-08-26 - Almost everything is working now; only have HDMI Audio left to go.
Link to comment
Share on other sites

  • Replies 63
  • Created
  • Last Reply

Top Posters In This Topic

Thanks @Jake Lo - what you and the osxlatitude team do is really appreciated!!

 

I tired your patches - put the patched DSDT and SSDT files and the updated config.plist in /EFI/Clover.  Here were the results:

 

- Microphone works very well now.  I actually had to turn down the gain and turn on ambient noise reduction due to the sensitivity of the mics.  Will be trying an iChat or Skype session at some point to see how well that works.

- Screen brightness - did not see a change there.  I go to System Preferences -> Displays, and no controls are found for brightness.  Pressing Fn+F11 or Fn+F12 still freezes the system immediately.  Did some digging in the forums and found out about Karabiner-Elements as per the "9179-dell-latitude-e7x70-clover-uefi-only" guide in the Sierra section.  I'm going to give that a try to see if it helps, and will report back here.

- Power Management - I was able to get the system to sleep, but the screen never comes back from sleep.  Did another forum search and found "10236-how-to-fix-black-screen-in-high-sierra" - I'm going to try these steps and see if that helps, and will report back here.

 

Once I try the above, I'll collect the current debug and clover files and post here.  If there is any other diagnostic information I should collect, please let me know and I'll get that information too.

 

Other notable observations in testing:

 

- Power Management (additional) - I discovered that simply unplugging or plugging-in the power adapter will cause the system to freeze immediately.  Not sure why, but I think it's worth noting, so I'm reporting that here.

- Running from SDCard - the SD Card reader in this system is on of the faster ones I've come across, so I decided to try running HS directly from the card.  I got a 64MB UHS-I card rated at 90MBs and tried installing HS.  And it worked - HS ran on that card with no noticeable difference other than being slower than on an SATA drive.  It's not "fast" by any stretch, especially compared to the SSD in this system, but it may be useful for anyone that wants to use this as an emergency bootable OS.  I may try getting a faster UHS-III card in the near future to see just how fast the SD Card reader is in this system; if I do, I'll post that here.

 

Is there any other pointers or anything else that I should be trying?

 

Thanks for you support on this everyone!   I'm not aware of any guides out there for any ruggedized laptops, so I'm looking forward to being able to put one together once we get as much working as we can.

  

 

Link to comment
Share on other sites

  • Moderators

Check BIOS if Legacy Option ROMs is enabled, disabling it might fix the freeze issue with the power adapter.

Try to repair permissions and rebuild cache, reboot and see if that fixes the brightness slider.

Post new debug file

 

Link to comment
Share on other sites

@Jake Lo,I tried your suggestions and had some good results.  Here is what happened:

 

- When I disabled Legacy Option ROM in the 1.18.0 BIOS, the power management/battery charging suddenly worked properly.  Inserting and removing the power cord seems to show the correct charging status for the battery, and you get the "chime" sound when you plug in the power adapter. 

 

- I repaired permissions and rebuilt the cache using the following commands:

sudo chmod -Rf 755 /S*/L*/E*

sudo chmod -Rf 755 /L*/E*

sudo chown -Rf 0:0 /S*/L*/E*

sudo chown -Rf 0:0 /L*/E*

sudo touch -f /S*/L*/E*

sudo touch -f /L*/E*

sudo kextcache -Boot -U /

and then rebooted.  When the system came back up, the brightness control was present in System Preferences -> Displays, and appeared to function normally.

 

- I then installed  Karabiner Elementsas per the "9179-dell-latitude-e7x70-clover-uefi-only" guide in the Sierra section, making sure to use the correct .json file in the Sierra section.  This worked - I was then able to control the screen brightness with the F11 and F12 keys.

 

- I then decided to try to Sleep the system.  In order to prep, I disabled hibernate by executing the following commands:

sudo pmset -a hibernatemode 0

sudo rm -f /var/vm/sleepimage

sudo pmset -a hibernatefile /dev/null

I then verified that the change was in effect by executing:

pmset -g

This returned a value of 0, indicating the change was effective.  I then selected the "Sleep" entry in the apple menu.  After a few moments, the system appeared to enter sleep, and I observed the "breathing" power light.  When I pressed the power button after it started "breathing" the system woke-up and appeared to work normally.  I then rebooted and repeated this test, and it still worked.

 

- I then rebooted again into HS, and then closed the lid of the system.  The screen turned off, but I got no breathing light.  When I opened the lid, the screen was black.  I will next attempt the steps in the "0236-how-to-fix-black-screen-in-high-sierra" thread in the forums.  Will give that a try and report results back here.

 

- Since I changed a BIOS setting (disabling Legacy Option ROM), I went ahead and pressed F4 in Clover to dump the current DSDT/SSDT files.  Not sure if this was necessary, but I figure it would be a good idea to do so whenever any BIOS settings get changed.  I'll attach a copy of the current Clover directory along with a current Debug to reflect all of the changes made.

 

- An observation - it seems that the system sometimes freezes when I'm using a web browser.  I've observed this happen with both Safari and Chrome so far.  I seem to remember reading about this somewhere in the forums that disabling the Video BIOS could help, but I have not yet found where I read that; even if I find that article (wherever I saw it), I don't think the 5414 BIOS has that option.  Does anyone have any insight on what might be causing web browsers to freeze?

 

Thanks again for your help!  We are a lot closer to having a fully functioning rugged "Tankintosh".

Edited by FoxND001
Link to comment
Share on other sites

@Jake Lo, I took the patch files you provided from the above post and put them in /EFI/Clover/ACPI/patched, and then I repaired permissions and rebuilt the cache using the commands commands in the previous post.  Then I rebooted - this worked without issue, and HS booted as expected.

 

Then I connected the external display via HDMI.  The built-in display turned black, and the external display lit-up and displayed at 1360x768 resolution.

 

Then I used IO Registry Explorer v3.0.2 build 14 to capture the IOReg file.  I've compressed and have attached here.

 

I'll play around with the various resolutions to see what this machine will actually do, and I'll also test with the lid closed to see what happens.  If anything interesting happens, I'll capture IOReg again and post here.  Otherwise, will standby for your instructions on what to try next.

Latitude 5414 Rugged.ioreg.zip

Link to comment
Share on other sites

  • Moderators

Known Issue & Workaround for my Skylake, see if it also works for you.

HDMI-Output works but if connect HDMI-Cable the local Display goes off and never appears.

I had tried different configurations but none panned out. Here's a workaround:

Close the LID until you see the HDMI display becomes the primary display, then open the LID. 

It'll switch LCD as primary and HDMI monitor as secondary.

Link to comment
Share on other sites

@Jake Lo, I tried your instructions above, closing the lid and then re-opening the lid, and the system reacted exactly as you described - the built-in monitor came on as primary, and the external monitor came on as secondary.  I then tried several different screen resolutions, tried mirroring the built-in display, tried mirroring the external display, tried running with the lid closed and external monitor only.  I then repeated all of these a few times, and the results were consistent - it works by doing things in this order:

 

1) Boot the system into HS with no external display connected.

2) Connect to an external display via HDMI.

3) Wait for the display to come up on external monitor.

4) Close the lid.

5) Wait about 5 seconds.

6) Open the lid.

7) Observe both built-in monitor and external monitor light up.

 

I'll update the first post to show this success.  Just to have some additional data, I'll attach an IOReg dump from both displays working.  I don't know if it will help, but I figure it might, so I'll go ahead and attach here.

 

Not much left to get this fully working - I'll test sleep via closing the lid next and report back here with what happens.  Thanks again for your help!

Latitude 5414 Rugged - Built-In and External Working and Mirrored.ioreg.zip

Link to comment
Share on other sites

 Share


×
×
  • Create New...