Jump to content

Latitude E7470 - SSDT/DSDT + Brightness issues


eduardog131
 Share

Recommended Posts

Good <insert time of timezone>,

 

I have a problem with my Latitude E7470 and macOS 10.13.6. I have successfully installed and everything is working, minus SSDT/DSDT and brightness. If I disable `Drop OEM tables` and drop the additional SSDTs (minus SSDT-PNLF), I can boot every time. If I do not disable them, I hang at HID Legacy Shim 2 or around there. Attached is my Clover [ACPI and Kexts] folder, note that I do not have any Broadcom texts because I do not have a wifi module, only a USB one, and I removed IntelGraphicsFixup and related items because I use WhateverGreen and changed the variables in the EFI shell.

 

Forgot to mention specs:
Latitude E7470

i5-6300U w/ Intel HD 520

8GB DDR4

96MB DVMT Prealloc

1920x1080 IPS screen

Hynix 256GB SATA, not NVMe SSD

 

Thanks!

-eduardog

Clover_ACPI_Kexts.zip

Link to comment
Share on other sites

You probably would not get proper help until you at least send your config. Ideally send proper problem reporting file.

 

I can tell you this so far - remove EAPDFix.kext (not needed with lates AppleALC) and FakePCIID_Intel_HD_Graphics.kext (not needed with lates WhateverGreen). You have FakePCIID_Broadcom_WiFi.kext that you do not need (remove it), but you removed BrcmPatchRAM2.kext and BrcmFirmwareRepo.kext that are actually need for working BT.

 

For brightness try AppleBacklightFixup.kext. I prefer this one over AppleBacklightInjector.kext (which also need patch in config).

Link to comment
Share on other sites

4 minutes ago, viking1304 said:

You probably would not get proper help until you at least send your config. Ideally send proper problem reporting file.

 

I can tell you this so far - remove EAPDFix.kext (not needed with lates AppleALC) and FakePCIID_Intel_HD_Graphics.kext (not needed with lates WhateverGreen). You have FakePCIID_Broadcom_WiFi.kext that you do not need (remove it), but you removed BrcmPatchRAM2.kext and BrcmFirmwareRepo.kext that are actually need for working BT.

 

For brightness try AppleBacklightFixup.kext. I prefer this one over AppleBacklightInjector.kext (which also need patch in config).

I'll get back to you with trying AppleBacklightFixup, and if it does not end up working I'll attach the problem reporting file. I'll add back in the working BT kexts. Thanks!

Link to comment
Share on other sites

For hangup issues, you will probably have to drop CpuSsdt and (or) Cpu0Ist in your config. Something like this

 

image.png.ba59b87b2cc2329a91ada63ff36ca68a.png

 

SSDT-5.aml (CpuSsdt) should be removed from patched folder in that case.

 

Drop OEM is needed if you are using patched aml files.

 

Your sort order section should match existing files in your patched folder. 

Link to comment
Share on other sites

15 minutes ago, viking1304 said:

For hangup issues, you will probably have to drop CpuSsdt and (or) Cpu0Ist in your config. Something like this

 

image.png.ba59b87b2cc2329a91ada63ff36ca68a.png

 

SSDT-5.aml (CpuSsdt) should be removed from patched folder in that case.

 

Drop OEM is needed if you are using patched aml files.

 

Your sort order section should match existing files in your patched folder. 

Okay, I have gathered the reporting files and they are attached to this post. I have tried AppleBacklightFixup and it still does not work. Dropping OEM tables and using the patched ACPI amls from the bootpack results in a KP, and using Drop CpuSsdt only hangs instead of KP-ing.

debug_3729.zip

Link to comment
Share on other sites

You have two configs and two patched folders which is not a problem by itself, but you can easily make things wrong (as you did). In one of those CpuSsdt is SSDT-6.aml and in second CpuSsdt is SSDT-5.aml

 

When you sent files first time you send this folder only:

SSDT-0.aml
SSDT-1.aml
SSDT-2.aml
SSDT-3.aml
SSDT-4.aml
SSDT-5.aml
SSDT-13.aml

and I wrote to you to remove SSDT-5.aml, since I checked all of them to see which one is CpuSsdt

 

You use another folder now

SSDT-0.aml
SSDT-1.aml
SSDT-2.aml
SSDT-3.aml
SSDT-4.aml
SSDT-5.aml
SSDT-6.aml
SSDT-14.aml

and you removed wrong table from Sort order. You need to remove SSDT-6.aml here, not SSDT-5.aml. You also need to remove SSDT-6.aml file itself from patched folder.

 

This should fix your hang/kp problems.

 

I updated all my kexts tonight and brightness stoped working for me too. Looks like AppleBacklightFixup.kext doesn't work with latest Lilu.kext for some reason. I had to remove AppleBacklightFixup.kext and to restore AppleBacklightInjector.kext and to re-enable change F%uT%04x to F%uTxxxx patch again. This works fine.

 

You have this patch in your config, so just replace AppleBacklightFixup.kext with AppleBacklightInjector.kext and rebuild kext cache. After reboot go to Displays in System Preferences and check if you have Brightness slider there or not. It is possible that your keyboard shortcut doesn't work even if brightness itself works.

 

p.s. /Library/Extensions is preferred location for adding kexts, not /System/Library/Extensions. It's not a problem if you add them there, but it would be hard for you to keep track of them later. I recommend to remove your kexts from there and to move them to /L/E. Always rebuild kext cache when you add or remove anything to/from /L/E or /S/L/E. 

Link to comment
Share on other sites

1 hour ago, viking1304 said:

You have two configs and two patched folders which is not a problem by itself, but you can easily make things wrong (as you did). In one of those CpuSsdt is SSDT-6.aml and in second CpuSsdt is SSDT-5.aml

 

When you sent files first time you send this folder only:

SSDT-0.aml
SSDT-1.aml
SSDT-2.aml
SSDT-3.aml
SSDT-4.aml
SSDT-5.aml
SSDT-13.aml

and I wrote to you to remove SSDT-5.aml, since I checked all of them to see which one is CpuSsdt

 

You use another folder now

SSDT-0.aml
SSDT-1.aml
SSDT-2.aml
SSDT-3.aml
SSDT-4.aml
SSDT-5.aml
SSDT-6.aml
SSDT-14.aml

and you removed wrong table from Sort order. You need to remove SSDT-6.aml here, not SSDT-5.aml. You also need to remove SSDT-6.aml file itself from patched folder.

 

This should fix your hang/kp problems.

 

I updated all my kexts tonight and brightness stoped working for me too. Looks like AppleBacklightFixup.kext doesn't work with latest Lilu.kext for some reason. I had to remove AppleBacklightFixup.kext and to restore AppleBacklightInjector.kext and to re-enable change F%uT%04x to F%uTxxxx patch again. This works fine.

 

You have this patch in your config, so just replace AppleBacklightFixup.kext with AppleBacklightInjector.kext and rebuild kext cache. After reboot go to Displays in System Preferences and check if you have Brightness slider there or not. It is possible that your keyboard shortcut doesn't work even if brightness itself works.

 

p.s. /Library/Extensions is preferred location for adding kexts, not /System/Library/Extensions. It's not a problem if you add them there, but it would be hard for you to keep track of them later. I recommend to remove your kexts from there and to move them to /L/E. Always rebuild kext cache when you add or remove anything to/from /L/E or /S/L/E. 

Thanks so much for all the help. Dropping SSDT 6 from my config still causes a hang unfortunately. Additionally, I get a ton of ACPI parse errors. I did not create any of these tables myself, they're all coming from the E7470 bootpack and I still have to enable OEM tables (and select BIOS.aml) as well as dropping the patched ones to fully boot. Any more ideas?

20181116_213439.jpg

Link to comment
Share on other sites

  • Moderators

@eduardog131

No need to quote on your responds, makes it hard to read if it's only between 2 person.

 

Give this new bootpack a try, fully hotpatched. Replaced into /EFI/Clover

Remove AppleBacklightInjector.kext from /L/E or /S/L/E if you have it

Repair permissions and rebuild cache

 

@viking1304

When using AppleBacklightFixup.kext, you need to pair it with the SSDT-PNLF.aml from Rehabman's GitHub. The one used with AppleBacklightInjector.kext won't work with it. And you must disable the F%uT%04x to F%uTxxxx hot patch.

You can find it in my attached bootpack.

E7470_Mojave_Hotpatches.zip

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...