Jump to content
metropolis

Thinkpad T460P Mojave -- almost perfect (no sleep, brightness control)

Recommended Posts

Just gave that a shot -- ran into some issues though, it kept giving me errors about `iokit/common` being missing. Tried to just nuke the backlight-level variable while in single user mode, to force that to reset, but it didn't seem to work -- when i run `nvram -p` now, it looks like this

 

 

fakesmc-key-MSWr-ui8    %00
flagstate    %00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00
fakesmc-key-RBr -ch8*    2016mb%00%00
fakesmc-key-EPCI-ui32    %09 %f0%00
fakesmc-key-MSAc-ui16    %00%00
efi-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>D33FCCF5-806E-4B7D-9AA7-65AF956D0E28</string></dict></dict></dict></array>
fakesmc-key-BATP-flag    %00
fakesmc-key-$Num-ui8    %01
fakesmc-key-REV -ch8*    %026%0f%00%00%97
fmm-computer-name    MacBook Pro
fakesmc-key-MSTc-ui8    %00
fakesmc-key-MSPS-ui16    %00%03
fakesmc-key-RMde-char    A
csr-active-config    g%00%00%00
fakesmc-key-RPlt-ch8*    j130%00%00%00%00
fakesmc-key-BEMB-flag    %01
fakesmc-key-#KEY-ui32    %00%00%00%11
efi-apple-payload3-data    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%00%00%00%00%00%00%04%01*%00%01%00%00%00"%00%00%00%00%00%00%00%00@%06%00%00%00%00%00.%a9;%fb%87,%10J%a8%f8%fd%8b%fe%9b%05%a8%02%02%04%04x%00\%00E%00F%00I%00\%00A%00P%00P%00L%00E%00\%00U%00P%00D%00A%00T%00E%00R%00S%00\%00M%00U%00L%00T%00I%00U%00P%00D%00A%00T%00E%00R%00\%00M%00a%00c%00-%00A%005%00C%006%007%00F%007%006%00E%00D%008%003%001%000%008%00C%00.%00e%00p%00m%00%00%00%7f%ff%04%00
multiupdater-state    %01%00%00%00%01%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00
fakesmc-key-MSFW-ui8    %01%00
security-mode    none
backlight-level    %00%00
SystemAudioVolume    T
specialbootdevice    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%00%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00%e0%1f2:%00%00%00%00%f5%cc?%d3n%80}K%9a%a7e%af%95m%0e(%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hB9%a3r%aa%b7I%06B%99p%be%e7(%ab%bc%de%7f%ff%04%00
efi-apple-payload2    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>FB3BA92E-2C87-4A10-A8F8-FD8BFE9B05A8</string></dict></dict><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\APPLE\UPDATERS\MULTIUPDATER\flasher_update.smc</string></dict></array>%00
platform-uuid    %b3?%96%9d~z@3%85%fd%09%e8%7f%fa%c4n
fakesmc-key-$Adr-ui32    %00%00%03%00
EFILoginHiDPI    %00%00%00%00
fakesmc-key-BNum-ui8    %01
fakesmc-key-BBIN-ui8    %01
efi-apple-payload3    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>FB3BA92E-2C87-4A10-A8F8-FD8BFE9B05A8</string></dict></dict><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\APPLE\UPDATERS\MULTIUPDATER\Mac-A5C67F76ED83108C.epm</string></dict></array>%00
SystemAudioVolumeDB    %fe
Clover.NVRamDisk    No
efi-boot-device-data    %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%00%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00%e0%1f2:%00%00%00%00%f5%cc?%d3n%80}K%9a%a7e%af%95m%0e(%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hB9%a3r%aa%b7I%06B%99p%be%e7(%ab%bc%de%7f%ff%04%00
prev-lang:kbd    en:0

 

Share this post


Link to post
Share on other sites

Shows backlight level = 0%

Try this, remove SSDT-PNLF.aml from Patched folder. Enable AddPNLF in Config.plist file

 

Share this post


Link to post
Share on other sites

Worked well! Waking from sleep when connecting to an external monitor, and initial boot while not connected works. However, I don't have a brightness slider present, and booting from sleep without an external monitor present results in a black screen on the onboard display. I'm not able to adjust the brightness of the onboard display after sleep, so it's a black screen.

 

NVRAM output is below:

 

fakesmc-key-MSWr-ui8	%00
flagstate	%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00
fakesmc-key-RBr -ch8*	2016mb%00%00
fakesmc-key-EPCI-ui32	%09 %f0%00
fakesmc-key-MSAc-ui16	%00%00
efi-boot-device	<array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>D33FCCF5-806E-4B7D-9AA7-65AF956D0E28</string></dict></dict></dict></array>
fakesmc-key-BATP-flag	%00
fakesmc-key-$Num-ui8	%01
fakesmc-key-REV -ch8*	%026%0f%00%00%97
fmm-computer-name	MacBook Pro
fakesmc-key-MSTc-ui8	%00
fakesmc-key-MSPS-ui16	%00%03
fakesmc-key-RMde-char	A
csr-active-config	g%00%00%00
fakesmc-key-RPlt-ch8*	j130%00%00%00%00
fakesmc-key-BEMB-flag	%01
fakesmc-key-#KEY-ui32	%00%00%00%11
efi-apple-payload3-data	%02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%00%00%00%00%00%00%04%01*%00%01%00%00%00"%00%00%00%00%00%00%00%00@%06%00%00%00%00%00.%a9;%fb%87,%10J%a8%f8%fd%8b%fe%9b%05%a8%02%02%04%04x%00\%00E%00F%00I%00\%00A%00P%00P%00L%00E%00\%00U%00P%00D%00A%00T%00E%00R%00S%00\%00M%00U%00L%00T%00I%00U%00P%00D%00A%00T%00E%00R%00\%00M%00a%00c%00-%00A%005%00C%006%007%00F%007%006%00E%00D%008%003%001%000%008%00C%00.%00e%00p%00m%00%00%00%7f%ff%04%00
multiupdater-state	%01%00%00%00%01%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00
fakesmc-key-MSFW-ui8	%01%00
security-mode	none
SystemAudioVolume	T
specialbootdevice	%02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%00%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00%e0%1f2:%00%00%00%00%f5%cc?%d3n%80}K%9a%a7e%af%95m%0e(%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hB9%a3r%aa%b7I%06B%99p%be%e7(%ab%bc%de%7f%ff%04%00
backlight-level	%05%00
efi-apple-payload2	<array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>FB3BA92E-2C87-4A10-A8F8-FD8BFE9B05A8</string></dict></dict><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\APPLE\UPDATERS\MULTIUPDATER\flasher_update.smc</string></dict></array>%00
platform-uuid	%b3?%96%9d~z@3%85%fd%09%e8%7f%fa%c4n
fakesmc-key-$Adr-ui32	%00%00%03%00
EFILoginHiDPI	%00%00%00%00
fakesmc-key-BNum-ui8	%01
fakesmc-key-BBIN-ui8	%01
efi-apple-payload3	<array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>FB3BA92E-2C87-4A10-A8F8-FD8BFE9B05A8</string></dict></dict><key>BLLastBSDName</key><string>disk0s1</string></dict><dict><key>IOEFIDevicePathType</key><string>MediaFilePath</string><key>Path</key><string>\EFI\APPLE\UPDATERS\MULTIUPDATER\Mac-A5C67F76ED83108C.epm</string></dict></array>%00
SystemAudioVolumeDB	%fe
Clover.NVRamDisk	No
efi-boot-device-data	%02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%00%00%00%00%00%00%04%01*%00%02%00%00%00(@%06%00%00%00%00%00%e0%1f2:%00%00%00%00%f5%cc?%d3n%80}K%9a%a7e%af%95m%0e(%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hB9%a3r%aa%b7I%06B%99p%be%e7(%ab%bc%de%7f%ff%04%00
prev-lang:kbd	en:0

and I've attached the debug log -- thanks again for all the help @Jake Lo

debug_4363.zip

Share this post


Link to post
Share on other sites

Something I noticed while doing some poking around with this new config — seems that the sound is not working. I’m going to keep hacking on this to see what might have gone awry here. Something suggests to me that one of the patches in the original config (with notes in Chinese) may have been added to fix the audio layout.

 

Gonna keep poking around at this — it feels so close to done, thanks to all of your help, @Jake Lo, and I definitely want to share this config with others (with caveats of course) once this is good to go. The T460P is an interesting machine and it’s blazing fast with an SSD on Windows.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...