Jump to content

Dell DW1820A doesn't want to cooperate


Recommended Posts

Hi,

 

I recently picked up a DW1820 CN-0VW3T3 which acutally has the PCI ID 1028:0021.

I put it into my Dell XPS 13 9360, Clover Patched the compatible string to pci14e4,4353 and rebooted.

Wifi gets recognized just fine and I can connect to Wifi, but there are major issues after a couple of minutes, at first the wifi will briefly disconnect and reconnect again, but after two or tree times the kernel task will go crazy, and the whole os grinds to a halt (first IO Operations struggle, then everything else will have issues, too).

I am using the-darkvoids config from here: https://github.com/the-darkvoid/XPS9360-macOS (delted the AirportBrcmFixup and USB Inject all kexts)

 

I tried all the compatible strings that float around the forum here and also tried AirportBrcmFixup with bootoptions brcmfx-driver=1 and 2. The fixup kext makes things worse for me (crashes earlier).

 

The strange thing is I can't even get the bluetooth to work correctly. With the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext in /Library/Extensions Bluetooth turns on and shows devices, but "crashes" when trying to connect to any of them (switches to not connected immediately).

 

Is there anything funky going on with my DSDT pachtes or something?

 

Help from the master @Hervé would be greatly appreciated.

hackintosh wifi.jpg

debug_29963.zip

Link to comment
Share on other sites

  • Administrators

Guys, 1st of all, check that the reported MAC address in the OS matches that of the label on the card. If it does not, well, I'm beggining to suspect that there are false or dodgy DW1820A cards being offered on the market (like there used to be for Apple's own BCM94360CD)...

 

If all looks Ok, then please try the pin masking.

 

That's it. Nothing further to offer.

 

Link to comment
Share on other sites

The Mac Adress matches the label.

 

I tried the pin masking out of curiosity and the card immediately stopped acting up. It was detected and working even without your "compatible" patch.

But with or without patches it only detects 2.4GHz networks and the bluetooth is still weird, it sometimes works fine and sometimes it won't connect to anything successfully.

 

Do you spot something wrong with my USB config?

Link to comment
Share on other sites

 Share

×
×
  • Create New...