Jump to content
aufannada

E7270 - Black Screen When HDMI Connection To LCD For Mirroring

Recommended Posts

Sorry, do you use High Sierra on E7270 or E7470?

 

Maybe there is a little difference so that the kext can't run on High Sierra on my E7270 because I tried to repeat several times but still with the same results, the screen went blank.

 

Share this post


Link to post
Share on other sites

You could create your own with Hackintool.

Click on Display tab

Inject EDID, select MacBookPro (16:10)

Export the kext and place in /E/C/k/O

  • Thanks 1

Share this post


Link to post
Share on other sites

Ok Jake, I've done it and succeeded. Now I have been able to connect HDMI to an LCD projector directly without blank screen, and it only takes 1-2 seconds to be able to display both images. I have also tried several experiments differently as a possibility after that and everything went normally without black screen.

 

Thank you very much.

 

Note : If I connect to an LCD projector using a mini-DisplayPort, the time needed is quite long, about 30-31 seconds. That is because the system is looking for the right resolution for the display, which is between 1920 x 1080 and 1366 x 768. And I prefer the resolution of 1366 x 768 because it matches what is displayed on the laptop screen.

 

But that doesn't matter to me, I never or rarely use mini-DisplayPort for mirroring because if use it the sound won't come out (sound is only on the laptop) or no DP audio.

Share this post


Link to post
Share on other sites

Now, the HDMI connection that was previously problematic has now been resolved.

 

There are 2 more which in my opinion will also be resolved. The first is the SD Card Reader, and the second is the Trackpad.

 

Could you help me again to finish both?

Share this post


Link to post
Share on other sites

miniDP audio should work if the right patch is added. Post your debug files with the miniDP connected.

There's some development for the SDCard for this model but had stopped for a while (Realtek RTS525A). Check here. You can donate money if you want further development to occur as it's very time consuming.

Dr. Hurt has made some development for the Alps touchpad, but it only works well for older v3 and maybe v5. Newer v7 and v8 definitely has issue. You can try it here. He too has stopped further development. For Mojave, you'll have to use the version compiled by Bronxteck.

Share this post


Link to post
Share on other sites

I mean the version of touchpad on the system, not kexts version.

For example:

E6420 and E6430 has v3 touchpad

E7440 has v5 touchpad

E7450 has v7 touchpad

E7470 has v8 touchpad

The kext supports v3 and v5 quite smoothly, and somewhat supports v7 and v8, just not smoothly.

 

With the kexts install, run this in terminal to determine what version you have. I'm pretty sure E7270 is the same as the E7470.

log show | grep ALPS

Share this post


Link to post
Share on other sites

@Jake Lo

 

Ok, I understand Jake. I have checked using the command above, and I found that my E7270 has a v8 touchpad version and does have problems after using the kext from Dr. Hurt and also from Bronxteck. So now I don't use it anymore. And I already considered the problem complete. For this touchpad case I will not find a solution again. Thank you for helping to solve the problem even though I failed to find the best solution.

 

On 7/21/2019 at 6:52 PM, Jake Lo said:

There's some development for the SDCard for this model but had stopped for a while (Realtek RTS525A). Check here. You can donate money if you want further development to occur as it's very time consuming.

 

For this I am still looking for the best solution. I have tried several ways but have not succeeded.

 

On 7/21/2019 at 6:52 PM, Jake Lo said:

miniDP audio should work if the right patch is added. Post your debug files with the miniDP connected.

 

This is my debug files..

 

debug_7191.zip

Share this post


Link to post
Share on other sites

I don't see any external monitor connected. Make sure the miniDP is connected to a monitor and post the IOREg file again or the full debug file while it's connected or HDMI monitor

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...