Jump to content
awaismshahzad

[SOLVED] E7470 Install Hang

Recommended Posts

Hello. I am in the process of getting Mac OS on my E7470 i7 laptop but the computer hangs before it can display the install screen when booting from USB. The installation gets to "apfs_module_start:1393: load: com.apple.filesystem.apfs. v945.257.7, apfs-945275.7, 2019/08/20" where it starts to hang. Wondering if someone else encountered this and possible solutions. 

IMG_7197.jpg

Current_EFI.zip

Share this post


Link to post
Share on other sites

Don't forget to upgrade Lilu.kext & Whatevergreen.kext

Disable Trim in Config file if you're installing to an NVMe drive

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the heads up for updating the kexts. Will do that. How do I disable trim in the config file as it is going to the NVME my E7470? It that in clover or on the Config file when plugged into the original Mac. 

 

Also, is there a way to bring up the original EFI partition that comes up as it is not coming up when I plug in the installation USB drive for some reason.

 

Thank you!

Share this post


Link to post
Share on other sites

you need to mount the EFI partition. Use app like Clover Configurator or ESP Mounter Pro.

The Trim patch is in the Config file under kextToPatch. Use Clover Configurator to edit it.

Share this post


Link to post
Share on other sites

Sounds good I'll go ahead and do that. Thank you so much for making this installation possible. 

 

Couple questions now that Mac OS is booting up great. Which wifi cards would you recommend using with the e7470 and is it possible to use a USB wifi card as I wait on getting one that works with Mac OS? Also, I'm not getting the battery indicator to work or show up when the laptop is plugged in. Would there be a kext that I might be missing or something I need to install in the post-installation to get that working? Thank you!

Share this post


Link to post
Share on other sites

I recommend the DW1560 but DW1830 will work too but it needs 3 antennae. You can utilized the 3rd antenna from the WWAN slot which is right next to it so no issue with the length.

USB wifi is fine but might have issue asleep and might need to disconnect and reconnect it. Make sure it's a Mac supported USB wifi, you can consult our support list from here.

No post installation kext for battery, should work right away. I have no issue with Battery status on my E7470. Please post debug file.

 

 

 

Share this post


Link to post
Share on other sites
11 hours ago, Jake Lo said:

No post installation kext for battery, should work right away. I have no issue with Battery status on my E7470. Please post debug file.

Attached the debug file.

 

11 hours ago, Jake Lo said:

I recommend the DW1560

Went ahead and ordered it. The USB wifi wouldn't work even with the driver installed for it works great until the DW1560 comes in.

 

Thank you!

debug_14173.zip

Share this post


Link to post
Share on other sites

Hmmm, you seem to have different bootpacks packed in here.

1) Reinstall this version of Clover with the following settings

  • Install for UEFI booting only
  • Install Clover in the ESP
  • UEFI Drivers\Recommended Drivers
    • ApfsDriverLoader
    • AptioMemoryFix
    • AudioDxe
    • DataHubDxe
    • FSInject
    • HFSPlus
  • Additional drivers
    • PartitionDxe
  • Themes (Optional)
  • Install Clover Preference Pane 

2) Make sure you don't have OsxAptioFix3Drv.efi in /EFI/Clover/drivers/UEFI

3) Remove following kexts in /clover/kexts/Other

  • VoodooPS2Controller
  • USBInjectAll
  • NoTouchID
  • SMCBatteryManager.kext and add ACPIBatteryManager.kext or remove FakeSMC.kext and add VirtualSMC.kext

 

4) Remove kexts from /L/E

  • EAPDFix.kext
  • AppleHDA_ALC293.kext
  • FakePCIID_Intel_HD_Graphics.kext
  • AppleBacklightInjector.kext
  • FakePCIID_Broadcom_WiFi.kext
  • FakePCIID.kext

Repair permissions and rebuild cache

 

Share this post


Link to post
Share on other sites

Thank you much! Battery is now showing and working great.

 

Did you install a separate program to change the size of the screen as the only options I have are 2140x1440 and 2048x1152 as well as 1600x900 in the system preferences?

Share this post


Link to post
Share on other sites

No,  but if you want, you can create your own using Hackintool.app under display. 

Or use SwitchResX.app

My basic resolutions are 1920x1080, 1600x900 and 1344x756

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...