Jump to content
MarkyMac

[SOLVED] E7450 Mojave - various odd issues

Recommended Posts

Hi

Pretty new to all this lark.

 

Got Mojave installed on an E7450. After much manual messing about with Clover and installing various bits and bobs, I now have a part functioning system.

 

Wifi is fine, as I'd previously been running High Sierra on this and had already swapped out the wifi card.

 

On boot I get a very long pause, then    '[IGPU] Graphics driver failed to load: could not register with Framebuffer driver!'

then another longer pause

 

but, eventually it boots.

 

I've no:-  

- sound

- keyboard

- trackpad

 

Not even looked at sleep etc.

 

How do I go about diagnosing where my problem lies?

 

thanks folks

Share this post


Link to post
Share on other sites

upgrade Clover using version from here

  • Install for UEFI booting only
  • Install Clover in the ESP
  • UEFI Drivers\Recommended Drivers
    • ApfsDriverLoader
    • AptioMemoryFix
    • AudioDxe
    • DataHubDxe
    • FSInject
    • HFSPlus
    • SMCHelper 
  • Additional drivers
    • PartitionDxe

Themes (Optional)

 

Update lilu and whatevergreen and applealc.kext

https://github.com/vit9696/Lilu/releases

https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md

 

Remove from /L/E and repair permissions and rebuild cache

  • EAPDFix.kext
  • FakePCIID_Intel_HD_Graphics.kext
  • ACPIPoller.kext

 

Share this post


Link to post
Share on other sites

Many thanks fella.  I think I've followed those instructions to the letter.

 

I get the same error message during boot, and graphics seem no better - still corrupt in places.

 

Still no sound, keyboard, trackpad or LAN.

 

F2 and F4 clover dumps done and debug recreated.

debug_26782.zip

Share this post


Link to post
Share on other sites

Remove all the kext with dSYM in it. Not needed

You have added a bunch of *.efi drivers I did not ask to add

Go ahead and delete the following folders: drivers64 and drivers64UEFI

Under drives/UEFI, remove these:

  • apfs.efi
  • OsxAptioFixDrv.efi

Delete nvram.plist

Share this post


Link to post
Share on other sites

No joy I'm afraid, still much the same as when I started.

EFI partition cleaned up as per instructions.

 

I just mount the EFI, make changes, then reboot right?

I only need to do permissions and kext cache rebuild if I touch /L*/E* or /S*/L*/E*?

 

debug_18804.zip

Share this post


Link to post
Share on other sites

EFI looks fine

check for these kexts in /S/L/E

  • AppleIntelHD5000Graphics.kext
  • AppleIntelBDWGraphicsFramebuffer.kext
  • AppleIntelBDWGraphics.kext

Those are needed for graphics acceleration.

Can't explain why sound, keyboard, touchpad and LAN are not working. I see all the correct kexts in the right places.

I would recommend you re download Mojave and create a clean USB installer with the well known createinstallmedia command

Use the current EFI folder you have now as the bootpack when you install Clover

Share this post


Link to post
Share on other sites

Thanks so much Jake.  As you said I've taken a dump of the EFI package, and started from scratch.

 

This time it's worked a treat, and it's so easy just to drop the EFI folder onto both the USB drive and to the target install drive after install.

 

Just bluetooth to sort....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...