Jump to content

Help required for Bluetooth of Intel N2230


wellcome
 Share

Recommended Posts

After several years registered in Osxlatitude I get ready to write my first post. Before I must explain that, after more than ten years with hackintosh, I had no need of it; but I do have to recognize that through the readings in their different forums I have solved numerous numerous problems in the different S.O of mac in these years. 


The purpose of this my first post is, that having verified that Hervé's Latitude E6440 has the same Bluetooth HCI - Wireless Centrino N-2230 - than my Tosihba Qosmio Px30t--Imac14,2--, I would like to be able to solve with your help the possibility of fixing at once forever the bluetooth formware, and not having to load Windows 10 or my Ubuntu first. After using various injectors and changes in the DSDT I have not succeeded.


However, in my other Lenovo G50 80--MacBookAir7,2-- notebook that tremble has an Intel / combo, in this case, Wireless 3180, the bluetooth is injected without any previous necessary action, or injectors, ctc.OOB, I think you call it here. The only difference I see in both cases is that Lenovo injects bluetooth into a USB 3.0 port via DSDT and a Toshiba into a USB 2.0 port. I have tried, therefore, that the Toshiba inject the BT into USB 3.0 port, like the other devices, but I have not succeeded, and I do not even know if that is possible. Is this the last and small problem that I still have to solve in my Toshiba Qosmio after 6 years of use
Therefore, I help you to solve this problem, if it has a possible solution.

 

Thank you very much and congratulations for the high level of this hackintosh forum, which has given me so much help in these years.

I am currently at macOS Catalina 10.15.1 beta2

 

Regards.

1265382541_Capturadepantalla2019-10-22alas10_36_03.png.3a32b9f01b56937988289711ec9dae7f.png

 

1622554848_Capturadepantalla2019-10-22alas15_08_30.thumb.png.ae016b0bb9377f1251feb8074e0344aa.png

Link to comment
Share on other sites

  • Administrators

The Intel wireless card of my ex-E6440 was not a N-2230 but a N-6235; it indeed carried the same Bluetooth module 8087:07da you've illustrated above. This being said, I do not fully understand what the issue is here and what you're trying to get.

 

Let's clarify something first: no device can be "injected" in a USB port through DSDT patching. USB devices are 100% plug'n play from that perspective. They always get automatically detected and you simply cannot inject any properties through DSDT; if you tried, you'd find it just would never be applied.

 

It does not really matter that the BT module registers against a USB2.0 controller or a USB3.0 controller. It simply depends on the chipset of the computer, knowing that recent/modern computers no longer have dedicated USB2.0 controllers. That can be easily checked through DSDT lookups or IOReg lookups:

  • USB3.0 are of XHCI (eXtensible Host Controller Interface) nature
  • USB2.0 are of EHCI (Enhanced Host Controller Interface) nature
  • USB1.x are of OHCI/UHCI (Open Host Controller Interface/Universal Host Controller Interface) nature

 

Ivy Bridge, Haswell or Broadwell computers typically possess both USB2 and USB3 controllers and you'll find EHCx + XHCx controllers in their DSDT/IOReg.

Skylake and later computers typically only have USB3 controllers so you simply won't find any device registered under USB2 controllers no matter the nature of the connected  USB device.

 

With regards to the Intel Bluetooth module 8087:07ba, it's always worked OOB for me though I can't say I've used it much... Afaik, there's never been any firmware patching kexts/tools for Intel modules, only for Broadcom ones. So, again, I'm wondering what your request is about here.

 

Link to comment
Share on other sites

Good afternoon Hervé:


First of all, thank you for the reply. I thought I had explained well in my post.


Well, I have read in this forum how they solved the problem of fixing the bluetooth hci firmware, using injectors, and other complex techniques such as the virtual firmware preload machine before in windows or linux.


And I just wanted to know if after those dates of 2017, in which the previous solutions were exposed, if later a system had been obtained to fix the bluetoooth hci firmware of my toshiba qosmio- Intel N- at one time and forever 2230-, for which I first need to load Windows 10 or my Ubuntu to be able to have macOS bluetooth for other devices - BT headphones for example - other than the keyboard and mouse, since these are always perfectly loaded on all Mac OSX I've installed so far.


And I have commented that my Lenovo G50 80-Broadwell- with wireless INTEL 3160 always injects in its boot, without having to enter Windows or Linux before, the bluetooth hci in USB 3.0 port, and the Toshiba, when it does, with the premise indicated to enter before in Windows or Linux, it does it in USB 2.0. And I thought that if that difference from being USB 3.0 or USB 2.0 the destination port was responsible for the OOB injection of the Lenovo INTEL 3160 BT.


In short, I understand from your words, that there is no new finding that allows me to have OOB operation on the INTEL N2230 of my Toshiba Qosmio, and I have to continue loading Windows or Linux first before entering macOS to have HCI bluetooth in it.

 

Thank you very much and best regards

Link to comment
Share on other sites

 Share

×
×
  • Create New...