Jump to content
Leon

How to Disable ChromeOS Window Animation

Recommended Posts

Morning,

Lets face facts, as nice as ChromeOS might be - the animations is a big fail from Google - this half-wit implementation is utterly slow and when you have alot of tabs and android apps open - extremely lagging.

So.. lets kill it fire.. sortof anyway - ironicly - Google is here for the saving.

Orginal link: https://appuals.com/disable-chromeos-window-animation/

First of all - You need to be in dev mode (face facts, doing anything cool with your chromebook requires that) - and before you can get into that - you will properly need to reset your device - meaning.. DO BACKUP.

Anyway, once you are in dev mode, its fairly easy.

1. Popup a shell: CTRL+ALT+T
2. Type: shell (to open a shell)
3. Type: sudo su (to be come root)

Now, we need to modify a file call chrome_dev.conf which is located in ETC, but changing that might cause it to be overwritten on a firmware update.. so lets make a copy of it and do a mount.

Type this:
cp /etc/chrome_dev.conf /usr/local

mount --bind /usr/local/chrome_dev.conf /etc/chrome_dev.conf
echo '--wm-window-animations-disabled' >> /etc/chrome_dev.conf
restart ui
exit

This should effectively kill most animations and make your chromeos feel alot faster.

//Leon
 

Share this post


Link to post
Share on other sites

Followup:
Now, as you by this point have noticed is that ChromeOS will disable the mount after a shutdown - now, i must warn you before going on that this might leave your system more vulnerable - but if you are used to tinkering around and want full control.

The solution can be found at: https://sites.google.com/site/cr48ite/getting-technical/remove-rootfs-verification-make-read-write

Basically, what we want todo is to disable the write protect on the root file system.

 

Go into shell and run the following:

sudo su

cd /usr/share/vboot/bin/

./make_dev_ssd.sh --remove_rootfs_verification --partitions 4

reboot

Upon reboot go back into shell
 

sudo su -

mount -o remount,rw /

Right, so now the write protection is disabled on the root file system and its time to have some fun.

Our goal here is to our custom chrome_dev.conf loaded ... there is some different ways we can go around this.

1. We can edit /etc/chrome_dev.conf directly... but the chances are that whatever we do will get overwritten after a firmware update.. 

2. We could try and bind mount it via /etc/fstab but chromeos have its own userland - so that wont load during boot.. 

3. We could do a init script that would load during boot.

Allright, lets test some stuff.

Option 1) - Making changes directly in /etc/chrome_dev.conf offcourse works so no point in looking at that

Option 2) - adding a bind mount to /etc/fstab

run:

echo '/usr/local/chrome_dev.conf /etc/chrome_dev.conf none defaults,bind 0 0 ' >> /etc/fstab

(you can verify it by running: cat /etc/fstab)

Now.. do a reboot.... do a "cat /etc/chrome_dev.conf" and compare it to "cat /etc/chrome_dev.conf" ... what did we learn here ?

.. that chrome os does not load /etc/fstab on boot... £[email protected]!!. .. more info here: 

 


To add a bit of fuel to fire - i can tell you straith of that editing "/usr/share/baselayout/fstab" wont do anything either.. so option 3 is off the table..well. kinda.. it does allow you to manually run "mount /etc/chrome_dev.conf" ... so atleast /etc/fstab is infact used by Linux itself.. just not loaded during boot.

I will get back to option (3) in the next comment...



 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...