Jump to content

[Solved] E6430 Catalina new install 2nd HDD in media bay "not readable"


Recommended Posts

Just finished a new install of Catalina on my E6430.  Under Mojave I was using the media bay for a time machine drive, with AppleAHCIPort.kext injected by CLOVER/kexts/Other.

Under Catalina, with a drive in the media bay, I get the old "the disk you have inserted is not readable" error, and the E6430 eventually freezes.  I have tried several Mac-formatted HDD's, all of which can be read via a SATA/USB adaptor, but the media bay will not read them.

I have also tried moving AppleAHCIPort.kext to /L/E.  This results in a KP on boot

I have also tried adding IOAHCISerialATAPI_Injector.kext to /L/E - the drive is still not readable.

I have HFSPlus.efi in my CLOVER/drivers/UEFI.


I suspect my DSDT might be the issue, since I had copied it over from my E6230; it worked in that machine under Mojave and Catalina.  I have attached my debug files.  Thanks in advance for any suggestions-



Link to comment
Share on other sites

  • Administrators

I very much doubt the patched DSDT of the E6230 has anything to do with your issue...


Your patched AppleAHCIPort kext is of High Sierra (beta?) origin (v328), re-versioned to v999. It probably came from here or here and details of the alternative to reverting kext (i.e. binary patch) were posted here. Given the very origin of the kext, I'm not too surprised it now causes KP in Catalina. What you ought to do is find the alternative to replacing/superseding Catalina's vanilla AppleAHCIPort kext by a now inappropriate older version and actually apply the relevant binary patch to Catalina's own kext.


Once you find details of the patch, simply apply them to the kext cache through Clover's built-in on-the-fly patching facility. I suggest you start here and/or Google for "Hotplug Catalina" / "Hotswap Catalina"... More suitable than kext superseding here.


As usual, the key is to know what you're doing and why you're doing it.


  • Like 1
Link to comment
Share on other sites

Hi Herve´,


Thanks for the valuable advice!

Actually, that AppleAHCIPort kext came from here, posted a few months ago in this forum, albeit in a thread on Mojave.

But knowing the right search terms to type into Google is sometimes half the battle...

The last link you provided contained most of the solution in several pieces.

Fortunately I was able to find a reddit post that I could link to here that contained the complete solution without the "8 zeroes vs 9 zeroes" confusion.

First, I removed both the AppleAHCIPort.kext and the IOAHCISerialATAPI_Injector.kext.

I used this converter to convert the Base64 strings from the reddit post into Hex that I could paste into the "kext to patch" page in Clover Configurator.

Make sure to apply all three patches from the reddit post, the two in the question and the one in the reply.

Link to comment
Share on other sites

  • Administrators

It does not really matter you got the old kext from a different thread, it's the exact same one (HiSie's v328)...

Allow me to correct your statement about the patch. The Clover binary patch applicable to Catalina simply is:

Kext: AppleAHCIPort
Find:    40600200
Replace: 00000000


The other 2 x patches you referred to (and those were mentioned for Mojave) appear totally irrelevant because the target (i.e. Find) binary code (hex strings) does not exist in the vanilla kext. At least not in 10.15.2.'s...


By the way, Clover Configurator includes a Base64 to Hex converter.


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...