Jump to content

MSI GL63 8RD not booting to install Catalina


ch4rl1e
 Share

Recommended Posts

Hey guys, i'm having trouble installing macOS Catalina 10.15.2 on my laptop GL63 8RD with an i7 8750H and 8GB RAM, the following screenshot is the error, apparently something is wrong with MSI EPF USB, i tried patching DSDT but i think i did it wrong. Can you help me please?

 

P.D: I tried doing it with another USB and i almost made it, but another error :((!!

P.D 2: I uploaded screenshots of the error and the EFI folder.

 

Specs:

MSI GL63 8RD (Laptop)

Coffee Lake i7-8750H

UHD630 iGPU

GeForce 1050Ti dGPU

8GB RAM

IMG_1183.jpeg

IMG_1236.jpeg

EFI (F) 2 3.zip

Link to comment
Share on other sites

  • Administrators

Make sure you inject USBInjectAll kext to begin with and boot with the flag to disable nVidia dGPU. Notwithstanding the fact that Hackintoshes do not support Optimus technology, GeForce 1050Ti is Pascal and therefore bears no support whatsoever beyond High Sierra (up to which it would require nVidia Web Driver); you'll have to make sure it's disabled, either through BIOS or through a dedicated SSDT. You can only run on the UHD630 iGPU.

Link to comment
Share on other sites

  • Administrators

No such boot flag in your posted config, so no way to guess... There are lots of patches in your Config file included USB ones, I'm not sure you need to keep them all enabled since they do not all apply to your platform (!). I don't see why you would need the GenericUSBXHCI kext either.

Link to comment
Share on other sites

 Share

×
×
  • Create New...