Jump to content

E5440 - Sometimes boot hangs


Luiz Felpera
 Share

Recommended Posts

Hello mates,

 

First I wanna thank everyone helping here, most of the little knowledge I got about hackintoshs came from this forum.

 

I have a Latitude E5440 with Mojave 10.14.5 installed and following specs:

 

dGa0ySU.png

 

* Intel I5 4310U

* 8GB DDR3

* NVIDIA 720M (using -nv_disable=1)

* 240GB SSD SanDisk

* ALC3226 (ALC292) Audio codec

* External WIFI

 

I have almost everything working using attached config and kexts, installed nothing on /L/E and /S/L/E. Using clover R4945 (I've tried to install it with last version but Clover wasn't showing Install MacOS media)

 

Got 2 problems, first is sometimes I can't boot OS, stucked on busy timeout [0], (60sec): 'IGPU'  error. It's intermittent, it happens when I shutdown and then power on, it doesn't happens if just restart.

 

When this error happens I have to uncheck Inject Intel from clover, then boot, then restart and so it boots with Intel injected.

 

Second problem is if my laptop sleeps, it can't wake up, stuck on black screen.

 

I've tried to generate the debug file but it throws an error that I'm not connected to the internet, even if I am, so maybe it's a third problem lol:

 

q45QYfO.png

 

 

Screen Shot 2020-02-28 at 15.20.48.png

Kexts.zip config.plist.zip

Link to comment
Share on other sites

I saw this post but was scared to replace due its to Catalina.

 

Well, did as you said, replaced files on my Kext/Other and ACPI but now it wont boot anymore, stucked on attached error, even if disabling Inject Intel. Had to boot with USB stick with old kexts.

 

Don't know if it has to do with this error, but look at this screenshot, "Kilu: disabling IntelGraphicsFix on unsupported OS"

WhatsApp Image 2020-02-28 at 5.10.42 PM.jpeg

Link to comment
Share on other sites

  • Moderators

Nvidia gets disabled via SSDT-Disable-DGPU.aml

iGPU injection is under Devices/Properties, new way of injection using Whatevergreen.

As for the time, make sure you don't have any legacy kext installed or in other directory that might get loaded.

Update to latest Clover. Use this version and install with the following settings:

  • Install for UEFI booting only
  • Install Clover in the ESP
  • UEFI Drivers\Recommended Drivers
    • ApfsDriverLoader
    • AptioMemoryFix
    • AudioDxe
    • DataHubDxe
    • FSInject
    • HFSPlus
  • Additional drivers
    • PartitionDxe
  • Themes (Optional)
  • Install Clover Preference Pane (Optional)
Link to comment
Share on other sites

Oh GOD :(....

 

Updated Clover to r5103 from your link and replaced all files again. But stills on timeout IGPU.

 

I didnt install any on L/E or similar. 

 

Is there any log or screenshot I can send you tô assert Im doing things right? 

 

I found one post of you solving a similar problem: 

May I try these files? 

 

Link to comment
Share on other sites

  • Moderators

Clover folder found in the debug shows a really old bootpack and static DSDT that's causing your issue.

You're not using the files I've linked above on post 2.

 

Perhaps you're booting from the USB and it's pulling files from your USB installer....

Compare the files I have linked in post 2 and the Clover folder you attached with the debug, see the differences??

Link to comment
Share on other sites

 Share

×
×
  • Create New...