Jump to content

Anyone with Catalina and Bluetooth working with Lenovo/Foxconn 00JT494/ TH77H649.00 (BCM4350)


Recommended Posts

So I have a Thinkpad x1 yoga 20fr.
Everything works, even the touch screen, the last thing I need is bluetooth.
The Wifi works, bluetooth is detected, I can search for devices and I can pair, but the connection fails every time.

I tried the card with and without pin masking, at this point it works regardless. No crashes that I'm aware of. ASPM = 0.


I installed Windows just to check if the card itself works, and it does. I extracted the matching hex firmware from it (attached).

I tried building my own RAMpatches based on acidanthera's 2.5.2 version with said firmware added, the way I did it was using the firmware_update.tool in the build files and feeding it the firmware folder from Windows with all the hexes.
The update tool runs, I rebuild the kext, but I still see the wrong version firmware when I check the system info.


So what I tried then was just rename the attached hex as the one used by acidanthera, and replaced it in the firmware folder, rebuilt the kext in xcode... same thing, no difference.

I am suspicious that I'm actually not updating the firmware in the card, and that if I managed to get the attached one uploaded it would work fine.

Anyone has any clues of what I'm doing wrong or how can I force the injection of that firmware in Catalina? (I see a firmwareinjector but seems to be building itself for the rampatch version 2, I might be wrong though).

I see an extra_firmwares folder but I don't know how to use it.


I've attached my kexts. I've been reading for days and I haven't been able to find enough people with this card, the troubleshooting thread seems closed or I would've posted there.




2.5.2 with my firmwares.zip

Link to comment
Share on other sites

Just confirmed bluetooth working with the above firmware but this time in MacOS.

I booted into Windows, used bluetooth for a bit, streaming music kinda far from the receiver, no lags, no disconnects.
Booted into MacOS, bluetooth works with the firmware above loaded. I believe it's leftover firmware from when booted to Windows, so I don't know if it's being reuploaded by mac or not. Any way to check?

Link to comment
Share on other sites


  • Create New...