Jump to content
PayPal donations: [email protected] ×
komand

XPS 15 9560 nvme drive not showing during installation

Recommended Posts

Hello everyone,

 

I am trying to install MAC OS Catalina on my Dell XPS 9560, which I got a few days back. 

The problem I am facing is, the Disk Utility is NOT showing my system disk, which is  CX2-8B512-Q11 NVMe LITEON 512GB. It only shows the installation media (USB drive under disk utility)

 

I wiped the entire drive clean - didn't work.

Created  APFS & HFS+ partitions using ubuntu live disk - didn't work.

 

I tried to NVME related EFIs from other successful installations, but didn't work either. 

 

Can someone please help me here. This is my 3rd day and nothing seems to be working.  Thanks for any help on this. 

MySetup.png

Laptop.png

NVME.png

config.zip

Share this post


Link to post
Share on other sites

Thanks for your reply @Jake Lo. Tried with the config you gave but unfortunately, it didn't work.

Can you kindly check my Clover folder if I messed up something during my random tries in the last 2-3 days?

CLOVER.zip

Share this post


Link to post
Share on other sites

@komand Any reason why you have kexts in both /10.15 and /Other folders? Why not have them all in the same place (in /Other)? Or remove the ones from 10.15 if you already have them in /Other. Having them in both places is not a good idea. It's either one or the other. Not both. Also, are all those SSDTs in ACPI/patched really patched? You have a TON of them. I doubt you actually need all of them. Also, you should only have AML versions of those. Not sure if DSLs actually affect it in any way...but..you don't need those. :)) The files are decompiled anyway when you open them in MaciASL. So no need to keep both AML and DSL.

 

Also, you're using a driver (NvmExpressDxe) and a kext (NVMeFix) for NVME... I don't have an NVMe drive, but...is that intended? I'm just wondering whether or not it creates conflicts. Also, doesn't Catalina come with built-in support for NVME? Or is it just for specific models? I thought I read something about this somewhere else. But it was probably only for some specific models.

 

Anyway, if it doesn't show your NVMe drive in Disk Utility, that's probably a driver issue. So first the drive should be visible there, then we can worry about formatting it as APFS/HFS+.

 

Try without the driver in drivers/UEFI, ooor without the "Nvmefix" in /kexts. See if maybe they're conflicting with each other. And see if using any of them actually makes that drive show up in Disk Utility.

 

Also, not sure which Clover that is, but you don't need the "-64" suffix for your drivers anymore. Since Clover only comes in 64-bit by default. Actually, I would rename all of them just to be sure.

Share this post


Link to post
Share on other sites

@arsradu the clover file I posted here< i found the same on git for my exact same laptop mode. I think that's the reason it has multiple versions folder. I will clean it up for 10.15. DSL files were there because of the same reason, and I guess I was being lazy knowing they will not be picked anyway.

 

Quote

Also, you're using a driver (NvmExpressDxe) and a kext (NVMeFix) for NVME... I don't have an NVMe drive, but...is that intended?

Unfortunately I don't know the internals enough to tell for sure and would love to get some help here.

 

I will follow the steps you suggested and let you know how it goes.. Thanks for your reply on this.

Share this post


Link to post
Share on other sites

Yeah, so, if I'm not mistaken, Clover will first look into your specific folders. For example, if you're using Catalina, it will look under 10.15. The problem is, all your important kexts are in Other.

 

Now, the point of the multiple folders for each version is to allow you to separate your kexts for different versions of MacOS. But if you don't need different kexts for different versions, there's no point to keep them separated. That's why, when you use the same kexts for all versions, you put them in the Other folder (and remove them from the dedicated folder).

 

Also, if I'm not mistaken (I honestly don't know if this is accurate, so apologies if it isn't), if you use the custom folders (in this case 10.15) the Other folder (which you actually want in this case) will be ignored. So that's why I said either one or the other, not both. Cause I'm not sure if Clover will actually get to the Other folder if you already have kexts in 10.15. Or anyway, I think one of them will not be used. Again, I could be wrong.

 

As for NVMe, as much as I would love to help you, I can't, cause I don't have an NVMe drive... :( I'm sorry. The only thing I was suggesting is maybe...if you don't need both (which it could happen for some kexts) to maybe try only one or the other, in case they create conflicts.

Share this post


Link to post
Share on other sites

Tried the suggested methods, remove nvme kext, keep efi and vice versa. Remove both and check for native support. deleting the 10.14 folder from kext and so on.

Nothing seems to work :(

 

if I open the termial from the installer menu and run "diskutil list", other than showing my installer USb, it is also listing some 18 different disks in /dev/diskxx format. Not sure why that is so!! Really confused now.

CLOVER.zip

Share this post


Link to post
Share on other sites

Could you post the output of diskutil list here?

 

You still haven't renamed your drivers (for example NvmExpressDxe-64.efi to NvmExtressDxe.efi), and you still have kexts in both 10.15 and Other. :) 

 

Also, can you boot without those patched SSDTs? Cause what I would do is first remove them all, see if I can boot, then only add the ones I absolutely know I need.

Share this post


Link to post
Share on other sites

Please find the attached screenshots for diskutil output. 

Also, I got a KP when I moved all the kext together under kexts folder (screenshot attached). So reverted the changes.

WhatsApp Image 2020-06-01 at 16.28.34.jpeg

WhatsApp Image 2020-06-01 at 16.28.33.jpeg

WhatsApp Image 2020-06-01 at 16.28.33 (1).jpeg

Share this post


Link to post
Share on other sites

I don't know how moving kexts from Clover/kexts/10.15 into Clover/kexts/Other (not all in /kexts) would cause that error...but ok. :)) Anyway, I've never seen that disk issue in my entire life. It doesn't recognise any drives. Not just NVME. There's no EFI partition, nothing. Can you post a screen of your Disk Utility window? I'm guessing you're trying to boot off of the USB now?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...